OH3 Upgrade - Script (Java?) Problem

I can’t use the new possibilities to create scripts under OH3 - none of the three possibilities start on my Raspberry Model B from 2013 with OPENHABIAN .
i remember during upgrade process out of the corner of my eye a message like “current JAVA version cannot be installed; remain on JAVA xxxx”.
Unfortunately, I don’t know where the upgrade message logs are stored, so I can’t name the specific message right now.

What can I do to make the scripts run…?

None of which three possibilities?

There are four supported languages (five if you count Blockly) and they can each be used either through the UI or by writing them in text files. So which language are you trying to use and how are you trying to use it.

A couple of notes, you have to install addons for Python or Groovy support. Rules DSL and JavaScript/Blockly are supported out of the box. The Helper Libraries don’t work yet unless you pull from one of the PRs that have been submitted but not yet approved to update them for OH 3 support.

If the Java version were not correct (i.e. Java 11) openHAB wouldn’t run at all. So it’s most likely the case that you’ve made a configuration error or you don’t understand how the rules work.

Sorry, i mean any of these three:

… so it seems i’ve a problem with the “out of the box” - scripting languages …

OK, so what’s the answer to the second question. How are you trying to write the scripts? If you can get to that page OH is up and running and fully functional. So the most likely case is there is something wrong with the way you are trying to write the scripts.

You never actually stated what is wrong. They don’t trigger? You see errors when they are supposed to trigger? How are you trying to make them run?

The problem is really, that if i “click” on one of the three scripting methods nothing happens … the only thing is this small notification:


Maybe im really wrong with “JAVA” … how about "problem lies in ‘Javascript’ " (?)…

You need to look in openhab.log and report any errors you see when you click on it.

If you had the wrong Java, openHAB wouldn’t even start up. You’d never be able to get the the page where you can click the option.

Hi Rich,
thank you - as always - for your attempts to help!

o.k. - i’ve checked the openhab.log - here’s relvant piece:

… you see this warning three times 'cause i’ve tried all three script methods (blockly,ecma and ruleDSL).

Are you trying to go through myopenhab.org to create these rules or are you doing it on your local LAN.

Try clicking on the bottom right corner of the page where your account it listed. Then “sign out of this session” and then re-log into the session. You session may have become stale and it is no longer authorized to create rules or something like that.

Just curious, did you specify a name for your rule/script? OH tries to save the rule/script before opening the editor. And saving fails if the name is empty.

i can resolve that - for this test i have manually assigned the unique id and the name for each (scriping method)

But still no success?

What happens if you create a new rule, give it a name and save it? No triggers, no actions, no conditions. Are you able to save it?

i can’t create an new rule - when i press the “create script” Button, the nothing happens.

At the moment i think i see some mor (maybe contiguous) problems. I’ve started the “upgrade system” (sudo openhabian-config) and since 30min it stands at this stage:

o.k. a old raspy b+ can take its time, I will keep an eye on it …

oh, oh - still no lifesign:

Think i’ve found the problem (in the openhab.log):

I think this “Authentication fail” causes both the not working call of the scripting methods, as well as the failed “upgrade system” from the “openhabian-config”.

but I still do not really understand … i’m ssh-logged with this very “openhabian” - User, i’ve startet “sudo openhabian-config” … how can there be this “Authentication failed”?

What web browser are you using and can you try with another? Chrome or edge or safari…

I’ve tried with firefox and edge :scream: … with none of them i can go any further … btw: ssh is per “putty”