OH3 Web UI in Safari Switch not working

Hi all,

recently I upgraded from openhab 2.4 to 3.0. So far so good after fixing a lot of issues I’m still struggling with the web ui. Both on iOS as well as on MacOS the switches are not working properly.
Whenever I try to switch the light on it’s switching back to off automatically. Is this an issue related to Safari? What can I do to fix it? Tweaking my sitemap?

sitemap test label=“Mini Casa” {
Frame label=“Licht Erdgeschoss” {
Switch item=Licht_Dunstabzug
Switch item=Licht_Kuechenschrank
Switch item=Downlight_Kueche
Switch item=Licht_Gemaelde
Switch item=Licht_Sofa
Switch item=Hue_Esstisch
Switch item=Hue_Lightstrip_EG
Slider item=Downlight_TV_dim
Slider item=Downlight_Kamin_dim
Slider item=Downlight_Essen_dim
Switch item=Licht_Treppe_OG
Switch item=Downlight_Flur
Switch item=Licht_Garderobe

Can you confirm if the light really switches off,or is it the display on your UI?
Your events.log could confirm what happens at openHAB end.

And you are you talking about new MainUI , not BasicUI+sitemap?

Hey rossko57,

well I was lacking some information. The lights are not switching ON/OFF at all. I try to switch my lights the switch in BasicUI is flipping back to OFF again. Although in the log file I can see that the event was triggered. I guess these are two issue. But why is the BasicUI not behaving as expected in Safari?
Any clues?
Thanks, Manuel

Alright, that’s a clue hat maybe the command has not worked at all. In which case the UI might be telling you the truth - your Item is still OFF after a failed attempt to turn ON.

Might we see your events.log as well?

Shame on me :frowning:
I changed the knx config recently which caused a connection loss to my knx IP interface.
Now I’ve commented almost every line…and it’s working again.

That’s my new config now:

Bridge knx:ip:bridge [
// portNumber=3671
// localIp=“”,
// readingPause=50,
// responseTimeout=10,
// readRetriesLimit=3,
// autoReconnectPeriod=60,
// localSourceAddr=“0.0.0”
] {
Thing device generic [
// address=“1.2.2”,
// fetch=true,
// pingInterval=300,
// readInterval=0
] {

Many thanks…I guess it should work now. For other issues I’ll open a separate thread.