OH3 with openHABian - Installation got stuck

Tags: #<Tag:0x00007efecdcbe3f0> #<Tag:0x00007efecdcbe288> #<Tag:0x00007efecdcbe148>

Hi everbody,

for various reasons I decided to install OH again from scratch. And since I am a beta/early adapoter kind of guy I wanted to give OH3 a shot. But I got stuck.

And here is what I did:

  1. Flashed the lastest openHABian image (1.6) on a SD card.
  2. Put the SD card in my Raspberry Pie 3 (and waited)
  3. ssh’ed to my RP
  4. “sudo openhabian-config”
  5. “select branch” -> master"
  6. A Popup comes up -> “continue”
  7. Another Popup comes up that asks me if I want to step back? I choose “master” again
  8. Installation happens
  9. “sudo openhabian-config”
  10. 40 -> 42 Upgrade to openhab 3
  11. backup -> skip (since its a new start anyway)
  12. Java 11 gets installed automatically
  13. Popup: Do you really want to install openhab 3? -> continue

Then it stops on "Installing selected openHAB version… I waited three hours.

Have I done something wrong?

It should work. Enable debugmode=maximum in /etc/openhabian.conf and try again.
Read the debug guide.

Don’t advise others to do trial and error poking please unless you’re sure it’s the solution.

4 Likes

Thank you.
I have set debugmode=maximum and repeated the steps above.
At Step 10. “40 ->42 Upgrade to opnehab 3” I get an error.


Before that it said:


I can access openHAB 2 (not 3!) via my RPs IP.

No screenshots but a complete text log please. Record in your terminal.
openhab3_is_installed does not mean it’s installed, it is just a function name being executed.

I have done everything again. This time I had to answer some yes/no questions and it worked, even if I have the exact same as mentioned above.
Thank you. At least I learned at this journey. :slight_smile:
Even if I dont know what went wrong the first couple of times.

There were code fixes in the meantime that’s why it worked this time.

Hi.

In my case it was the same, as you described. Starting hangs because fo java.
After i installed java 11 (openhabian configuration tool - 40 openHAB related- 45) Zulu 11open JDK 32-bit it works fine.

Kuli