OH3 Zwave Configuration Parameter Options Displayed As Numeric Only

  • Platform information:
    • Hardware: Raspberry Pi 3 Model B Rev 1.2
    • OS: Raspbian GNU/Linux Version 11
    • Java Runtime Environment: Zulu11.52+13-CA (build 11.0.13+8-LTS)
    • openHAB version: 3.2.0 (Build)
  • Issue of the topic: EVERY Zwave Device I have is showing a Numeric Value for Configuration Parameter options as opposed to ANY Textual Representation. I am running a brand new installation of OpenHabian which installed openHAB 3.x. I plugged my Zwave/Zigbee stick in of which my Things had been discovered in a previous 2.x version for what it’s worth. Also the only OS updates I have done is the installation of NTP via apt.

A screenshot of what you are seeing would be informative because a lot of Zwave parameters are numbers.

Also logs, particularly errors or warnings from the Zwave binding.

I’m not seeing screaming errors. Below Nodes 6, 15, 1nd 16 are indeed offline

openhabian@openhabian:/var/log/openhab $ grep -i warn openhab.log
2022-01-01 18:44:14.761 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception:
2022-01-01 18:44:25.789 [WARN ] [ve.internal.protocol.ZWaveController] - NODE 16: Restore from config: Error. Data invalid, ignoring config.
2022-01-01 18:44:25.791 [WARN ] [ve.internal.protocol.ZWaveController] - NODE 6: Restore from config: Error. Data invalid, ignoring config.
2022-01-01 18:44:25.819 [WARN ] [ve.internal.protocol.ZWaveController] - NODE 15: Restore from config: Error. Data invalid, ignoring config.
2022-01-01 18:46:51.961 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 6: Device discovery could not resolve to a thingType! Manufacturer data not known.
2022-01-01 18:47:57.038 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 15: Device discovery could not resolve to a thingType! Manufacturer data not known.
2022-01-01 18:49:49.742 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 16: Device discovery could not resolve to a thingType! Manufacturer data not known.
openhabian@openhabian:/var/log/openhab $ grep -i error openhab.log
2022-01-01 18:44:25.789 [WARN ] [ve.internal.protocol.ZWaveController] - NODE 16: Restore from config: Error. Data invalid, ignoring config.
2022-01-01 18:44:25.791 [WARN ] [ve.internal.protocol.ZWaveController] - NODE 6: Restore from config: Error. Data invalid, ignoring config.
2022-01-01 18:44:25.819 [WARN ] [ve.internal.protocol.ZWaveController] - NODE 15: Restore from config: Error. Data invalid, ignoring config.

It looks like your devices are not fully added in to OH yet. As a result, OH can read the config data that they are sharing with the controller, but it cannot look up the device in the device database so it doesn’t know how to convert that config into UI friendly formats. You say that all these devices previously worked with OH2 so all the info should be in the zwave database. Check in OH_CONF/userdata/zwave directory. Do you see xml files for each of the devices?

Node 6, 15, and 16 have not been on the wire since I loaded OpenHabian and OpenHAB 3.x so I expect those errors, sadly :frowning:

Are 6, 15 &16 all the same type of device? Are they truly offline or just showing unknown device?

One thing to check is the last approval date in the database for the devices. When a device is being modified it is removed from the binding until it is approved and a new binding is compiled. If the device you are having problems with is the one from the picture, it was changed in mid November. It should have made it into the release, but you never know. Also the changes that were made could be related to your config parameters changing.

In order of increasing effort, my suggestions to try

  1. try to simply delete the thing from the UI and use the inbox scan to get it back. If just parameters were changed in the database this could work.
  2. Exclude the device using the protocol in the device manual and reinclude while in scan mode
  3. Get the latest 3.3 zwave snapshot and put in addons (remove the old zwave binding first).

Bob

I think my picture and warning post has been misleading. In response to Rich request for snapshot and warnings/errors I posted the picture of only 1 of my devices. Please note that EVERY zwave device shows ONLY Numerical values for Configuration Parameters. I know for fact that some of those should be at least enumerated values in their display. The one I posted I expect to be a good example of what I am seeing, but again, EVERY device displays as such. The scrape of warnings/errors yielded ONLY those nodes that I do indeed have offline and sitting in a box. They were previously discovered but I had to remove them temporarily so I don’t feel they have relevance to the conversation, albeit I ‘could’ be wrong :), but again I don’t believe they do.

Do we think that the devices needed to be discovered by OH3 possibly? When I plugged the dongle in and added the binding they immediately showed up in the Inbox. I am also able to add them in the model and control them. It feels like the only issue is the lack of any Visually Textual values of expected configuration parameters.

That all being said, do you feel the suggested steps above are still advisable?

Thank you for your help,
Jim

No. Those steps will not help you

With that background I would suggest you cross reference the parameters you think should not be a number with the configuration shown in the zwave DB for that device. Zwave only sends numbers (in Hex), so there would have to be a translation from a non-number to a number somewhere. The device in the picture above has this .xml in the binding. zw4006_0_0.xml (10.8 KB) For instance Parameter 3, the “1” is short for “Manual” and Parameter 4, the “0” is short for “disabled”, etc.

Bob

IIUC, OP is complaining about missing config param UI options:

[screenshot: openHAB 3.2.0 Build #2554, NAS-PD07Z NEO Coolcam PIR 5 in 1]

@cj179

  1. Are you sure that there should be a radio button selection etc. for your specific devices (-> check the Z-Wave database entries)?
  2. Try a different browser.

Ok thanks. On a different wavelength.

Bob

@Ap15e

Everything looked as expected in OH 2.x but not in OH3 thus far. I have attempted the operation in Edge, Chrome, and Brave to no avail.

Regarding checking the Z-Wave database entries, forgive my ignorance but exactly how would you like me to go about checking that?

Probably need @Ap15e to confirm since I have not been concerned with whether the parameter is set by number or menu option. However, on a quick DB review the menu appears if the “limit to options” is set to “true”. On the Device Parameter tab this shows up as a red funnel versus a black funnel. Black, if there are options, but “limit to options” is false. To change the configuration, you will need write access.

As it turns out your example device is not set-up to provide the menu option;


Whereas @Ap15e 's example is;

My guess is that the DB for device was changed along the way to just use numbers (as noted above the last edit was mid-november 2021). You’ll need to check the other devices as suggested above.

Bob

Parameters
3
4
5
6
13
14
19
should be set to “limit to options”.

I may have just come to understanding to what you guys mean. Is it possible that the “limit to options” have all been reset in my version of the database? If I’m understanding correctly what @apella12 and @Ap15e are implying as to the functionality then it would appear the DB installed with my OpenHabian install is trashed.

That is a little extreme as it is basically a UI format issue.

However, you are right. Someone along the way changed the “limit to options” between your version of 2.x and 3.2. If your one device shown above is the only one with the format issue and you don’t have DB access, maybe you can sweet talk @Ap15e to making the changes he identified. Otherwise, you can either live with it (Should be a one-time issue) or read the blog on the DB link above (to register and open a ticket for write access) and make the changes yourself.

If the DB is changed, you will need to follow step 3 in post #6 in about a week after the changes are made. It should work with your otherwise 3.2 installation.

Bob

There might be a reason why ‘limit to options’ was removed. So I’m a bit reluctant to change it back.

It appears to be every device I own. I’ll step through each and every one, about 20 or so, and advise if any act appropriately

There are two angles to “appropriately”. One angle is how you want it to appear and the other is how it is set-up in the DB to appear (red or black funnel). If it is not appearing how it is setup in the DB (Red funnel, but number only) that would point to a problem with OH or the binding.

Bob

1 Like

Very good point indeed @apella12. I have not previously traversed my way to the database to view the funnels. Can you point me down the right path to do so and I will reply with an educated “appropriate” response. :slight_smile:

Thanks!
Jim

Database is here. Find device, go to parameter tab. I think you can view without registering, but if not do that. You do not need write access to view the funnels, just to change them.

Bob