OH4 does not publish messages to MQTT

Good afternoon to all!Set up a bundle of MEL Cloud and Openhab. I want to transfer the received values to MQTT, and OH4 does not transmit them. If you change the values via MQTT Explorer, OH4 accepts them from MQTT. Why doesn’t OH4 post messages?

No idea.

Please show your configurations.

UID: mqtt:topic:719c077556:daa19c3257
label: MQTT_mitsubishi_conditioner
thingTypeUID: mqtt:topic
configuration: {}
bridgeUID: mqtt:broker:719c077556
  - id: MQTT_mitsubishi_power
    channelTypeUID: mqtt:switch
    label: MQTT_mitsubishi_power
    description: ""
      commandTopic: mitsubishi/cond/POWER
      retained: true
      postCommand: true
      stateTopic: mitsubishi/cond/POWER

I thought there were errors with the formats, I tried switching the speed 1, 2, 3. This did not help either. I didn’t see anything unusual in the logs.

2023-09-11 19:30:36.126 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'Mitsubishi_speed' changed from 3 to 2
2023-09-11 19:34:36.725 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'Mitsubishi_speed' changed from 2 to 3
2023-09-11 19:36:36.937 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'Mitsubishi_speed' changed from 3 to 1

Shoudn’t be the commandTopic like

commandTopic: cmnd/mitsubishi/cond/POWER

and the stateTopic

commandTopic: stat/mitsubishi/cond/POWER

At least in my config it’s like this

  - id: Eingang
    channelTypeUID: mqtt:switch
    label: Eingang
    description: ""
      commandTopic: cmnd/tasmota_aussen/POWER
      stateTopic: stat/tasmota_aussen/POWER

1 Like

Your thing represents the power switch, but your log is related to a numeric item.

Maybe post an example that belongs together.

If you say: OH does not post the message
How have you checked this? Is the device not reacting on the message or have you checked via mqtt explorer, if something is posted?

MQTT messages work in one direction, from MQTT to Openhab. I tried using MQTT Explorer to send ON OFF values to themes and Item responds to them (the air conditioner turns on and off). If you change the values of Item in Openhab, then it does not come to MQTT. I can’t understand why.

Thanks! I divided the topics and it worked.