On / Off switch for Hue Color Bulb not working


how can I switch my Hue Color Lamp on and off? I know it is supposed to be a switch linked to the “color” channel. But whenever I try to create a point (=switch) for my equipment (the bulb) I can only switch it ON. The OFF switch is not working.

My bulb is of thing type 0210 (Extended Colour Light). What am I doing wrong here?

Doesn’t have to be. Color type Items accept ON/OFF commands.

You just send commands ON or OFF from a rule.

or represent your Color type Item in your UI with a switch type widget, that will send commands ON or OFF.

I don’t know how much of this still relevant to hue type 210

there they used colortemperature channel for switching.

Just to note that I looked at that old thread and noticed that whilst the OP was using a 0210 bulb he was linking to a ‘switch’ channel. The 0210 bulbs should work with On/Off, Brightness and Color all linked through the color channel.

For OH 2.5 I used the following in an items file:

Group                      Light_FF_CR_Downlight_01                     "Cloakroom Downlight 1"                       <light>
Switch                     Light_FF_CR_Downlight_01_Switch              "Cloakroom Downlight 1 On/Off"                <switch>         (Light_FF_CR_Downlight_01, Grp_Lights_FF_CR_Ceiling_Switch)        {channel="hue:0210:00178866094c:hue_bulb_ff_cr_dl01:color"}
Dimmer                     Light_FF_CR_Downlight_01_Dimmer              "Cloakroom Downlight 1 Brightness"            <slider>         (Light_FF_CR_Downlight_01, Grp_Lights_FF_CR_Ceiling_Brightness)    {channel="hue:0210:00178866094c:hue_bulb_ff_cr_dl01:color"}
Color                      Light_FF_CR_Downlight_01_Color               "Cloakroom Downlight 1 Colour"                <colorpicker>    (Light_FF_CR_Downlight_01, Grp_Lights_FF_CR_Ceiling_Color)         {channel="hue:0210:00178866094c:hue_bulb_ff_cr_dl01:color"}
Dimmer                     Light_FF_CR_Downlight_01_ColorTemperature    "Cloakroom Downlight 1 ColorTemp"             <slider>         (Light_FF_CR_Downlight_01, Grp_Lights_FF_CR_Ceiling_ColorTemp)     {channel="hue:0210:00178866094c:hue_bulb_ff_cr_dl01:color_temperature"}
String                     Light_FF_CR_Downlight_01_Alert               "Cloakroom Downlight 1 Alert"                                  (Light_FF_CR_Downlight_01)                                         {channel="hue:0210:00178866094c:hue_bulb_ff_cr_dl01:alert"}
Switch                     Light_FF_CR_Downlight_01_ColorLoop           "Cloakroom Downlight 1 Effect"                <switch>         (Light_FF_CR_Downlight_01)                                         {channel="hue:0210:00178866094c:hue_bulb_ff_cr_dl01:effect"}

For OH 3, I do the same but via the UI.

What do you see in the logs when you toggle the switch.

Thank you for your advice. I looked at my log and not only this switch, but also another switch (which I created without linking it to any channel) are turning ON but they DO NOT turn off (according to my log).

This is what my “Testswitch” looks like (and all the other switches that I tried)


@rossko57 you were right, that did solve my problem.

First, I had to go “Settings → API-Security → (show advanced) enable basic auth & implicit user role”. After I saved this, I changed my address (for openHab web interface) from “http” to https". Now, my browser correctly transfers the command and the item switches off… I would not have guessed that.