One wire binding - startup problem

  • Platform information:
    • Hardware: Raspberry Pi 3
    • OS: _Raspbian Linux raspberrypi 4.19.75-v7l+
    • Java Runtime Environment: _OpenJDK version 11.0.3
    • openHAB version: Openhab 2
  • Issue of the topic: One wire Binding startup problems Thing DS18x20

Dear openHAB community,

I’m trying to connect some DS18X20 via OneWire Binding to opanHAB.
As I’m a newby I configure in the Paper UI.
The Sensors are visabel at the owhttpd and owserver (owdir).

The OWServer ist online:

I don’t get the Things for the Sensors running:

I have tried out different addresses, none of these did lead to success:

81.9… is the identifier for my DS9490R. I guess this is not required in the address.

Any idea what I’m doing wrong?

Best Regards,

Java Runtime Environment: _OpenJDK version 11.0.3
openHAB version: Openhab 2

openHAB2 requires Java 8.

Some would say you should have used the openHABian image to make things easier.

Others would say openHAB3, which requires Java 11 will be released this week. RC2 is currently available for testing.

That should be correct. On the other hand: why don‘t you use discovery? If the owserver thing is configured correctly, all sensors should be automatically discovered.

1 Like

Hi Guys,

discovery didn’t show anything.

I’ve made an update of openhub.
Great software, everthing works perfect now.
Even all of the adress variants I’ve tried out where working.

Thanks to you for the quick help and thanks to the openHab developers for the gorgeous code!
I’m having a lot of fun using this Product - even as someone having low software experience.

Best Regards

1 Like