Only one of three Hue Bulbs responds

Recently i’ve recived a Philips Hue Starter Kit, but only the white, because everything else was a bit to expensive…
Annyway, after a bit of reading and trying I got it working, but only for one of three Bulbs. But I did everything the same way for every Bulb, or at least I think so.

First I got the Hue-Thing here:

Bridge hue:bridge:Serialnumber [ ipAddress=“” ] {
0100 Lampe_Lukas_Decke [ lightId=“1” ]
0100 Lampe_Essbereich_Decke [ lightId=“2” ]
0100 Lampe_Sofa_Decke [ lightId=“3” ]

and than I got the Hue Items

Switch Lampe_Lukas_Decke_Toggle       { channel="hue:0100:1:Lampe_Lukas_Decke:brightness" }
Dimmer Lampe_Lukas_Decke_Dimmer       { channel="hue:0100:1:Lampe_Lukas_Decke:brightness" }

Switch Lampe_Essbereich_Decke_Toggle  { channel="hue:0100:1:Lampe_Essbereich_Decke:brightness" }
Dimmer Lampe_Essbereich_Decke_Dimmer  { channel="hue:0100:1:Lampe_Essbereich_Decke:brightness" }

Switch Lampe_Sofa_Decke_Toggle        { channel="hue:0100:1:Lampe_Sofa_Decke:brightness" }
Dimmer Lampe_Sofa_Decke_Dimmer        { channel="hue:0100:1:Lampe_Sofa_Decke:brightness" }

If anybody could tell me why only the Sofa-Bulb is working, I would be happy.

Thanks Lukas

I’m using Hue devices also but used PaperUI for setup. Went smooth and everything is working correctly and I’d suggest you to do the same. But if you want to do it with config files here’s a few questions to get started:

What is “Serialnumber”? If I have understood the docs correctly this an ID number which should be the same in your item config.

Was the authentication successfull? Can’t see any userName config option after your ip number.

Have you confirmed that all the other bulbs are working correctly? For example with Hue app in your smartphone?

What does the logs say? Have you turned on debug logging?

Your channels may be wrong. I will look at my config when I get home.

I also understood it that way, but with the 1 with it beeing the first Bridge, I think, it isn’t working. But if I copy the Serialnumber given by paper UI it is at least able to controll the Sofa Bulb.

I didn’t set anny Login information for Hue, so I wouldn’t know what to type there.

With Hue App and thru Paper UI every Bulb is working, so I think everything is fine with the Bulbs.
I tried it “the coding way” because it is the only way so far I found to setup sitemaps for the App. Im still pretty new to openHAB, but givin my best to read the documentation first :smiley:

To the Logs, there are no Errors printet, but if I change the Bulbs thru the Hue App it is printing:

2018-11-08 23:36:16.630 [vent.ItemStateChangedEvent] - hue_0100_001788670b30_Lampe_Essbereich_Decke_brightness changed from 11 to 100

2018-11-08 23:36:16.662 [vent.ItemStateChangedEvent] - Lampe_Sofa_Decke_Dimmer changed from 22 to 100

And if I flipp the switch in the openHAB App it is printing:

2018-11-08 23:36:31.186 [ome.event.ItemCommandEvent] - Item 'Lampe_Essbereich_Decke_Toggle' received command ON

2018-11-08 23:36:31.208 [vent.ItemStateChangedEvent] - Lampe_Essbereich_Decke_Toggle changed from OFF to ON

2018-11-08 23:36:34.734 [ome.event.ItemCommandEvent] - Item 'Lampe_Essbereich_Decke_Toggle' received command OFF

2018-11-08 23:36:34.748 [vent.ItemStateChangedEvent] - Lampe_Essbereich_Decke_Toggle changed from ON to OFF

But nothing happens…

Maybe the sitemap might be interessting to, but I don’t think, that I made the mistake here.

sitemap Test label= "Test Overview"
        Text item= Temperature  
        Switch item= Lampe_Sofa_Decke_Toggle icon="light" label="Licht Sofa"
        Switch item= Lampe_Essbereich_Decke_Toggle icon="light" label="Licht Esstisch"
        Switch item= Lampe_Lukas_Decke_Toggle icon="light" label="Licht Lukas" 


Here is my thing line:

Bridge hue:bridge:00123456780b [ ipAddress="" , userName="abcdefg" ]  //no hostname

0220 8 [ lightId="8" ] //Kitchen


Dimmer	Light2_Dimm "2 Over Sink Right [%d %%]" (gKitchenSink) { channel="hue:0220:00178827d80b:2:brightness" }

I think you were missing a few things, compare to mine. This works.

Ok, thanks, will have a look on it, when I’m Home.
From a first look I see, that you have a userName written there. Where do I find my username, because I don’t remember adding one, while configuring Hue. :thinking:

After saving your hue.things file you have look at logs. It asks you to press the pairing button on your hue bridge.

==> /var/log/openhab2/openhab.log <==

2018-11-09 13:10:08.613 [INFO ] [binding.hue.handler.HueBridgeHandler] - Creating new user on Hue bridge 192.168.X.X- please press the pairing button on the bridge.

After pressing the pairing buttons again watch your logs

==> /var/log/openhab2/openhab.log <==
2018-11-09 13:10:28.674 [INFO ] [binding.hue.handler.HueBridgeHandler] - User 'blahblahblahXHasdhasdg' has been successfully added to Hue bridge.

And theres your username.

FYI looks like that the “Serialnumber” part in hue thing configuration can be anything. I tried “livingroom” and it works. I initially thought that it had to be a number:

Bridge hue:bridge:livingroom [ ipAddress="192.168.X.X", userName="blahblahblahXHasdhasdg" ] {
    0100 bulb1 [ lightId="1" ]
    0100 bulb2 [ lightId="2" ]

So now my item configuration looks like:

Dimmer HueTest1 "Hue Test"  <light> (gHueLights) { channel="hue:0100:livingroom:2:brightness" }

I think it lessens the confusion when linking items and when you have multiple bridges.

Also I believe the serial number keeps things from showing in the inbox after configuring your things file.

Ok, at first, for some reasen the Hue bridge in the PaperUI now went from “Online” to “UNINITIALIZED - HANDLER_MISSING_ERROR” didn’t know I changed something while I was away, but annyway.

Unfortunatley if I safe the .things file again it is saying nothing but updated the hue.things and if I press the button unfortunatley nothing is happening too.
I then tried to get a Username with the Ip-Adress/debug/clip.html and copy pastet the username from there, but it is also not working.

Maybe I should just get rid of the Binding and every File and start all over again? And try to make every step “the right way” now?

1 Like

You can try deleting all related files and restarting oh. Might be a good option to delete tmp and cache also while doing a restart. After that you can start from scrach.

While resetting the Philips Hue binding and deleting the Cach I somehow managed to destrox something on the Pi. Or it was just bad Timing.
Unfortunetly I’m not Home this weekend so there is no time to search for the Error…
But I will write here if I get it to work eventually.