Only part of my items show up in Google Home

Tags: #<Tag:0x00007efec88bf358>
  • Platform information:

    • Hardware: Raspberry pi 3B+
    • OS: Raspbian 10
    • Java Runtime Environment: openjdk 11.0.6
    • openHAB version: 2.5.9 Release
  • Issue of the topic:
    Hi all,
    Google home is linked (even though I had to re-do the link like 5 times) and working.
    I can control some of my device with google home. But not everything that is defined in my items files is showing.
    In the following item definitions below, I can see and control the first (Store du salon) and the two lasts (Led de la pergola, Miroir dressing) from Google home and via voice control.
    But not the other items, which on the other hand work fine from the openhab paper ui.
    I tried “ok google sync my device”, which is what did make the first items appear in the first time, but the others won’t show at all.

    • Items configuration related to the issue
      Rollershutter RFXCOMRFYSomfyStoreSalon_Shutter "Store du Salon" <blinds> [ "Blinds" ] {channel="rfxcom:rfy:3f440f85:shutter"} Rollershutter RFXCOMRfyActuator1_Shutter "Store de la terrasse" <blinds> [ "Blinds" ] {channel="rfxcom:rfy:7b20321b:shutter"} Rollershutter RFXCOMRfyPergola_Shutter "Toit de la Pergola" <blinds> [ "Blinds" ] {channel="rfxcom:rfy:629e34fd:shutter"} Rollershutter RFXCOMRfyActuator_Shutter "Led de la Pergola" <blinds> [ "Blinds" ] {channel="rfxcom:rfy:29924158:shutter"} Switch PriseMiroir_Command "Miroir dressing" [ "Switchable" ] {channel="rfxcom:lighting2:867574b8:4553594_1:command" }

Hi @hyzteric,

Please put code in code blocks using the “</>” menu icon, so that it’s easier to read. As I understand it, these two items are not working in Google Assistant. I assume everything is in the same items file:

Rollershutter RFXCOMRfyActuator1_Shutter “Store de la terrasse” [ “Blinds” ] {channel=“rfxcom:rfy:7b20321b:shutter”}
Rollershutter RFXCOMRfyPergola_Shutter “Toit de la Pergola” [ “Blinds” ] {channel=“rfxcom:rfy:629e34fd:shutter”}

The first thing I’d check is that the quotation marks around "Blinds" weren’t converted to smart quotes (“”). I can’t tell that from what you posted.

If the quotation marks are correct, then I would guess that it’s still an issue with syncing Google Assistant. I would try removing the tags for the non-working items AND one of the working items, then syncing GA again. You should see the working item disappear, confirming that the sync works. Then add each item back one-by-one and sync.

While we’re talking about Google Assistant, please be aware that you are using an outdated method that is no longer in development. Per the current documentation, you should instead use metadata. Tags continue to work for legacy reasons, but they aren’t recommended going forward.

Rollershutter RFXCOMRfyActuator1_Shutter “Store de la terrasse” {channel="rfxcom:rfy:7b20321b:shutter", ga="Blinds"}

As above ^^^

Rollershutter       RFXCOMRFYSomfyStoreSalon_Shutter  "Store du Salon"              { ga="Blinds", channel="rfxcom:rfy:3f440f85:shutter"}
Rollershutter       RFXCOMRfyActuator1_Shutter        "Store de la terrasse"        { ga="Blinds", channel="rfxcom:rfy:7b20321b:shutter"}
Rollershutter       RFXCOMRfyPergola_Shutter          "Toit de la Pergola"          { ga="Blinds", channel="rfxcom:rfy:629e34fd:shutter"}
Rollershutter       RFXCOMRfyActuator_Shutter         "Led de la Pergola"           { ga="Blinds", channel="rfxcom:rfy:29924158:shutter"}
Switch              PriseMiroir_Command               "Miroir dressing"             { ga="Switch", channel="rfxcom:lighting2:867574b8:4553594_1:command"}

Thank you @rpwong and @denominator, the quotes were correct and it worked like a charm with the up to date metadata.

I started with metadata but then I found an example with tags on this forum and it started working that way so I went on from that.

I am new, obsiously, to openHab and I think it is brilliant, but the documentation sometimes makes too much assumption for beginners. I’ve been using two vera boxes and one domoticz boxes in the past, so I’m a bit used to how it should work. But it does not come easy. However, I don’t regret switching to openHab as I can see the huge potential.

I tried to edit my question with the “</>” menu icon but it does not work like in your reply. :-/

1 Like

Welcome to openHAB it has been a learning curve for me too. OH3 is a totally different UI so a whole new one coming up.

I think @rpwong was suggesting using code fences around you code in the forum to help format it to make it easier to read. Put 3 ``` before and after your code.

2 Likes

Yep, that’s what I meant. There are a variety of ways to do it, and all of them make it easier to read lines of code.

@hyzteric, glad you got it figured out. I am curious why the tags weren’t working, but no reason to worry about since metadata is better.

2 Likes