Only UIs not starting after reboot

After upgrading to the newest snapshot version (to get my zwave devices working) everythign seemed fine. But after the reboot I have a strange situation: The UIs are not starting (Problem accessing /basicui/app) but all the other things work (rules etc.). When I delete the /cache and /tmp files and restart via systemctl start openhab2-service then it works - until the next reboot of my Raspi and then I’m in the same state. There is nothing special in the openhab2.log (all output from thing update and rules is shown correct). Just the UIs are not there (PaperUI, HABadmin etc.). Thanks for help in advance.

Actually there is something strange in the logs all bundles are uninstalled
Can anyone help?

2017-10-19 11:43:45.672 [INFO ] [internal.service.FeaturesServiceImpl] - reflections/0.9.10.v20160429-1435
2017-10-19 11:43:45.729 [INFO ] [internal.service.FeaturesServiceImpl] - swagger-jersey2-jaxrs/1.5.8.v20160511-1038
2017-10-19 11:43:45.934 [INFO ] [internal.service.FeaturesServiceImpl] -
2017-10-19 11:43:46.164 [INFO ] [internal.service.FeaturesServiceImpl] - Stopping bundles:
2017-10-19 11:43:46.171 [INFO ] [internal.service.FeaturesServiceImpl] - org.apache.servicemix.bundles.not-yet-commons-ssl/
2017-10-19 11:43:46.247 [INFO ] [internal.service.FeaturesServiceImpl] -
2017-10-19 11:43:46.312 [INFO ] [ll.impl.action.osgi.CommandExtension] - Unregistering commands for bundle
2017-10-19 11:43:46.639 [INFO ] [internal.service.FeaturesServiceImpl] - Refreshing bundles:
2017-10-19 11:43:46.642 [INFO ] [internal.service.FeaturesServiceImpl] - com.eclipsesource.jaxrs.provider.swagger/ (Bundle will be uninstalled)
2017-10-19 11:43:46.645 [INFO ] [internal.service.FeaturesServiceImpl] - (Bundle will be uninstalled)
2017-10-19 11:43:46.661 [INFO ] [internal.service.FeaturesServiceImpl] - com.jayway.jsonpath.json-path/2.1.0 (Bundle will be uninstalled)

The bundles you see getting uninstalled is ok, I believe. Same on my box, I think it happens when Karaf reads services/addons.cfg. Either way, all these bundles (plus those in addons) get (re-)installed afterwards.
On missing UI, there’s this issue on PaperUI, but it might as well
affect other UIs. See if you can directly access UI as described there.

Unfortunately all URLs are not working, also when access directly. The bundles seem to be deinstalled, that is a message during operation

2017-10-19 10:26:00.293 [WARN ] [.core.transform.TransformationHelper] - Cannot get service reference for transformation service of type JSONPATH

Meanwhile quite frustrated I installed everything new from scratch - same problem - The first time openhab2 starts perfectly, as soon as I restart it it hangs with “GUIs beeing installed”. When I remove the content of the openhab/cache directory and openhab/tmp it starts again, but I get problems with my persistamce store etc. Isn’t there anyone who can help?

I added EXTRA_JAVA_OPTS="-Dosgi.clean=true …" in /etc/default/openhab2 to auto-clean the cache on each startup, so at least I don’t have to do that manually (and you shouldn’t be starting OH often anyway).
On un-installing bundles …I also setup from scratch. I noted that I had most of the features installed twice.
See in Karaf console if that applies to you as well.
I had remote=false in addons.cfg but it seems OH did still install the bindings from the repo in addition to those from the .kar (which you get when you install openhab2-addons package).
I did not install the package this time and set remote=true, no more duplicate features since.
Might make a difference for your problem or might not, but worth a look.

Thank you fvery much or that tip. Actually it worked right with removing the openhab2-addons package (apt-get remove …) I tried to add the Dosgi.clean=true beforehand but that didn’t work. Also I didn’t touch my addons.cfg, but I have the “Access Remote Repository” set to ON in the Paper UI. Now my zWave binding is not working but I will post this as another issue. Thanks again!