Hi All,
Does anybody have problem with install habian on raspberry pi3. I tried 5 times with different versions, but always Node.js install failed and habian is not installed.

I have Openhabian on multiple machines. The big question is (probably) whether you are hitting the net-installation or the full installation link on your download. There is a whole series of messages in the (HUGE) Openhabian thread pointing AWAY from using the net-installation image.

The ua-netinst openHABian image is not provided any longer. However just to be clear: it was never a bad choice, it just had its limitations.

@stanislav3885 please try to describe your problem better, clearer and with the right details. A big help would for example be a copy of your first-boot.log (the installation progress you probably saw something about nodejs in).

I will happily defer to @ThomDietrich from here…:slight_smile:


I tied with three different versions v.1.3 - this file – openhabianpi-raspbian-201706161358-git7ff273e-crc00389b9f.img.xz
v.1.2 — openhabianpi-raspbian-20170318-git9767b24-crc9616e8a1.img.xz
and with this netinstaller-- openhabianpi-ua-netinst-20170317-gitbd31755f-crc88a5ae46.img

I will provide you with log later because I don’t save it I will try to install it once again and if problem is occured again will bring the log here. Thanks a lot in advance

Here is the log from installation process. Every when i try this happened:

2017-04-10_09:58:50_UTC [openHABian] Starting the openHABian initial setup. This might take a few minutes.
2017-04-10_09:58:50_UTC [openHABian] If you see this message more than once, something went wrong!
2017-04-10_09:58:50_UTC [openHABian] Storing configuration... OK
2017-04-10_09:58:50_UTC [openHABian] Changing default username and password... OK
2017-04-10_09:58:50_UTC [openHABian] Setting up Wifi connection... SKIPPED
2017-04-10_09:58:50_UTC [openHABian] Ensuring network connectivity... OK
2017-04-10_09:58:50_UTC [openHABian] Waiting for dpkg/apt to get ready... OK
2017-08-31_07:02:17_UTC [openHABian] Updating repositories and upgrading installed packages... OK
2017-08-31_07:08:14_UTC [openHABian] Installing git package... OK
2017-08-31_07:08:35_UTC [openHABian] Cloning myself... OK
2017-08-31_07:08:39_UTC [openHABian] Executing 'openhabian-setup.sh unattended'
2017-08-31_07:08:39_UTC [openHABian] Checking for root privileges... OK
2017-08-31_07:08:39_UTC [openHABian] Loading configuration file '/etc/openhabian.conf'... OK
2017-08-31_07:08:39_UTC [openHABian] Setting timezone based on IP geolocation... OK (Europe/Sofia)
2017-08-31_10:09:38_EEST [openHABian] Setting locale based on openhabian.conf... OK
2017-08-31_10:10:03_EEST [openHABian] Setting hostname of the base system... OK
2017-08-31_10:10:04_EEST [openHABian] Setting the GPU memory split down to 16MB for headless system... OK
2017-08-31_10:10:04_EEST [openHABian] Installing basic can't-be-wrong packages (screen, vim, ...)... OK
2017-08-31_10:11:41_EEST [openHABian] Installing additional needed packages... OK
2017-08-31_10:11:53_EEST [openHABian] Installing additional bluetooth packages... OK
2017-08-31_10:12:26_EEST [openHABian] Adding slightly tuned bash config files to system... OK
2017-08-31_10:12:26_EEST [openHABian] Adding slightly tuned vim config file to system... OK
2017-08-31_10:12:26_EEST [openHABian] Downloading and setting up FireMotD... OK
2017-08-31_10:12:52_EEST [openHABian] Installing etckeeper (git based /etc backup)... OK
2017-08-31_10:13:27_EEST [openHABian] Installing Zulu Embedded OpenJDK... OK
2017-08-31_10:16:03_EEST [openHABian] Installing openHAB 2.1 (stable)... OK
2017-08-31_10:17:42_EEST [openHABian] Adding openHAB syntax to vim editor... OK
2017-08-31_10:17:43_EEST [openHABian] Adding openHAB syntax to nano editor... OK
2017-08-31_10:17:43_EEST [openHABian] Preparing openHAB folder mounts under /srv/... OK
2017-08-31_10:17:43_EEST [openHABian] Applying file permissions recommendations... OK
2017-08-31_10:17:45_EEST [openHABian] Applying miscellaneous system settings... OK
2017-08-31_10:17:45_EEST [openHABian] Setting up Samba network shares... OK
2017-08-31_10:19:16_EEST [openHABian] Installing Node.js (prerequisite for other packages)... FAILED (nodejs preparations)
2017-08-31_10:19:16_EEST [openHABian] Initial setup exiting with an error.

Hello @stanislav3885,
trying one of the older image versions will not do any good. We should concentrate on the newest version.

@bob_dickenson please stay in the loop, I might miss something :wink:

Okay so an error in the nodejs installation is weird but not unlikely. I don’t know why you are seeing issues with this. Anyhow, we can solve your issue quickly. Nodejs+frontail+yo_generator are the last packages installed before the openHABian installation is finished, so lets just skip them for now so you have a system to work with. Please execute on the console:

sudo rm -f /opt/openHABian-install-failed
sudo rm -f /opt/openHABian-install-inprogress
sudo touch /opt/openHABian-install-successful
sudo touch /opt/afterfirstboot.lock
sudo reboot

You should end up with a fully working system. Now to still install nodejs, please follow the installation instructions here and see why it fails: https://nodejs.org/en/download/package-manager/#debian-and-ubuntu-based-linux-distributions
P.S. the openHABian installer uses https://deb.nodesource.com/setup_7.x which is still available. Maybe we should switch to version 8 as well.


Thanks for advice i will try later today and provide you with feedvack. Please excuse me about my late answer but I was blocked because I am a new user and reached daily limitations

Hello @ThomDietrich,

I’m new to the community and doing my first steps with openhab. My linux experience is pretty basic, but I’ll give my best to help solving the problem.

I ran into the same installation error as Stanislav and followed your proposed steps. It did not find the /opt/openHABian-install-inprogress directory but I just ignored this.

After rebooting I was able to reach the openhab web frontend on port 8080. I then ran the commands from the nodejs documentation (using setup_7.x) and it funnily installed without complaints.

To finish the setup: Can I look up the steps needed to get frontail running with openhab somehere?

If you need logs or something to trace down the installation error please let me know.

Hey Steffen,
welcome to the community!

Did you try a second time? Errors during the installation are unlikely but happen from time to time, the second installation succeeds normally. The node setup might fail due to your hardware. Which device are you trying this on?

Besides that everything looks great. With the now installed nodejs you should also be able to install frontail from the openHABian configuration menu.
What else is there to trace down?

Yes, I tried a second time but with the same result. (also on a Raspberry Pi 3 as Stanislav and using the latest openhabian release)

Then I followed your steps from above again and successfully installed frontail via openhabian-config afterwards. The Max! Cube I’m playing with also was easily discovered.
So everything is fine on my side now, I just was not sure if it is something installer related and you would need input to fix it.

The only thing I noticed was a very long wait time while installing nodejs manually when FireMOTD updated the currently available update count afterwards. Not sure if there is something like a timeout in this context.

Okay thanks for the input. I don’t need further details at the moment but will look into the issue myself soon.

Happy you got your setup working. Enjoy openHAB!

I tried to manually install Node,js (sudo wget -O /tmp/nodejs-v7.x.sh https://deb.nodesource.com/setup_7.x) but I received a certificate error. In my case, the date and time of the system were incorrect. By setting the clock, the fault was resolved.

I had this issue and it was due to openDNS filtering. I connected to a network that was not using openDNS and it worked. Hope this helps someone.

Hi @ThomDietrich,

New Openhabian here. I had the same issue that stanislav3885 had, and your post has allowed me to be able to access the UI through port 8080. So, thanks a lot for that!

Then, I installed NodeJS v9 successfully on the first try and things seem to be working fine except that I can’t install frontail, neither through openhabian-config, nor by running sudo npm install -g frontail. The error that I get is this:

npm WARN deprecated connect@2.11.0: connect 2.x series is deprecated
npm ERR! code 128
npm ERR! Command failed: /usr/bin/git clone --depth=1 -q -b master git://github.com/zipang/daemon.node.git /root/.npm/_cacache/tmp/git-clone-a224fe05
npm ERR! fatal: could not create leading directories of '/root/.npm/_cacache/tmp/git-clone-a224fe05': Permission denied

I also tried installing it as the non-root user, to no avail.

Any ideas why I’m getting permissions issues, even when I run it as root?

I followed option 2 in these steps: https://docs.npmjs.com/getting-started/fixing-npm-permissions

I was able to successfully execute npm install -g frontail, but it doesn’t seem to work, since it wasn’t executed with root user permissions. Installing through openhabian-config and with root permissions still fails.