Openhab 1.7.1 Souliss error is killng the raspberry SD card

After a brand new clean installing OH 1.7.1, my openhab.log file is full with the error below (there rate is about 50ms which is by the way simply killing my Raspsberry SD card :rage:)

2015-12-23 15:38:30.854 [ERROR] [.service.AbstractActiveService] - Error while executing background thread Souliss Refresh Service
java.lang.NullPointerException: null

Current solution is to remove the addons/org.openhab.binding.souliss-1.7.1.jar file.
Any idea when a fix will be ready for that issue

Could you try the current org.openhab.binding.soullis.1.8.0-SNAPSHOT.jar binding in the here? (remove the current JAR and put the new JAR in your addons folder)

Do you have any more configuration or logs that might help diagnose the issue? Hopefully @fazioa or another contributor or maintainer can take a look.

Don’t know about the Souliss binding, but you could write the logs to a tmpfs instead. In addition a higher commit value (commit=300) in /etc/fstab is useful.

Have you tried using the addon-jar from the 1.8.0 SNAPSHOTS?

OK this looks better
Log file shows now:

2015-12-23 16:45:56.403 [INFO ] [.b.s.internal.SoulissActivator] - souliss binding has been started.
2015-12-23 16:45:56.405 [INFO ] [.b.s.internal.SoulissActivator] - Load parameter from file: /properties/
2015-12-23 16:45:56.410 [INFO ] [.b.s.internal.SoulissActivator] - Load parameter from file: /properties/
2015-12-23 16:45:56.415 [INFO ] [.s.i.n.typicals.StateTraslator] - ok
2015-12-23 16:45:56.416 [INFO ] [.b.s.internal.SoulissActivator] - Load parameter from file: /properties/
2015-12-23 16:45:56.418 [INFO ] [.s.i.n.typicals.StateTraslator] - ok
2015-12-23 16:45:56.418 [INFO ] [.b.s.internal.SoulissActivator] - Load parameter from file: /properties/
2015-12-23 16:45:56.419 [INFO ] [.s.i.n.typicals.StateTraslator] - o

Do you have original configuration file? Do you have modified it?
Can you post parte of log file?

You are first user that write about this problem.

No it was a brand new installation of 1.7.1
See also!topic/openhab/sC1WFA4IjGE

More infos.
Souliss error starts after the installation of OH1.7.1. and after the installation of the start / stop procedure see

This only after a system reboot, (not via /etc/init.d/openhab start or stop) ? (sudo update-rc.d openhab defaults)

Replacing the org.openhab.binding.souliss-1.7.1.jar by org.openhab.binding.souliss-1.8.0-SNAPSHOT.jar solves the problem

I had same issue on fresh install of 1.7.1 and solved it by removing the org.openhab.binding.souliss-1.7.1.jar from the addons folder.