Openhab 1.7.1 trying to get TKB TZ88E to work

First timer, have rudimentary knowledge of Openhab, have read as much as I can but am stuck.
I have openHab running on Raspberry Pi2 with Aeon z-stick and habmin working.
The habmin is showing the device as node3 as Wenzhou TKB Control System [ID:11,Type:1]

My item is:
Switch Power_Socket_Gen5 “Amps” (Hifi) { zwave=“3:command=SWITCH_BINARY” }

Which I have added to sitemap, and it operates as a switch when using the app. However, the actual socket does not turn on or off.

Any tips for how to correct this much appreciated.

I left it for a while, then tried again and it worked! Is this typical for zwave devices?


Hi - I have experienced the same with the same setup. I had some xmas tree lights plugged into a TZ88E GEN5 and most of the time, I could turn them on and off but there
were occasions when the on/off request was accepted and the state of the switch changed from on to off in the display but the switch didn’t always
turn on or off. There were no errors in the console window.
I never got to the bottom of it, but I do think that the product info in the database needs updating and that it doesn’t yet recognise the GEN 5 version of the TZ88E
I am currently experimenting with a new build but haven’t got to the end game yet.
I have not experienced the same issues with the previous versions of the TZ88
Will report back

Can you provide the information so that it can be updated? :wink:

I have managed to edit the products.xml within the jar and changed the ID
from 0001 to 0011 and this means that the TZ88E GEN5 is now recognised.
However, whilst all of the Configuration parameters are shown in habmin,
the Association branch of the tree isn’t shown so I can’t set the
Association between the node that is the TZ88E and the controller.
Any suggestions?

Are you using a new version of the binding? If so, this shouldn’t have been necessary since ID of 11 is already in the database -:


Please confirm you are using the latest binding? If not, please upgrade and see if the issue is still there - I suspect it might not be.

OK - CommandClass85 was missing
TZ88E GEN5 now working and I learnt a bit about adding a new product to the
database too.
Happy to contribute on this front in the future.

Hi Tim, I have the same TZ88E and was trying to figure out from the provided leaflet how to update the database. Could you point me in the right direction, as I have some other devices too that I’d like to add.

Hi Kev - happy to help - there’s one final bit that I’m not happy with my end (which is that the item for my TZ88E keeps getting refreshed every 10 seconds or so)
but, this is how I got the TZ88E GEN5 to be recognised.

Use WINRAR to open the zwave binding (the .jar)
Extract the products.xml from the database folder and edit it.
I found that it had previously shown the following


but the new GEN5 gives out a product code of 11 so it doesn’t match up with anything in the product database and it doesn’t then show the correct options in habmin.
I changed the id to 0011 and put the products.xml back into the jar using WINRAR.
I believe you can also add a supplementary Reference of 11 so the products.xml has both.

The other thing I found was that the TZ88.xml file inside the TKB folder inside the database folder of the zwave binding didn’t have command class 85 and, without this, habmin doesn’t show an associations branch.
So, basically, they were the two changes I made.

If any of this is unclear, please shout.


Hi Tim, thanks for the explanation.
I downloaded the latest v1.8.1 distribution and looked at the zwave products.xml.
Like you, the TZ88 had a reference Id of 0001, so I’ve changed that to 0011.

Can you help further with the command class?
I can see in the supplied product manual it lists the supported command classes, including the COMMAND_CLASS_ASSOCIATION_V1. How do you know this is value 85? and is this hex value 85, i.e. should the value in tz88.xml be set as follows:


Update: I’ve found this resource has some examples of the command class name along with the hex value. So I’ll be setting the value as 0x85 for the association now :slightly_smiling: