Openhab 1.7 on Synology DS1515+


Can someone help we on the update from 1.5 to 1.7 on a DS1515+ ?
I’ve installed the 1.5 through the package installer, but the manual update won’t work…
Seems like im doing something wrong.

Kind Regards

Hey there,

I’m very new as well to OpenHAB, but any details you can share on what problem you’re experiencing? I just installed OpenHAB last night on my DS415+ and had to manually add the package after modifying the port number in the .spk file.

Let me know and I’ll help where I can.


I’m not sure what package to download and extract over the 1.5 install…

I’d backup your rules, items, etc and then just look at doing a fresh 1.7.1 install and then copy over your files from 1.5.

Here’s what I did:

  1. Download the 1.7.1 package
  2. unzip the .spk file
  3. open the package manager on your NAS
  4. select manual install
  5. click the browse button (or whatever) and then choose the spk file you downloaded and unzipped

In my case, the package installer complained about the port being used which is hardcoded in the spk file, so I just opened up a text editor and searched for the reference to the port, and then modified to another value. Saved the spk and retried steps 1-5.

Hope that helps!

The DS1515+ has a intel cpu so the spk packages won’t work :wink:

openHAB 1.7.1 works like a charm on my DS1515+ with the package from cniweb.

Can you please enlighten me where you got it ?

I tried it again and now it works… wtf
Ok close this :slight_smile:


I’m a newbie and charmed by the potential of Openhab (as I have a Synology NAS). I first got the 1.5 demo version working on a Synology DS515j by the 2 packages coming from in combination with a trick on!topic/openhab/VfJkbf6WLdQ to solve the Sitemap ‘demo’ could not found issue that I had (as I wanted to have the configuration files on volume1/public/OpenHAB/…

To really start with using OpenHAB I wanted to start with the latest release 1.7.1. I used the version coming from github (/cniweb/openhab-syno-spk/releases)

To do this I had to uninstall the 1.5 version app and demo package first and after that manually installed the 1.7.1 spk file. I copied the demo config ( under volume1/public/OpenHAB.

I always get the message:
Sitemap ‘demo’ could not be foundCaused by:org.openhab.ui.webapp.render.RenderException: Sitemap ‘demo’ could not be found.

In the log file I found a openhab.cfg not found issue. I renamed the default cfg file but still no success.

Any idea of how to debug this further?

Kind regards, Johannes

this is a rights question , check that your openhab user has access to the folder and subfolders