OpenHAB 2.0.3 iOS remotely not working

I have a issue which preventing me from using openHAB iPhone app remotely.

It used to work fine before I recently updated it to the latest version which is 2.0.3.

The problem

  • The app is saying connecting remotely URL at the bottom , that disappears.

When trying to remotely use nothing happens


I have try restarted app from iOS task manger many times

Log in on to try use basic UI still doesn’t work

I am wondering is there a bug with the new update ??

How did you connect to your locale openHAB instance before the update to 2.0.3?

If you´re not able to see your UI after login in at myopenhab there´s an error that´s not down to your app.

I´ve no issues with the 2.0.3 iOS app.

@vzorglub could you please move this topic to the iOS category?

Before the update everything works perfectly , I logged in through and use the basic Ui works also when I use the app on my iPhone is work , just after the update I had these problems . But just trying to troubleshoot make sure nothing changed . But I seriously don’t know what is going on

What remote URL are you using in the settings of your app?
What is the state of the switch Ignore SSL Certificates?

Did you tried to clear the cache of your app?

The remote URL I am using is Http:// , for my local URL I’m using my PI address which I have setup everything up with. My SSL certificates is currently on the off position and yes I have tried clear cache also . But like I’ve said even when I have sign in to my and go to basic Ui it still doesn’t work . So ai don’t know if I also have to update something within openHAB

Please try instead and double check your credentials.
Give it a try and change the Ignore SSL certificates to ON.

What does the status say when you´re logged in to
Also check if your UUID and secret are still correct, here´s a info where to find them.

Okay I try everything you said still nothing is happening , I’m not getting no status coming

Please check what status is displayed after login in

It says that I am online

Do you have any errors in your openHAB log when trying to access your sitemap via
Are you able to see the dashboard when accessing
Are you able to open anything from this dashboard?

Let´s try to solve this issue first because it seems like there´s something wrong/broken between your locale oH and the oH Cloud that effect the connection via app.

Yes I can access and open everything just the connection

So you‘re able to open the BasicUI?
Earlier you said you can‘t access the BasicUI through

What does your logfile say when accessing the BasicUI through

No manybe you don’t understand , I can acces basic Ui but when trying to use a item through basic UI it still doesn’t work . So, using the app remotely it doesn’t work and logging in basic UI still doesn’t work .

And only this happen when I updated the app

Old thread but just run into the same problem described above. After upgrading to OpenHab3, the iOS showed BasicUI a few times then no longer, just a blank screen after the connection message at the bottom goes away (indicating a successful login). Removed and reinstalled the app several times but no dice.
A couple of interesting clues, which make me think it’s some issue with iOS and/or the app itself.

  1. Tried with a different iPhone and it works flawlessly.
  2. The same blank screen appears in Demo mode.
  3. No difference whether local or remote.
  4. BasicUI works perfectly from browser, both local and remote.

Any ideas would be much appreciated!

There doesnt even appear to be a way to configure in the IOS App now!!!

Don’t know what you are talking about, but both, release and testflight version have the same config options and are working with myopenHAB…