openHAB 2.3 Release Candidate available!

I upgraded to OH2 snapshot 1288. Unfortunately the item linking bug is still present. I filed an issue in ESH.

Yes, that is correct. The issue is that it all works nicely in ESH, it just stops working once you stick the Paper UI into openHAB :frowning:
I fear we have to live with that as a known limitation for 2.3.0 and might patch it with a 2.3.1.
At least there is a workaround: As the item is created, you can then click “Cancel” and simply link it then to the created item. Not nice, but it works.

@Kai I’ve just updated to 2.3.0.RC1-1 and after 2 days the astro 2 binding has stopped firing and the beta Nuki Binding has stopped sending commands. The astro binding still has the midnight entry in the log but the sunset event doesn’t happen.
Previously I could go for weeks without any problems so its downgrade time for me

That does not sound good. I assume it is the binding from the distro (not manually added as a jar in addons, right?) Did anyone else see similar effects on a recent snapshot? The astro binding hasn’t changed for a while, so I would expect that if there is a bug, it should be in there since a while already.

All, we now have a 2.3.0 RC2 available here. It is not yet available as a Linux package (@Benjy could you please build them?). All bugs for which I mentioned fixes above should be fixed in it, a few things might be open.
I wouldn’t call anything a blocker, but we might want to do a 2.3.1 this time a few days/weeks after the release, let’s see.

1 Like

The Nuki binding was already installed, and I switched from Astro 1 to Astro 2 when I installed the update with the binding changed using PaperUI.

Kevin, what is your latitude?

Please see:

36.8 degrees South -36.8 plus many decimals in PaperUI

The linuxpkg repos are ready. If you were on RC1, please update using

sudo apt install openhab2=2.3.0~RC2-1

And optionally

sudo apt install openhab2-addons=2.3.0~RC2-1
1 Like

worked fine (just a meaningless warning that it’s a downgrade)

root@rpi3:/home/pi# apt-get install openhab2=2.3.0~RC2-1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be DOWNGRADED:
0 upgraded, 0 newly installed, 1 downgraded, 0 to remove and 0 not upgraded.
Need to get 64.7 MB of archives.
After this operation, 30.7 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 testing/main openhab2 all 2.3.0~RC2-1 [64.7 MB]
Fetched 64.7 MB in 16s (4,031 kB/s)                                                                                                              
dpkg: warning: downgrading openhab2 from 2.3.0.RC1-1 to 2.3.0~RC2-1
(Reading database ... 108003 files and directories currently installed.)
Preparing to unpack .../openhab2_2.3.0~RC2-1_all.deb ...
Unpacking openhab2 (2.3.0~RC2-1) over (2.3.0.RC1-1) ...
Processing triggers for systemd (215-17+deb8u7) ...
Setting up openhab2 (2.3.0~RC2-1) ...
### openHAB was not running so will not start automatically...
### In order to start openhab2, execute
 sudo /bin/systemctl start openhab2.service
1 Like

I noticed the openhab-docs aren’t 100% up to date yet and I think they should be ready when you announce 2.3.
(I didn’t follow that thread on website redesign so forgive me if that’s taken care of in there).
There’s no 2.3 pulldown option yet, and “latest” (the default most users will likely use I guess) still has
a couple of links into nirvana (at least to ESH designer on installation page).
I’d suggest we all cross-check the docs pages one more time, too.

Happy to report that 2.3RC2 has no errors on start-up and I have tried to trigger all my rules (may have missed some) and nothing to report
Carry On!!

is the hue emulator working with amazon alexa (Echo v2) in this release?

Karaf command for listing items seems to be giving a bad response:

openhab> smarthome:items list
No item found for this pattern.

But there’s no pattern provided, so it should just list them all. Since I have no items defined, I’d expect it to say “No items defined” or something similar…

That’s no regression and nothing critical, is it? Feel free to create a PR at ESH to reformulate the message, but it is imho not relevant for the release.

the workaround seems not working for me, the item is created but afterwards i can’t select it form the list to link, because it is not in the list
Also tried to reload paperUI, used incognito mode so the browser can’t access any cached files and restarting openHAB, the result is the always the same, the created item is not in the list and therefore can’t be linked

We actually do not have to - this bug has been fixed yesterday and the fix will be included in the final release.

1 Like

No, I really shouldn’t have mentioned it here.


during this weekend I tested the release candidate.

for some reason, yesterday it was working more or less but not today.

during the startup I get the exception

Mai 28 08:48:00 knx openhab[14437]: Exception in thread "upnp-async-2" java.lang.NullPointerException
Mai 28 08:48:00 knx openhab[14437]:         at     org.jupnp.protocol.RetrieveRemoteDescriptors.describe(
Mai 28 08:48:00 knx openhab[14437]:         at
Mai 28 08:48:00 knx openhab[14437]:         at java.util.concurrent.ThreadPoolExecutor.runWorker(
Mai 28 08:48:00 knx openhab[14437]:         at java.util.concurrent.ThreadPoolExecutor$
Mai 28 08:48:00 knx openhab[14437]:         at

after that the system is shutting down itself as when I typed in “shutdown” manually.

Another thing I realize. In 50% of my cases the rules are fired before the items are initialized or all persistence services are loaded. This is filling my logs with hundred of error messages.

Why not waiting with until the whole system is initialized properly before executing the rules.

in this case I get errors like

Rule 'Check Roommessages': The name 'Sensor_Doors_FF' cannot be resolved to an item or type; line 10, column 22, length 15


Could not update element with key astro:sun:local in ManagedThingProvider, because it does not exists.


Could not transform 'NULL' with the file '' : Target value not found in map for 'NULL'


There is no queryable persistence service registered with the id 'mapdb'

this are just examples. I got a lot more.

so for now I will go back to version 2.1.0 which was the last working version for me. :disappointed_relieved:

I’m still trying to get it working :slight_smile:

I was able to enclose it a little bit. More details can be found here.