Openhab 2.4.0 - issues with Xaiomi aquara, humidity sensor

Tags: #<Tag:0x00007f433e6d09d8> #<Tag:0x00007f433e6d08e8> #<Tag:0x00007f433e6d07f8>

Hi,

I’m using:

  • Openhab 2.4.0

Bindings:

344 │ Active │ 80 │ 1.1.6 │ com.zsmartsystems.zigbee
345 │ Active │ 80 │ 1.1.6 │ com.zsmartsystems.zigbee.dongle.cc2531
346 │ Active │ 80 │ 1.1.6 │ com.zsmartsystems.zigbee.dongle.ember
347 │ Active │ 80 │ 1.1.6 │ com.zsmartsystems.zigbee.dongle.telegesis
348 │ Active │ 80 │ 1.1.6 │ com.zsmartsystems.zigbee.dongle.xbee

I’ve reverted Openhab from version 2.5.0 to 2.4.0 due to other issues. For now everything is working fine except xiaomi aquara temperature, humidity sensor with zigbee dongle cc2531.

Zigbee dongle cc2531 is properly recognized and online.
Xiaomi sensor:

  • with Openhab version 2.5.0 worked fine - temperature and humidity values were properly updated.
  • with Openhab version 2.4.0 is still offline.

Some debug logs:

2020-07-12 11:25:02.227 [DEBUG] [p.discovery.ZigBeeDiscoveryExtension] - DISCOVERY Extension: Starting mesh update
2020-07-12 11:25:02.228 [DEBUG] [p.discovery.ZigBeeDiscoveryExtension] - DISCOVERY Extension: Starting mesh update for 00124B000BE8876C
2020-07-12 11:25:02.229 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: Update mesh
2020-07-12 11:25:02.230 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: scheduled [ROUTES, NEIGHBORS]
2020-07-12 11:25:02.372 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: running
2020-07-12 11:25:02.373 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX CMD: ManagementRoutingRequest [0/0 -> 0/0, cluster=0032, TID=1B, startIndex=0]
2020-07-12 11:25:02.374 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=0/0, profile=0000, cluster=50, addressMode=DEVICE, radius=31, apsSecurity=false, apsCounter=27, payload=00 00]
2020-07-12 11:25:02.374 [DEBUG] [31.network.impl.CommandInterfaceImpl] - -> AF_DATA_REQUEST (Packet: subsystem=null, length=12, apiId=24 01, data=FE 0C 24 01 00 00 00 00 32 00 1B 30 1F 02 00 00 2D, checksum=2D, error=false)
2020-07-12 11:25:02.490 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <- AF_DATA_SRSP (FE 01 64 01 00 64)
2020-07-12 11:25:02.491 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <-- ZToolPacket (FE 06 45 B2 00 00 00 00 00 00 F1)
2020-07-12 11:25:02.492 [DEBUG] [31.network.impl.CommandInterfaceImpl] - Received Async Cmd: Packet: subsystem=null, length=6, apiId=45 B2, data=FE 06 45 B2 00 00 00 00 00 00 F1, checksum=F1, error=false
2020-07-12 11:25:02.493 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=0/0, profile=0000, cluster=32818, addressMode=null, radius=0, apsSecurity=false, apsCounter=0, payload=00 00 00 00 00]
2020-07-12 11:25:02.493 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: ManagementRoutingResponse [0/0 -> 0/0, cluster=8032, TID=NULL, status=SUCCESS, routingTableEntries=0, startIndex=0, routingTableList=[]]
2020-07-12 11:25:02.497 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <-- ZToolPacket (FE 0D 45 FF 00 00 00 32 80 00 00 00 00 00 00 00 00 05)
2020-07-12 11:25:02.497 [DEBUG] [zigbee.transaction.ZigBeeTransaction] - Transaction complete: ManagementRoutingRequest [0/0 -> 0/0, cluster=0032, TID=1B, startIndex=0]
2020-07-12 11:25:02.497 [DEBUG] [31.network.impl.CommandInterfaceImpl] - Received Async Cmd: Packet: subsystem=null, length=13, apiId=45 FF, data=FE 0D 45 FF 00 00 00 32 80 00 00 00 00 00 00 00 00 05, checksum=05, error=false
2020-07-12 11:25:02.498 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: ManagementRoutingRequest returned CommandResult [SUCCESS, ManagementRoutingResponse [0/0 -> 0/0, cluster=8032, TID=NULL, status=SUCCESS, routingTableEntries=0, startIndex=0, routingTableList=[]]]
2020-07-12 11:25:02.498 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=0/0, profile=0000, cluster=32818, addressMode=null, radius=0, apsSecurity=false, apsCounter=0, payload=00 00 00 00 00]
2020-07-12 11:25:02.498 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: ManagementRoutingResponse [0/0 -> 0/0, cluster=8032, TID=NULL, status=SUCCESS, routingTableEntries=0, startIndex=0, routingTableList=[]]
2020-07-12 11:25:02.498 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: ManagementLqiRequest complete [0 routes]
2020-07-12 11:25:02.499 [DEBUG] [com.zsmartsystems.zigbee.ZigBeeNode ] - 00124B000BE8876C: Routing table NEW: []
2020-07-12 11:25:02.500 [DEBUG] [com.zsmartsystems.zigbee.ZigBeeNode ] - 00124B000BE8876C: Routing table OLD: []
2020-07-12 11:25:02.501 [DEBUG] [com.zsmartsystems.zigbee.ZigBeeNode ] - 00124B000BE8876C: Routing table unchanged
2020-07-12 11:25:02.501 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: request ROUTES successful. Advanced to NEIGHBORS.
2020-07-12 11:25:02.502 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: running
2020-07-12 11:25:02.503 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX CMD: ManagementLqiRequest [0/0 -> 0/0, cluster=0031, TID=1C, startIndex=0]
2020-07-12 11:25:02.503 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=0/0, profile=0000, cluster=49, addressMode=DEVICE, radius=31, apsSecurity=false, apsCounter=28, payload=00 00]
2020-07-12 11:25:02.504 [DEBUG] [31.network.impl.CommandInterfaceImpl] - -> AF_DATA_REQUEST (Packet: subsystem=null, length=12, apiId=24 01, data=FE 0C 24 01 00 00 00 00 31 00 1C 30 1F 02 00 00 29, checksum=29, error=false)
2020-07-12 11:25:02.622 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <- AF_DATA_SRSP (FE 01 64 01 00 64)
2020-07-12 11:25:02.623 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <-- ZToolPacket (FE 1C 45 B1 00 00 00 01 00 01 DD DD DD DD DD DD DD DD 73 66 A3 01 00 8D 15 00 A6 4D 12 02 01 AA 97)
2020-07-12 11:25:02.624 [DEBUG] [31.network.impl.CommandInterfaceImpl] - Received Async Cmd: Packet: subsystem=null, length=28, apiId=45 B1, data=FE 1C 45 B1 00 00 00 01 00 01 DD DD DD DD DD DD DD DD 73 66 A3 01 00 8D 15 00 A6 4D 12 02 01 AA 97, checksum=97, error=false
2020-07-12 11:25:02.624 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=0/0, profile=0000, cluster=32817, addressMode=null, radius=0, apsSecurity=false, apsCounter=0, payload=00 00 01 00 01 DD DD DD DD DD DD DD DD 73 66 A3 01 00 8D 15 00 A6 4D 12 02 01 AA]
2020-07-12 11:25:02.625 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: ManagementLqiResponse [0/0 -> 0/0, cluster=8031, TID=NULL, status=SUCCESS, neighborTableEntries=1, startIndex=0, neighborTableList=[NeighborTable [extendedPanId=DDDDDDDDDDDDDDDD, extendedAddress=00158D0001A36673, networkAddress=19878, deviceType=END_DEVICE, rxOnWhenIdle=RX_OFF, relationship=CHILD, permitJoining=UNKNOWN, depth=1, lqi=170]]]
2020-07-12 11:25:02.629 [DEBUG] [zigbee.transaction.ZigBeeTransaction] - Transaction complete: ManagementLqiRequest [0/0 -> 0/0, cluster=0031, TID=1C, startIndex=0]
2020-07-12 11:25:02.629 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <-- ZToolPacket (FE 23 45 FF 00 00 00 31 80 00 00 00 00 00 01 00 01 DD DD DD DD DD DD DD DD 73 66 A3 01 00 8D 15 00 A6 4D 12 02 01 AA 57)
2020-07-12 11:25:02.629 [DEBUG] [31.network.impl.CommandInterfaceImpl] - Received Async Cmd: Packet: subsystem=null, length=35, apiId=45 FF, data=FE 23 45 FF 00 00 00 31 80 00 00 00 00 00 01 00 01 DD DD DD DD DD DD DD DD 73 66 A3 01 00 8D 15 00 A6 4D 12 02 01 AA 57, checksum=57, error=false
2020-07-12 11:25:02.630 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=0/0, profile=0000, cluster=32817, addressMode=null, radius=0, apsSecurity=false, apsCounter=0, payload=00 00 01 00 01 DD DD DD DD DD DD DD DD 73 66 A3 01 00 8D 15 00 A6 4D 12 02 01 AA]
2020-07-12 11:25:02.630 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: ManagementLqiRequest response CommandResult [SUCCESS, ManagementLqiResponse [0/0 -> 0/0, cluster=8031, TID=NULL, status=SUCCESS, neighborTableEntries=1, startIndex=0, neighborTableList=[NeighborTable [extendedPanId=DDDDDDDDDDDDDDDD, extendedAddress=00158D0001A36673, networkAddress=19878, deviceType=END_DEVICE, rxOnWhenIdle=RX_OFF, relationship=CHILD, permitJoining=UNKNOWN, depth=1, lqi=170]]]]
2020-07-12 11:25:02.631 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: ManagementLqiRequest complete [1 neighbors]
2020-07-12 11:25:02.632 [DEBUG] [com.zsmartsystems.zigbee.ZigBeeNode ] - 00124B000BE8876C: Neighbor table unchanged
2020-07-12 11:25:02.632 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: request NEIGHBORS successful. Advanced to null.
2020-07-12 11:25:02.633 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: running
2020-07-12 11:25:02.634 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: complete
2020-07-12 11:25:02.634 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - 00124B000BE8876C: Node 0 update
2020-07-12 11:25:02.640 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: ManagementLqiResponse [0/0 -> 0/0, cluster=8031, TID=NULL, status=SUCCESS, neighborTableEntries=1, startIndex=0, neighborTableList=[NeighborTable [extendedPanId=DDDDDDDDDDDDDDDD, extendedAddress=00158D0001A36673, networkAddress=19878, deviceType=END_DEVICE, rxOnWhenIdle=RX_OFF, relationship=CHILD, permitJoining=UNKNOWN, depth=1, lqi=170]]]
2020-07-12 11:25:42.688 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <-- AF_INCOMING_MSG (FE 40 44 81 00 00 00 00 A6 4D 01 01 00 34 00 35 FE 2C 00 00 2C 18 E8 0A 01 FF 42 25 01 21 DB 0B 04 21 A8 43 05 21 09 5F 06 24 01 00 00 00 00 64 29 3C 09 65 21 E4 11 66 2B C0 83 01 00 0A 21 00 00 A6 4D 1D 86)
2020-07-12 11:25:42.689 [DEBUG] [31.network.impl.CommandInterfaceImpl] - Received Async Cmd: Packet: subsystem=null, length=64, apiId=44 81, data=FE 40 44 81 00 00 00 00 A6 4D 01 01 00 34 00 35 FE 2C 00 00 2C 18 E8 0A 01 FF 42 25 01 21 DB 0B 04 21 A8 43 05 21 09 5F 06 24 01 00 00 00 00 64 29 3C 09 65 21 E4 11 66 2B C0 83 01 00 0A 21 00 00 A6 4D 1D 86, checksum=86, error=false
2020-07-12 11:25:42.692 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX APS: ZigBeeApsFrame [sourceAddress=19878/1, destinationAddress=0/1, profile=0104, cluster=0, addressMode=null, radius=0, apsSecurity=false, apsCounter=0, payload=18 E8 0A 01 FF 42 25 01 21 DB 0B 04 21 A8 43 05 21 09 5F 06 24 01 00 00 00 00 64 29 3C 09 65 21 E4 11 66 2B C0 83 01 00 0A 21 00 00]
2020-07-12 11:25:42.696 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX ZCL: ZclHeader [frameType=ENTIRE_PROFILE_COMMAND, manufacturerSpecific=false, direction=SERVER_TO_CLIENT, disableDefaultResponse=true, manufacturerCode=0, sequenceNumber=232, commandId=10]
2020-07-12 11:25:42.744 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: ReportAttributesCommand [Basic: 19878/1 -> 0/1, cluster=0000, TID=E8, reports=[Attribute Report: attributeDataType=CHARACTER_STRING, attributeIdentifier=65281, attributeValue=!�
!�C! _$]]
2020-07-12 11:25:42.745 [DEBUG] [pp.discovery.ZigBeeNetworkDiscoverer] - 19878: NWK Discovery scheduling node discovery
2020-07-12 11:25:42.745 [DEBUG] [pp.discovery.ZigBeeNetworkDiscoverer] - 19878: NWK Discovery starting node discovery
2020-07-12 11:25:42.746 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX CMD: IeeeAddressRequest [0/0 -> 19878/0, cluster=0001, TID=1D, nwkAddrOfInterest=19878, requestType=1, startIndex=0]
2020-07-12 11:25:42.746 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=19878/0, profile=0000, cluster=1, addressMode=DEVICE, radius=31, apsSecurity=false, apsCounter=29, payload=00 A6 4D 01 00]
2020-07-12 11:25:42.746 [DEBUG] [31.network.impl.CommandInterfaceImpl] - -> AF_DATA_REQUEST (Packet: subsystem=null, length=15, apiId=24 01, data=FE 0F 24 01 A6 4D 00 00 01 00 1D 30 1F 05 00 A6 4D 01 00 1D, checksum=1D, error=false)
2020-07-12 11:25:42.856 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <- AF_DATA_SRSP (FE 01 64 01 00 64)
2020-07-12 11:25:43.216 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <-- ZToolPacket (FE 14 45 FF A6 4D 00 01 80 00 00 00 00 04 73 66 A3 01 00 8D 15 00 A6 4D 04)
2020-07-12 11:25:43.217 [DEBUG] [31.network.impl.CommandInterfaceImpl] - Received Async Cmd: Packet: subsystem=null, length=20, apiId=45 FF, data=FE 14 45 FF A6 4D 00 01 80 00 00 00 00 04 73 66 A3 01 00 8D 15 00 A6 4D 04, checksum=04, error=false
2020-07-12 11:25:43.218 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX APS: ZigBeeApsFrame [sourceAddress=19878/0, destinationAddress=0/0, profile=0000, cluster=32769, addressMode=null, radius=0, apsSecurity=false, apsCounter=0, payload=00 04 73 66 A3 01 00 8D 15 00 A6 4D]
2020-07-12 11:25:43.219 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: IeeeAddressResponse [19878/0 -> 0/0, cluster=8001, TID=NULL, status=UNKNOWN, ieeeAddrRemoteDev=null, nwkAddrRemoteDev=null, startIndex=null, nwkAddrAssocDevList=[]]
2020-07-12 11:25:50.746 [DEBUG] [zigbee.transaction.ZigBeeTransaction] - Transaction timeout: IeeeAddressRequest [0/0 -> 19878/0, cluster=0001, TID=1D, nwkAddrOfInterest=19878, requestType=1, startIndex=0]
2020-07-12 11:25:52.248 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX CMD: IeeeAddressRequest [0/0 -> 19878/0, cluster=0001, TID=1E, nwkAddrOfInterest=19878, requestType=1, startIndex=0]
2020-07-12 11:25:52.249 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=19878/0, profile=0000, cluster=1, addressMode=DEVICE, radius=31, apsSecurity=false, apsCounter=30, payload=00 A6 4D 01 00]
2020-07-12 11:25:52.250 [DEBUG] [31.network.impl.CommandInterfaceImpl] - -> AF_DATA_REQUEST (Packet: subsystem=null, length=15, apiId=24 01, data=FE 0F 24 01 A6 4D 00 00 01 00 1E 30 1F 05 00 A6 4D 01 00 1E, checksum=1E, error=false)
2020-07-12 11:25:52.360 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <- AF_DATA_SRSP (FE 01 64 01 00 64)
2020-07-12 11:26:00.248 [DEBUG] [zigbee.transaction.ZigBeeTransaction] - Transaction timeout: IeeeAddressRequest [0/0 -> 19878/0, cluster=0001, TID=1E, nwkAddrOfInterest=19878, requestType=1, startIndex=0]
2020-07-12 11:26:01.751 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX CMD: IeeeAddressRequest [0/0 -> 19878/0, cluster=0001, TID=1F, nwkAddrOfInterest=19878, requestType=1, startIndex=0]
2020-07-12 11:26:01.752 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=19878/0, profile=0000, cluster=1, addressMode=DEVICE, radius=31, apsSecurity=false, apsCounter=31, payload=00 A6 4D 01 00]
2020-07-12 11:26:01.753 [DEBUG] [31.network.impl.CommandInterfaceImpl] - -> AF_DATA_REQUEST (Packet: subsystem=null, length=15, apiId=24 01, data=FE 0F 24 01 A6 4D 00 00 01 00 1F 30 1F 05 00 A6 4D 01 00 1F, checksum=1F, error=false)
2020-07-12 11:26:01.863 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <- AF_DATA_SRSP (FE 01 64 01 00 64)
2020-07-12 11:26:09.752 [DEBUG] [zigbee.transaction.ZigBeeTransaction] - Transaction timeout: IeeeAddressRequest [0/0 -> 19878/0, cluster=0001, TID=1F, nwkAddrOfInterest=19878, requestType=1, startIndex=0]
2020-07-12 11:26:11.255 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX CMD: IeeeAddressRequest [0/0 -> 19878/0, cluster=0001, TID=20, nwkAddrOfInterest=19878, requestType=1, startIndex=0]
2020-07-12 11:26:11.256 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=19878/0, profile=0000, cluster=1, addressMode=DEVICE, radius=31, apsSecurity=false, apsCounter=32, payload=00 A6 4D 01 00]
2020-07-12 11:26:11.257 [DEBUG] [31.network.impl.CommandInterfaceImpl] - -> AF_DATA_REQUEST (Packet: subsystem=null, length=15, apiId=24 01, data=FE 0F 24 01 A6 4D 00 00 01 00 20 30 1F 05 00 A6 4D 01 00 20, checksum=20, error=false)
2020-07-12 11:26:11.367 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <- AF_DATA_SRSP (FE 01 64 01 00 64)
2020-07-12 11:26:19.255 [DEBUG] [zigbee.transaction.ZigBeeTransaction] - Transaction timeout: IeeeAddressRequest [0/0 -> 19878/0, cluster=0001, TID=20, nwkAddrOfInterest=19878, requestType=1, startIndex=0]
2020-07-12 11:26:20.759 [DEBUG] [pp.discovery.ZigBeeNetworkDiscoverer] - 19878: NWK Discovery ending node discovery
2020-07-12 11:30:02.227 [DEBUG] [p.discovery.ZigBeeDiscoveryExtension] - DISCOVERY Extension: Starting mesh update
2020-07-12 11:30:02.228 [DEBUG] [p.discovery.ZigBeeDiscoveryExtension] - DISCOVERY Extension: Starting mesh update for 00124B000BE8876C
2020-07-12 11:30:02.229 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: Update mesh
2020-07-12 11:30:02.230 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: scheduled [ROUTES, NEIGHBORS]
2020-07-12 11:30:02.874 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: running
2020-07-12 11:30:02.875 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX CMD: ManagementRoutingRequest [0/0 -> 0/0, cluster=0032, TID=21, startIndex=0]
2020-07-12 11:30:02.876 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=0/0, profile=0000, cluster=50, addressMode=DEVICE, radius=31, apsSecurity=false, apsCounter=33, payload=00 00]
2020-07-12 11:30:02.877 [DEBUG] [31.network.impl.CommandInterfaceImpl] - -> AF_DATA_REQUEST (Packet: subsystem=null, length=12, apiId=24 01, data=FE 0C 24 01 00 00 00 00 32 00 21 30 1F 02 00 00 17, checksum=17, error=false)
2020-07-12 11:30:02.994 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <- AF_DATA_SRSP (FE 01 64 01 00 64)
2020-07-12 11:30:02.995 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <-- ZToolPacket (FE 06 45 B2 00 00 00 00 00 00 F1)
2020-07-12 11:30:02.995 [DEBUG] [31.network.impl.CommandInterfaceImpl] - Received Async Cmd: Packet: subsystem=null, length=6, apiId=45 B2, data=FE 06 45 B2 00 00 00 00 00 00 F1, checksum=F1, error=false
2020-07-12 11:30:02.996 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=0/0, profile=0000, cluster=32818, addressMode=null, radius=0, apsSecurity=false, apsCounter=0, payload=00 00 00 00 00]
2020-07-12 11:30:02.997 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: ManagementRoutingResponse [0/0 -> 0/0, cluster=8032, TID=NULL, status=SUCCESS, routingTableEntries=0, startIndex=0, routingTableList=[]]
2020-07-12 11:30:03.003 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <-- ZToolPacket (FE 0D 45 FF 00 00 00 32 80 00 00 00 00 00 00 00 00 05)
2020-07-12 11:30:03.003 [DEBUG] [zigbee.transaction.ZigBeeTransaction] - Transaction complete: ManagementRoutingRequest [0/0 -> 0/0, cluster=0032, TID=21, startIndex=0]
2020-07-12 11:30:03.004 [DEBUG] [31.network.impl.CommandInterfaceImpl] - Received Async Cmd: Packet: subsystem=null, length=13, apiId=45 FF, data=FE 0D 45 FF 00 00 00 32 80 00 00 00 00 00 00 00 00 05, checksum=05, error=false
2020-07-12 11:30:03.005 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: ManagementRoutingRequest returned CommandResult [SUCCESS, ManagementRoutingResponse [0/0 -> 0/0, cluster=8032, TID=NULL, status=SUCCESS, routingTableEntries=0, startIndex=0, routingTableList=[]]]
2020-07-12 11:30:03.006 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=0/0, profile=0000, cluster=32818, addressMode=null, radius=0, apsSecurity=false, apsCounter=0, payload=00 00 00 00 00]
2020-07-12 11:30:03.006 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: ManagementLqiRequest complete [0 routes]
2020-07-12 11:30:03.007 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: ManagementRoutingResponse [0/0 -> 0/0, cluster=8032, TID=NULL, status=SUCCESS, routingTableEntries=0, startIndex=0, routingTableList=[]]
2020-07-12 11:30:03.007 [DEBUG] [com.zsmartsystems.zigbee.ZigBeeNode ] - 00124B000BE8876C: Routing table NEW: []
2020-07-12 11:30:03.007 [DEBUG] [com.zsmartsystems.zigbee.ZigBeeNode ] - 00124B000BE8876C: Routing table OLD: []
2020-07-12 11:30:03.008 [DEBUG] [com.zsmartsystems.zigbee.ZigBeeNode ] - 00124B000BE8876C: Routing table unchanged
2020-07-12 11:30:03.008 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: request ROUTES successful. Advanced to NEIGHBORS.
2020-07-12 11:30:03.009 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: running
2020-07-12 11:30:03.009 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX CMD: ManagementLqiRequest [0/0 -> 0/0, cluster=0031, TID=22, startIndex=0]
2020-07-12 11:30:03.010 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=0/0, profile=0000, cluster=49, addressMode=DEVICE, radius=31, apsSecurity=false, apsCounter=34, payload=00 00]
2020-07-12 11:30:03.010 [DEBUG] [31.network.impl.CommandInterfaceImpl] - -> AF_DATA_REQUEST (Packet: subsystem=null, length=12, apiId=24 01, data=FE 0C 24 01 00 00 00 00 31 00 22 30 1F 02 00 00 17, checksum=17, error=false)
2020-07-12 11:30:03.127 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <- AF_DATA_SRSP (FE 01 64 01 00 64)
2020-07-12 11:30:03.129 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <-- ZToolPacket (FE 1C 45 B1 00 00 00 01 00 01 DD DD DD DD DD DD DD DD 73 66 A3 01 00 8D 15 00 A6 4D 12 02 01 42 7F)
2020-07-12 11:30:03.130 [DEBUG] [31.network.impl.CommandInterfaceImpl] - Received Async Cmd: Packet: subsystem=null, length=28, apiId=45 B1, data=FE 1C 45 B1 00 00 00 01 00 01 DD DD DD DD DD DD DD DD 73 66 A3 01 00 8D 15 00 A6 4D 12 02 01 42 7F, checksum=7F, error=false
2020-07-12 11:30:03.131 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=0/0, profile=0000, cluster=32817, addressMode=null, radius=0, apsSecurity=false, apsCounter=0, payload=00 00 01 00 01 DD DD DD DD DD DD DD DD 73 66 A3 01 00 8D 15 00 A6 4D 12 02 01 42]
2020-07-12 11:30:03.132 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: ManagementLqiResponse [0/0 -> 0/0, cluster=8031, TID=NULL, status=SUCCESS, neighborTableEntries=1, startIndex=0, neighborTableList=[NeighborTable [extendedPanId=DDDDDDDDDDDDDDDD, extendedAddress=00158D0001A36673, networkAddress=19878, deviceType=END_DEVICE, rxOnWhenIdle=RX_OFF, relationship=CHILD, permitJoining=UNKNOWN, depth=1, lqi=66]]]
2020-07-12 11:30:03.134 [DEBUG] [zigbee.transaction.ZigBeeTransaction] - Transaction complete: ManagementLqiRequest [0/0 -> 0/0, cluster=0031, TID=22, startIndex=0]
2020-07-12 11:30:03.135 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <-- ZToolPacket (FE 23 45 FF 00 00 00 31 80 00 00 00 00 00 01 00 01 DD DD DD DD DD DD DD DD 73 66 A3 01 00 8D 15 00 A6 4D 12 02 01 42 BF)
2020-07-12 11:30:03.135 [DEBUG] [31.network.impl.CommandInterfaceImpl] - Received Async Cmd: Packet: subsystem=null, length=35, apiId=45 FF, data=FE 23 45 FF 00 00 00 31 80 00 00 00 00 00 01 00 01 DD DD DD DD DD DD DD DD 73 66 A3 01 00 8D 15 00 A6 4D 12 02 01 42 BF, checksum=BF, error=false
2020-07-12 11:30:03.135 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: ManagementLqiRequest response CommandResult [SUCCESS, ManagementLqiResponse [0/0 -> 0/0, cluster=8031, TID=NULL, status=SUCCESS, neighborTableEntries=1, startIndex=0, neighborTableList=[NeighborTable [extendedPanId=DDDDDDDDDDDDDDDD, extendedAddress=00158D0001A36673, networkAddress=19878, deviceType=END_DEVICE, rxOnWhenIdle=RX_OFF, relationship=CHILD, permitJoining=UNKNOWN, depth=1, lqi=66]]]]
2020-07-12 11:30:03.136 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: ManagementLqiRequest complete [1 neighbors]
2020-07-12 11:30:03.136 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=0/0, profile=0000, cluster=32817, addressMode=null, radius=0, apsSecurity=false, apsCounter=0, payload=00 00 01 00 01 DD DD DD DD DD DD DD DD 73 66 A3 01 00 8D 15 00 A6 4D 12 02 01 42]
2020-07-12 11:30:03.137 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: ManagementLqiResponse [0/0 -> 0/0, cluster=8031, TID=NULL, status=SUCCESS, neighborTableEntries=1, startIndex=0, neighborTableList=[NeighborTable [extendedPanId=DDDDDDDDDDDDDDDD, extendedAddress=00158D0001A36673, networkAddress=19878, deviceType=END_DEVICE, rxOnWhenIdle=RX_OFF, relationship=CHILD, permitJoining=UNKNOWN, depth=1, lqi=66]]]
2020-07-12 11:30:03.137 [DEBUG] [com.zsmartsystems.zigbee.ZigBeeNode ] - 00124B000BE8876C: Neighbor table updated: [NeighborTable [extendedPanId=DDDDDDDDDDDDDDDD, extendedAddress=00158D0001A36673, networkAddress=19878, deviceType=END_DEVICE, rxOnWhenIdle=RX_OFF, relationship=CHILD, permitJoining=UNKNOWN, depth=1, lqi=66]]
2020-07-12 11:30:03.138 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: request NEIGHBORS successful. Advanced to null.
2020-07-12 11:30:03.138 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: running
2020-07-12 11:30:03.139 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00124B000BE8876C: Node SVC Discovery: complete
2020-07-12 11:30:03.140 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - 00124B000BE8876C: Node 0 update
2020-07-12 11:31:40.799 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - Permit join to 65532/0 for 60 seconds.
2020-07-12 11:31:40.800 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX CMD: ManagementPermitJoiningRequest [0/0 -> 65532/0, cluster=0036, TID=23, permitDuration=60, tcSignificance=true]
2020-07-12 11:31:40.800 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=65532/0, profile=0000, cluster=54, addressMode=DEVICE, radius=31, apsSecurity=false, apsCounter=35, payload=00 3C 01]
2020-07-12 11:31:40.801 [DEBUG] [31.network.impl.CommandInterfaceImpl] - -> AF_DATA_REQUEST (Packet: subsystem=null, length=13, apiId=24 01, data=FE 0D 24 01 FC FF 00 00 36 00 23 30 1F 03 00 3C 01 2F, checksum=2F, error=false)
2020-07-12 11:31:40.913 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <- AF_DATA_SRSP (FE 01 64 01 00 64)
2020-07-12 11:31:40.914 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX CMD: ManagementPermitJoiningRequest [0/0 -> 0/0, cluster=0036, TID=24, permitDuration=60, tcSignificance=true]
2020-07-12 11:31:40.916 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=0/0, profile=0000, cluster=54, addressMode=DEVICE, radius=31, apsSecurity=false, apsCounter=36, payload=00 3C 01]
2020-07-12 11:31:40.917 [DEBUG] [31.network.impl.CommandInterfaceImpl] - -> AF_DATA_REQUEST (Packet: subsystem=null, length=13, apiId=24 01, data=FE 0D 24 01 00 00 00 00 36 00 24 30 1F 03 00 3C 01 2B, checksum=2B, error=false)
2020-07-12 11:31:41.035 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <- AF_DATA_SRSP (FE 01 64 01 00 64)
2020-07-12 11:31:41.036 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <-- ZToolPacket (FE 03 45 B6 00 00 00 F0)
2020-07-12 11:31:41.036 [DEBUG] [31.network.impl.CommandInterfaceImpl] - Received Async Cmd: Packet: subsystem=null, length=3, apiId=45 B6, data=FE 03 45 B6 00 00 00 F0, checksum=F0, error=false
2020-07-12 11:31:41.037 [DEBUG] [e.dongle.cc2531.ZigBeeDongleTiCc2531] - Unhandled ZToolPacket type 0x45b6
2020-07-12 11:31:41.037 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <-- ZToolPacket (FE 0A 45 FF 00 00 00 36 80 00 00 00 00 00 06)
2020-07-12 11:31:41.038 [DEBUG] [31.network.impl.CommandInterfaceImpl] - Received Async Cmd: Packet: subsystem=null, length=10, apiId=45 FF, data=FE 0A 45 FF 00 00 00 36 80 00 00 00 00 00 06, checksum=06, error=false
2020-07-12 11:31:41.039 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX APS: ZigBeeApsFrame [sourceAddress=0/0, destinationAddress=0/0, profile=0000, cluster=32822, addressMode=null, radius=0, apsSecurity=false, apsCounter=0, payload=00 00]
2020-07-12 11:31:41.040 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: ManagementPermitJoiningResponse [0/0 -> 0/0, cluster=8036, TID=NULL, status=SUCCESS]
2020-07-12 11:32:41.025 [DEBUG] [31.network.impl.CommandInterfaceImpl] - <-- ZToolPacket (FE 01 45 CB 00 8F)
2020-07-12 11:32:41.026 [DEBUG] [31.network.impl.CommandInterfaceImpl] - Received Async Cmd: Packet: subsystem=null, length=1, apiId=45 CB, data=FE 01 45 CB 00 8F, checksum=8F, error=false
2020-07-12 11:32:41.027 [DEBUG] [e.dongle.cc2531.ZigBeeDongleTiCc2531] - Unhandled ZToolPacket type 0x45cb

Based on logs it seems sensor is discovered.
Can you figure out why sensor is still in offline state.

A year ago the Zigbee binding developer said there were too many changes since OH 2.4 to properly support that old binding version. It may be time to make the major jump to 2.5.x.

The Zigbee log viewer may provide some hints.

https://www.cd-jackson.com/index.php/openhab/zigbee-log-viewer

Sure, I had 2.5.0 version before but as I said, due to other issues with bluetooth binding I’ve rolled back to 2.4.0.
Some info from log viewer:

Well, you’ve you’ve chosen to use an old version that does not support your device, while a newer version does support it. What would you like to happen?

Ok, I thought that it’s supported with that version - I found info in binding: “Xiaomi Temperature and Humidity Sensor”

Well, it doesn’t work. Have you looked to see if there are binding versions 2.4.x later than 2.4.0?

It seems in openhab 2.4.0 there is 1.1.6 zigbee binding version. I didn’t found older one.
If it doesn’t work I’ll back for now to Xiaomi Hub.

The ZigBee binding is v2.4 in OH 2.4. I guess you are referring to the zigbee protocol stack version, but this doesn’t actually implement any of the device specific features. As others have said, there were a lot of changes to the binding (but also the zigbee libraries) and if something doesn’t work in 2.4 there is no way to change this since 2.4 is a fixed/static version.

You can try the 2.5 version of the binding under OH2.4 - this should work.

1 Like

You can extract the bluetooth binding from 2.4 and load it manually into 2.5. Im running the 2.4.0RC1 Samsung TV binding on 2.5.6 right now because of an issue.

I would only do that with the install script, if it still works with 2.4.
Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

1 Like