openHAB 2.5.9 release discussion

This is true. However I think if you wait enough at first startup (after upgrade) and not restart openhab at the first error, you just need to restart openhab once and everything is back to normal.

This is a known problem that hits some people. It only occurs when the cache get’s cleared which happens automatically on an update.

Hopefully this won’t be a problem in OH 3. I know there has been some work on changing how stuff starts up in OH 3.

As Kristof indicates, after an upgrade wait long enough for everything that is going to load finishes loading. Than usually a single reboot is sufficient.

I handle all my updates using Ansible and run in Docker. When a new Docker image is pulled my task will wait for five minutes and then restart the container. Haven’t had a problem since and pretty much only have about 6 minutes of down time.

I need to update the role to only do the wait and restart when the actual version of OH changes. The Docker Image changes far more frequently so most of the restarts of OH are unnecessary.

I run a full update of all of my machines and docker containers every few days and very rarely encounter a serious problem that takes much time to solve. It’s when I wait for months before updating that I have that feeling of dread because if something goes wrong it’s going to be a lot of work to find out why and fix it.


Well, that’d be my problem. No patience. :grinning: Thanks, I will try that next time!

So what I’ve been doing has actually been making it worse! When I get impatient, I’ll stop OpenHAB, clear the cache, then reboot.

My thought process was that when everything just started looking bad, that was going to leave the cache in a bad state as well.

So going forward, I’ll try some patience before a reboot.

Thanks for the quick response, and for all you do!

Minor (in my case anyway as it only needed a few items to be updated) issue. After upgrading to 2.5.9 all my group items created in paperUI lose their base type & function attribute and have to be re-entered. Does not seem to affect definitions in files.

Hi everbody,

yesterday I had a strange issue.
My system is installed on RPI 3B+, running openhabian since years.
I updated my system on monday 21th september from 2.5.8 to 2.5.9.
The only change I’ve done afterwards, is deinstalling the “old” v1 version of the wol binding
and moving over my wake on lan items to network binding (2.5.9), as this is newly
supporting wol.

Everything work perfectly until yesterday evening (Fritday 25th september 22:38)

This occured:
Suddenly the rule engine stopped to worked. No rules has been executed anymore!
I received sensor values from all of my binding and I was able to switch
lights and sockets thru all my bindings manually (in sitemap)

I restartet OH and since then everything is working again.

The only error which was shown in openhab.log is:

2020-09-25 23:32:05.652 [WARN ] [mazonechocontrol.internal.Connection] - Parsing json failed
2020-09-25 23:32:05.675 [WARN ] [mazonechocontrol.internal.Connection] - Illegal json: {“playlists”:{“Andreas Gabalier”:[{“entryList”:null,“playlistId”:“cd99bd5d-b964-4301-82c7-e494d521ea48”,“title”:“Andreas Gabalier”,“trackCount”:19,“version”:“13”}],“Austropop”:[{“entryList”:null,“playlistId”:“ccc1f663-a103-4511-962a-a27de1f70507”,“title”:“Austropop”,“trackCount”:26,“version”:“27”}],“Austropop2”:[{“entryList”:null,“playlistId”:“8a2151fc-c722-445d-96be-1a8693cd06b6”,“title”:“Austropop2”,“trackCount”:1,“version”:“2”}],“EAV”:[{“entryList”:null,“playlistId”:“aa839d0a-2b31-4101-9800-7dee602b0afc”,“title”:“EAV”,“trackCount”:13,“version”:“14”}],“Meine Favoriten”:[{“entryList”:null,“playlistId”:“4f904480e45e456eb3c4309b69f40cb9”,“title”:“Meine Favoriten”,“trackCount”:0,“version”:“1:1008991531”}]}}

But this error there since 17th september (also in version 2.5.8). It’s hopefully fixed in 2.5.10 version of the binding:
This error is discussed in Release Candidate and Support: Amazon Echo Control Binding

Attached you can find openhablog in the timeslot 25th september 22:00:00 - 23:59:59
(cat /var/log/openhab2/openhab.log | grep "2020-09-25 2[23]:")

So I’m not quite sure if this was the root cause of the stopped rules engine!

As I’m running OH since years and I never had this issue, the question to all of you is, if someone else having this incident also?

What I’ll do next.

  1. Having an eye on this, if it comes up again
  2. IF so, I’ll restart OH and stop amazon echo control binding, and have a look further on.

I hope, that this was a “one time error”, but at the moment I’m not sure about this.


openhablog.txt (11.2 KB)

1 Like

This is interesting as I observed something similar. I run OH in a docker container and after upgrading to 2.5.9, with several restarts as I always perform following an upgrade, I modified my items and rules to take advantage of the wol feature in the Network Binding, and removed the 1.x WOL binding. That evening and next morning several of my rules failed to fire (mostly cron and rules containing timers). I just figured it was gremlins, so I updated my docker again with 2.5.9 and restarted a few times. Since then I have not noticed any issues, but it’s only been a couple of days. Coincidence? Perhaps, but odd nonetheless. Otherwise things seem fine with new Network Binding and other 2.5.9 updated bindings.

I can agree that mostly my rules with timers and cron failed.
I hope, that the error doesn’t come back, let’s see in the next days

same on me last night :frowning: - rule engine stopped working
that seems to be the moment it happens:

2020-09-27 01:17:09.410 [INFO ] [.smarthome.model.script.Notification] - Dispatch info: Yamaha receiver ist offline!
2020-09-27 01:18:12.286 [ERROR] [] - Unexpected exception while processing MQTT message. Closing Netty channel. CId=DVES_5DE173 Connection reset by peer

2020-09-27 01:47:26.539 [INFO ] [.smarthome.model.script.Notification] - Dispatch info: Yamaha receiver ist offline!
2020-09-27 01:47:56.260 [INFO ] [.smarthome.model.script.Notification] - Dispatch info: Xiaomi Robot ist offline!`

Are you also using the wake on lan function of the new network binding?

I don’t use the network binding.
Actually I think the rules engine didn’t stop completely.
I could watch log-entries from my rules in the logfile.
But no items (different bindings) at all have received commands

I discovered the same problem with rule engine. If I change .rules to often or reload .items file which causes rule files reload triggered, the rule engine run into a problem. It looks like the rules are working but the new changes are not imported. I can fix this by restarting rule engine from console.

And it looks like the cron engine run into a problem too. No cron jobs will be triggered anymore until it is restarted.

OK, looks like there’s an issue upcoming on 2.5.9?
Do you also use the 2.5.9 network binding or the amazon echo binding?

How do I restart rules or cron engine manually?

Thank you

This error exists in OH 2.5.8 too. I use the network binding but not the amazon echo binding.

I restart the rules engine by console if I see that problem. To detect it I use:

rule "System started file xxxx.rules"
        System started
        logInfo("Logger", "System started has triggered in xxxx.rules")

If I don’t see this in log file after saving .rules-file I know that the rules is not reloaded anymore.

OK. what is the command to restart rules engine?

bundle:restart "openHAB Core :: Bundles :: Model Rules Runtime"

or use the number of the bundle you can get by bundle:list

OK Thanks. Is there an other bundle, which is responsible for the cron rules?

It looks like cron jobs are not affected. It was a false positive from my side. My cron jobs are all working, and even it looks like all rules are still working, only not updating with last rule changes which were done by saving rules file.

More investigation are needed here. Above was mentioned that rulesare workign but items do not get updates. Full error not clear for me. What I can say until 2 days of running on OH 2.5.9 that it is working as expected if I do not change a rule.

A post was split to a new topic: OH stops after a day wir OutOfMemory

Hello Markus
hi Markus
can you please contact me at
I would like to talk to you about the integration of Shelly in openHAB. Allterco is interested in you