OpenHab 2.5 to 3.1 Rules page not loading

Used Openhabian to upgrade from 2.5 to 3.1. Worked really well. Only issue was the Rule page kept saying loading, but didn’t load. Rules were all ngr in Openhab 2.5 .

Had a good look on the forums and ended up looking in /var/lib/openhab/jsondb//automation_rules.json. Eventually spotted that one rule had slightly different order/syntax of some configurations. Changed it and now the Rule page loads.

Incorrect syntax :

"uid": "ce01a778-cafe-40f5-a253-948610da5a15",
"tags": [],
"visibility": "VISIBLE",
"description": "EnableHolidays"

Correct syntax :

"uid": "ce01a778-cafe-40f5-a253-948610da5a15",
"name": "EnableHolidays",
"tags": [],
"visibility": "VISIBLE"

So this worked for me, all of which i got from a collection of other posts :

sudo systemctl stop openhab.service
nano /var/lib/openhab/jsondb//automation_rules.json
sudo openhab-cli clean-cache
sudo systemctl start openhab.service

Many thanks to the developers, especially for OpenHabian :), and to the support on this forum.