openHAB 2.5.x Patch Releases

Had the same issue and I fixed it by using the following repository for stable:
deb https://dl.bintray.com/openhab/apt-repo2 stable main

1 Like

According to our official documentation the official stable repo is in bintray.

Corrected, Thank you
Took me a few times looking at my apt source to see what I was doing wrong,

A quick message to let you know that the Freebox binding is no more working in distribution 2.5.5, the authentication to the server is systematically failing.
I already proposed a fix, I hope that it will be merged quickly.

2 Likes

something has changed again and previous logging from jsr233 rules has stopped working. I don’t see any changes in the changes list that could impact this. It is working correctly with 2.5.3 and 2.5.4 releases.

Someone else reported something similar and it was resolved by touching the org.ops4j.pax.logging.cfg file…

That sounds more like a workaround than a resolution.

have not yet tried this, but curious how this will solve the issue if the openhab process is started from 0?

That’s because it is a workaround. I’ve seen this happen very rarely since before 2.5M2, but I update files, clear cache, and restart OH a LOT more often than the average user. The actual issue has not been identified, but the symptom is that logging stops for some loggers. The only updates in this release were to add-ons… there were no updates to scripted automation, the update script, or logging. There may be something glitchy with the update process, but it is not specific to this release. It’s something to keep an eye on, but discussion about it does not belong in this topic.

I’m not sure what you mean by this, but if you open a new topic, I’ll be happy to discuss there.

1 Like

Yes, this is another topic that should be addressed. For example, 2.5.4 release (https://github.com/openhab/openhab-distro/releases/tag/2.5.4) did not list any changes to the Xiaomi Mi binding, however, there were changes (a bug to be precise) that made the binding unusable for 2 and more gateways. That means the release notes can not be taken as the main source of truth.

1 Like

hmm, could it be such errors are not written to openhab.log? I had a dozend of them, but grep now finds nothing. The error indicated that.getEvent() and .getChannel() are not methods of the receivedEvent base class.

OH version is 2.5.0 Release Build

just doing an apt-get upgrade to upgrade to the latest released OH version and bundles

I now see 2 config files for the Ops4J PAX logging:

/var/lib/openhab2/etc/org.ops4j.pax.logging.cfg
and
/var/lib/openhab2/config/org/ops4j/pax/logging.config

Maybe they interfere?

I managed to upgrade to OH 2.5.5 but now I get again the same error when running apt update:

openhabian@openhab:~$ sudo apt update
[sudo] password for openhabian: 
Hit:1 http://deb.debian.org/debian buster InRelease
Get:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]                                                        
Get:3 http://archive.raspberrypi.org/debian buster InRelease [32.6 kB]                                                           
Hit:4 https://repos.influxdata.com/debian buster InRelease                                                                       
Hit:5 https://packages.grafana.com/oss/deb stable InRelease                                                                      
Hit:6 https://repo.z-wave.me/z-way/raspbian buster InRelease                                                                     
Ign:7 https://openhab.jfrog.io/openhab/openhab-linuxpkg testing InRelease                                             
Hit:8 https://deb.nodesource.com/node_10.x buster InRelease            
Err:9 https://openhab.jfrog.io/openhab/openhab-linuxpkg testing Release
  Unknown date format Bad header data [IP: 35.231.52.82 443]
Get:10 http://archive.raspberrypi.org/debian buster/main armhf Packages [330 kB]
Reading package lists... Done     
E: The repository 'https://openhab.jfrog.io/openhab/openhab-linuxpkg testing Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Maybe it’s an intermittent problem.?

There are no testing releases. Just stable & unstable.

Does that mean that the documentation at https://www.openhab.org/docs/installation/linux.html ( search for testing ) is not up to date / outdated ? The documentation distinguishes between stable, testing and beta releases aka unstable aka snapshots

I assume there may be testing releases as openHAB 3 gets more stable.

Since they are not developing the 2.x core any longer, they just do unstable with monthly stable releases for updated bindings.

1 Like

Sorry, but even if that is or would be the case as far as I understand I still should be able to get previous testing releases without any any error message, right. And it is not the step when I try to get the package it is the step when I download information about the available versions.

root@cubietruck:~# aptitude update
Hit http://ports.ubuntu.com xenial InRelease
Get: 1 http://ports.ubuntu.com xenial-security InRelease [109 kB]
Get: 2 http://ports.ubuntu.com xenial-updates InRelease [109 kB]
Hit http://phoscon.de/apt/deconz xenial InRelease
Get: 3 http://ports.ubuntu.com xenial-backports InRelease [107 kB]
Get: 4 https://deb.nodesource.com/node_7.x xenial InRelease [4,634 B]
Hit https://apt.armbian.com xenial InRelease            
Ign https://openhab.jfrog.io/openhab/openhab-linuxpkg testing InRelease
Get: 5 https://openhab.jfrog.io/openhab/openhab-linuxpkg testing Release [11.6 kB]
Get: 6 https://openhab.jfrog.io/openhab/openhab-linuxpkg testing Release.gpg [821 B]
Get: 7 http://ports.ubuntu.com xenial-updates/main armhf Packages [1,071 kB]
Get: 8 http://ports.ubuntu.com xenial-updates/universe armhf Packages [924 kB]
Hit https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages [7,609 B]                                                                                                                                                                       
Err https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages                                                                                                                                                                                 
  Hash Sum mismatch
Fetched 2,336 kB in 9s (248 kB/s)                                                                                                                                                                                                                                 
W: Failed to fetch store:/var/lib/apt/lists/partial/openhab.jfrog.io_openhab_openhab-linuxpkg_dists_testing_main_binary-armhf_Packages.gz: Hash Sum mismatch
E: Some index files failed to download. They have been ignored, or old ones used instead.

I also do not expect to the see ‘unknown date format bad header data’ error message in case an new version is being tested.

In case I do

apt-cache madison openhab2

I get

  openhab2 |    2.5.5-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
  openhab2 |    2.5.5-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main all Packages
  openhab2 |    2.5.4-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
  openhab2 |    2.5.4-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main all Packages
  openhab2 |    2.5.3-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
  openhab2 |    2.5.3-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main all Packages
  openhab2 |    2.5.2-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
  openhab2 |    2.5.2-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main all Packages
  openhab2 |    2.5.1-2 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
  openhab2 |    2.5.1-2 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main all Packages
  openhab2 |    2.5.1-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
  openhab2 |    2.5.1-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main all Packages
  openhab2 |    2.5.0-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
  openhab2 |    2.5.0-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main all Packages
  openhab2 | 2.5.0~RC1-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
  openhab2 | 2.5.0~RC1-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main all Packages
  openhab2 | 2.5.0~M6-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
  openhab2 | 2.5.0~M6-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main all Packages
  openhab2 | 2.5.0~M5-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
  openhab2 | 2.5.0~M5-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main all Packages
  openhab2 | 2.5.0~M4-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
  openhab2 | 2.5.0~M4-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main all Packages
  openhab2 | 2.5.0~M3-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
  openhab2 | 2.5.0~M3-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main all Packages
  openhab2 | 2.5.0~M2-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
  openhab2 | 2.5.0~M2-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main all Packages
  openhab2 | 2.5.0~M1-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
  openhab2 | 2.5.0~M1-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main all Packages
  openhab2 |    2.4.0-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
  openhab2 |    2.4.0-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main all Packages
  openhab2 | 2.4.0~RC1-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
  openhab2 | 2.4.0~RC1-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main all Packages
  openhab2 | 2.4.0~M8-1 | https://openhab.jfrog.io/openhab/openhab-linuxpkg testing/main armhf Packages
...

and more.

So I do not see any 3.X version in the testing repo but e.g. 2.5.5-1
Looking into https://openhab.jfrog.io/openhab/openhab-linuxpkg/pool/main/ shows different version numbers but no 3.X yet. 2.5.6 I assume belongs to unstable.

Try dropping armhf from the repo I think I saw somewhere that it may not be needed any longer.

My ubuntu apt config was not correct. Check the instalation instructions.

1 Like

Then this must have been a recent change. There’s the stable releases, the milestone releases (which my setup is tracking) and the daily snapshot releases (unstable).

So far I automatically received updates up to 2.5.4. Only 2.5.5 gives problems with the repository.