Openhab 2 beta 3 bindings not downloading/ installing

Hi
Sorry if it has been ask before, but I can’t find it.
I downloaded and installed “openhab-online-2.0.0.b3.zip
https://bintray.com/openhab/mvn/download_file?file_path=org%2Fopenhab%2Fdistro%2Fopenhab-online%2F2.0.0.b3%2Fopenhab-online-2.0.0.b3.zip

on a intel NUC with Ubuntu Server 16.04 LTS

When I go to the Paper UI -> extentions and then try to install the Z-wave or Sonos binding it’s not happening

I click on the INSTALL button, the button becomes a turning circle and noting else happens

Do I have to download the binding first like in OH 1?
If so where do I put it? /addons? For 2.0 bindings

I see the topic , but its nog clear to me what “I fixed it” means.

Installed the off line version
https://openhab.ci.cloudbees.com/job/openHAB-Distribution/lastSuccessfulBuild/artifact/distributions/openhab-offline/target/openhab-offline-2.0.0-SNAPSHOT.zip

I have the same problem.

in /userdate/logs/openhab.log I see

2016-06-12 01:25:29.743 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-package-standard': Error restarting bundles

and /userdate/logs/events.log shows

2016-06-12 14:06:08.347 [ExtensionEvent ] - binding-zwave: org.apache.karaf.features.internal.util.MultiException: Error

I had the same issue last night. It just so happened that last night was also my first try with OpenHAB2 so i’m not exactly super impressed, heh. I then had site 404 issues heading to Git to check some things. I am now assuming the issues stemmed from Git and not being able to download the bindings properly.

I’m waiting until tomorrow when I get more time to play, and hopefully Git has their issues sorted (if that’s the problem)

Hi,

OpenHAB 2 automatically downloads and installs bindings, so there should be no need to manually download them as in OH1.

I use the OH2 on-line distro to keep up to date with releases, and running on a slow ARM CPU Raspberry Pi 2 it can take up to 1- 2 hours (yes really!) before OpenHAB detects all the dependencies needed as the Eclipse Smart Home / Karaf platform seems to progressively download Java packages one by one.

During this time, many unexpected and confusing load of error messages are often created as a function is called, found to be missing, located, and downloaded.

I have also seen the web-GUI appear to spin for a long time after hitting the install button. Sometimes, the binding has been downloaded fine and it just takes a refresh of the config GUI to show the actual installed state.

I’ve not used the off-line packages, but would expect the download delay to be almost zero, meaning a quick refresh of the page may show the requested binding as installed, and ready for config and use.

1 Like

Thanks for pointing that out, I will try with a clean install and have more patients and see if it works.

Another top tip is to build up slowly - I’ve made plenty of simple mistakes like missing a character in a config file and spent hours failing to find the root cause by looking for complex issues.

Get something working, then add new stuff in stages.

OH2 uses config files less, but if something breaks have a means of stepping back to a known working state. A tar backup file of /opt/openhab can save your sanity!

I’d suggest working with the OneWire or Astro bindings first for experience as they are simpler and more transparent for debug.

File parsers can fail silently, and most docs are OH1 not OH2 so watch out for simple stuff like comment formats (bash # verses C++ //).

Z-Wave is changing at a high rate, and I can see big code changes coming soon so expect the unexpected. Sadly, I have dimmers which use secure Z-Wave Plus which don’t quite work yet, although simple switches and sensors are fine.

Again, build up slowly… and good luck!

Yes, if you have enough space on your flash memory, I would always recommend the offline distro. Karaf does not seem to be very optimized for remote installation of many features at once. Doing it from the local filesystem is definitely much faster and reliable.

1 Like

I have installed openHAB2 on Raspberry Pi and have it working with rules to control my security system, and also have it working with Alexa. But now when I am trying to install/uninstall any binding (e.g. Astro) through PaperUI, I just see the spinner running forever with a message popping up saying “Error: 504- Gateway time-out”. I don’t see any error in the logs. If I refresh my browser, spinner goes away but the binding stays uninstalled. I tried rebooting Pi and clearing cache but that didn’t help. How can I get my PaperUI working again?

Had the same trouble (turning circle, seemingly no installation of anything happening) last night with the openHAB 2.0.0-3 installation on my QNAP. Turned out the reason for this behaviour was my browser, that saw no reason to actually refresh instead of using the cached site.
Switched from (deprecated) IE to Mozilla and all of a sudden it started working just fine.