Openhab 2 first start - ... can take several minutes since 1 hour


I installed Openhab2 on my Debian 7 and all seems fine.
But while the first start of Openhab2, I choosed “skip package installation” and it starts with installation of “openhab-package-minimal” (Message in the Logfile).
But the Website shows:

Please stand by while UIs are being installed. This can take several minutes.

… since 1 hour…
What can I do?

Have you rebooted the machine? Or similarly, restarted the service?

I restarted the Service and the same message appears.
Rebooting the server doesn’t help too.

Any other ideas?

If you “skip package installation”, it means that nothing, especially no UI, is installed. That’s why you can wait indefinitely for them to appear.
You need to manually install them by e.g. adding them to conf/services/addons.cfg.

Hmmm. Should that message about installing UIs be suppressed when the user clicks Skip? Perhaps have it load a message that says “Please proceed with manual configuration” or something along those lines. I can see others becoming confused by a message that says to wait for something that will never happen.

I just performed the repository install for online distro of the snapshot. I used to run the manual install of the snapshot.

I copied all my ./conf settings over to /etc/openhab2

So all my ./conf/services/addons.cfg are in place but I still get “Please stand by while UIs are being installed. This can take several minutes.” It’s been running for an hour or so and through a reboot. Logs are showing no activity.

I deleted the cache at /var/lib/openhab2/cache/* and restarted and the installs are proceeding as expected.

Agreed. This PR fixes that.

1 Like


sorry for the late response.
Thanks for the help.Installing the UIs manually solved the problem.
It`s a good idea imo to suppress the message when the user skipped the installation.

Message suppression has already been merged with the latest builds.

I got the same problem.
At the first time start, it did show up UIs perfectly.
But the next reboot, it says:“Please stand …”.
I’ve been waiting for hours and it’s very frustrating. I think OH2 is quite unstable at the moment.
What should I do? I use manual repository

Look at the logs for errors. There is some error occurring and without that we can’t help.