OpenHAB 2 not displaying demo widgets?

I just downloaded the latest OpenHAB 2, moded conf/services/addons.cfg to set “package = demo”, started server, went to BasicUI, alas no widgets displayed. Is documentation in error or has something been missed from latests drop?


I did the same thing yesterday but forgot to remove the # character from in front of “package”. Everything worked after that.

Failing that, have you tried a restart of OH2?

LOL, I actually read the instructions so definitely no # in the way and yes, three times I tried starting OH2.

Did you edit addons.cfg before you started openHAB for the first time?


The reason I ask is the first time you start openHAB for a fresh install it reads addons.cfg and then installs the bindings and demo files.

What I did after I realised my mistake was to save a copy of my edited version of addons.cfg then delete the contents of the openHAB directory ( i.e start again). I then extracted the zip file again and copied in the addons.cfg file and then start openHAB 2.

Everything worked after that. Hope this helps.

Oh, the old blow everything away and not understand the why approach! ROFLMAO, is this a Microsoft Product?? Okay, I’ll play that game and delete everything.

Nope. I deleted everything from openHAB as suggested. Modified addons.cfg. But now the server starts but I get a 404 error??

I re-deleted and now I am trying the offline install. Stay tuned.

Ah. The download page has two options an Offline and Online version of OH2. I had downloaded the OnLine, jumped to the, and kaput as the link on the demo instruction has a link to the OffLine version. I guess I should have the prior knowledge pill before tackling things, which is it the red or the blue? Then of course you’ve the “core” download (is that the 1.8x?. Noobie unfriendly zone :wink: All good, I have widgets now.

Yes, I also found you need to use the “offline” distro. That is what the link in the documentation points to. I missed this as I already have a development and production system running openHAB 2. Yesterday I needed to have an instance of the demo running for another task.

The documentation needs a little tweaking, I think I might look at how I can help with that.

Good stuff!

One thing to remember is that if you use the online version, when you first start the system it will continue to download data from the server - this will take more time. I don’t know if this explains why you couldn’t get the online version to work, but it’s just a thought as I know the online version shows the demo package here.