Openhab 2 + Plex Binding

Hello there,

I have installed openHab 2 on my linux server few days ago. I coupled my heating controllers as well as my philips hue system to openhab. Everything is working fine.

At the moment, I am working at telephone ringing events. I want to pause my sonos system (if it is playing) as well as my plex client in living room (if its playing) when someone is calling me. After that when the call is finished I want to resume the playback. For sonos it is working perfectly. But for Plex there is one problem I am facing at. I can see all the information of my Plex Client. What it is playing, if it is playing, the progress is also showing. But I have no possibilities to control the client. I my case I want to pause/stop the playback and then I want to resume it.

I assume that my plex.cfg is correct. I got my token and so on. I have all the items from the bindings wiki (Plex-Binding.

Dimmer PlexTVVolume		"Volume"		<video>		{plex="2v7etrpwhanxxxxxxxxxx#playback/volume"}
Switch PlexTVPause		"Pause"			<video>		{plex="2v7etrpwhanxxxxxxxxxx#playback/pause"}
Switch PlexTVPlay		"Play"			<video>		{plex="2v7etrpwhanxxxxxxxxxx#playback/play"}
Switch PlexTVPlayPause	"PlayPause"		<video>		{plex="2v7etrpwhanxxxxxxxxxx#playback/playpause"}
Switch PlexTVStop		"Stop"			<video>		{plex="2v7etrpwhanxxxxxxxxxx#playback/stop"}
Frame label="Plexsteuerung" {
		Switch item=PlexTVPlayPause
		Switch item=PlexTVPlay
		Switch item=PlexTVPause
		Switch item=PlexTVStop
		Slider item=PlexTVVolume

But when I am triggering for example the PlexTVPause Switch, nothing happens. And after a few seconds the switch is triggered again to its previous state. So I think with that logic I am not able to control my Plex Client.

What can I do to control my Plex Client? Has anybody a working solution for me?

With best regards from Germany

What is your Plex client running on? I have similar options in being unable to control my Plex device with Play, Pause, etc when using the built in Plex App on my Samsung TV.

Yet it did work on my Android tablet. If you can, possibly try Plex with another client and see what happens.

I am running the Plex client on Google Chromecast Stick. So the problem lies there, right?

Its possibly the problem. If you can try with Plex on an Android (Tablet) or perhaps even on a Windows PC and see what you can do.

If you can pause, play etc, on another device, then you can eliminate and determine if it is the chromecast stick.

You can also try the chromecast binding. It should be able to pause playback on the chromecast regardless of the source.

I can pause/play via chromecast, but I can’t pass pause/play to a standalone player.