openHAB 3.0 Release Candidates discussion

Hi All!
Tried to upgrade from M5 to RC1 in docker by replacing with new image. It got stuck in endless loop as it says “You are already on Openhab 3.0.0.M5” and restarts up upgrade process. If I put M5 image back it boots properly.

When the upgrade detects that the home directory is still /var/lib/openhab2 it changes it to the correct path. I hadn’t realised that openHABian still uses the openhab user for frontail (it shouldn’t do (cc @mstormi)). I’ll release a workaround.

1 Like

It’s probably the Portainer issue described in the README:

1 Like

Yes, when using portainer you have to delete the ‘OPENHAB_VERSION’-Environmentvariable of your OpenHAB-Instance before doing the upgrade.

1 Like

Right it shouldn’t and I’d think it doesn’t on fresh installs in quite a long time. If you have installed openHABian/frontail before this got fixed though you’ll still have the old user. Re-installing frontail via menu might help there.


6 posts were split to a new topic: Migration question

The ‘RC1-2’ might be the version with the fix, that @ysc mentioned above, already applied (but I’m not 100% sure)

In that case your commands would be:

sudo apt install ./openhab_3.0.0~RC1-2_all.deb

If you do a fresh install anyway, I would try it out and having a look in the logs after install - if anything looks good, you’re probably good to go. :slight_smile:

The ‘-2’ at the end is just for the .deb packaging, it fixes the following install error.

The content after the install is identical and is now given to anyone who uses the milestone/testing repository. Unfortunately that does mean the same issues are present.

1 Like

Thanks for the clarification!

I got the same problem again as I had when upgrading to M5 (from M3): For some reason the Ephemeris bundle didn’t start. So there was loads of errors relating to that in the log. Simply restarting the bundle makes everything work as intented. Anyone else seen this?

On my upgrade the log4j2.xml was replaced automatically (upgraded using apt on a Debian server), so no smarthome.event there to replace. However, I seem to have the same problem anyway. Nothing in events.log and when doing a log:tail in Karaf I see no status changes. Anyone has a workaround?

Just noticed another huge problem. OH doesn’t read my .rules files anymore. The rules in the GUI works fine, but the rules I still have in files are nowhere to be found. Anyone else?

Beginning to feel I shouldn’t have upgraded to this RC :frowning:

edit: When editing the rules files my openhab.log says it’s loading them. But it doesn’t…

There seems to be something wrong in your installation, as rule files are working here without any issue.

Ok. Questions is what… It worked perfectly well before I upgraded from M5…

Could you try to do a

log:set INFO openhab.event

in your openHAB console and see if this will bring back the logging of events? We might then see clearer on what is happening on your system.

Nope, that didn’t do any difference :frowning:

Can you post what a openhab> log:get gives you?

Logger                                             │ Level
ROOT                                               │ WARN
javax.jmdns                                        │ ERROR
javax.mail                                         │ ERROR
openhab.event                                      │ INFO
openhab.event.AddonEvent                           │ ERROR
openhab.event.InboxUpdatedEvent                    │ ERROR
openhab.event.ItemAddedEvent                       │ ERROR
openhab.event.ItemChannelLinkAddedEvent            │ ERROR
openhab.event.ItemChannelLinkRemovedEvent          │ ERROR
openhab.event.ItemRemovedEvent                     │ ERROR
openhab.event.ItemStateEvent                       │ ERROR
openhab.event.RuleAddedEvent                       │ ERROR
openhab.event.RuleRemovedEvent                     │ ERROR
openhab.event.RuleStatusInfoEvent                  │ ERROR
openhab.event.StartlevelEvent                      │ ERROR
openhab.event.ThingAddedEvent                      │ ERROR
openhab.event.ThingRemovedEvent                    │ ERROR
openhab.event.ThingStatusInfoEvent                 │ ERROR
openhab.event.ThingUpdatedEvent                    │ ERROR
org.apache.cxf.jaxrs.sse.SseEventSinkImpl          │ ERROR
org.apache.karaf.jaas.modules.audit                │ INFO
org.apache.karaf.kar.internal.KarServiceImpl       │ ERROR                │ ERROR                     │ OFF
org.apache.sshd                                    │ WARN
org.eclipse.lsp4j                                  │ OFF
org.jupnp                                          │ ERROR
org.openhab                                        │ INFO
org.ops4j.pax.url.mvn.internal.AetherBasedResolver │ ERROR
org.ops4j.pax.web.pax-web-runtime                  │ OFF

Ok. Did another restart of openHAB and suddenly everything works. My .rules files are read correctly, I get events in my log and Ephemeris was started without problems. So I still don’t have any idea what the problem actually was. Anything worth doing any continued digging into?

FWIW I had all my rules not triggered after I upgraded, they ran fine if run manually but triggers didn’t work for some reason. After restarting they now work well.