openHAB 3.0 Release Candidates discussion

I guess, there is still some kind of misunderstanding.
You don’t need the App on iOS devices to access the dashboard remotely.
In Safari, go to

and sign in, you should now see the following:

Click to access your dashboard should lead you to your openHAB

Now add it to your homescreen

Only Culprit by using it this way, you won’t have the nice icon. But this will be implemented later within the app.

If this does not work for you, then there is something wrong within your installation.

A post was split to a new topic: InfluxDB not working after upgrade to OH3

2 posts were split to a new topic: Hue binding exceptions in OH3RC2

2 posts were split to a new topic: Yio binding

Weird, normally you get the icon. It’s probably because of the basic auth you have on myopenhab.

A post was split to a new topic: Slider scaling on OH3

Yes iOS is really picky. If have my instance running behind a reverse proxy with client certificate authentication. This will also keep it from using the icon on the Home Screen. Thus, I would really like to see the main UI be integrated into the iOS app.

Thanks for taking time to respond to my issue. I understand that that I should be to access the dashboard directly from Home using a standard web browser such as Safari. However it does not work for me with OH3. It does work if I’m running OH2 however and I have been using it with OH2 for almost 2 years now. My point was that not only does direct access from Home not work, but also my iOS apps also do not work. All give me a time out 500 or 504 error. However, strangely, at least to me, is that Notifications/Messages to my iOS device from the server work just fine, so some level of connection is established. As you say it may be an installation problem, or in my case a migration issue as I am running Dockers, but I tried a clean install without migrating and I saw the same problem. I will continue to evaluate and report back if I find a solution or the root cause.

I am not talking about accessing your dashboard from home.
My Screenshots are showing a remote connection through to my OH3 installation. So it is proven working and not only for me.

A post was split to a new topic: Colorpicker in OH3

I noticed two problems on my OH3 installation:

  • With an influxdb v1 database, OH always read historical historical state of switch items as OFF. The value is well stored in the database (I can see it with grafana). It seems linked to these posts:
  • File global variables (with var keyword) in old DSL rules are always null when initialized outside any rule. File global constants (with val keyword) are OK.

Shall I open new issues on github?


I have the same issue, historical switch items are always OFF. Also see my post here:

SOLVED: I went back through my notes and realized that I had the same problem when I updated from 2.4 to 2.5 wherein I was unable to use to access my dashboards. The root cause of the problem is that I am running a high core count (32 core) server and Jetty chokes. The solution is to either pin the Docker to use only 4 cores or modify the services/runtime.cfg. I had made the modifications to my 2.5.9 installation but OH3 changes from “eclipse.smarthome” to “openhab” and those changes have to be done manually.

For future reference: in Openhab 3.0 org.eclipse.smarthome.webclient has changed to org.openhab.webclient. So it becomes:



Thanks to @mhilbush and @arjanmels for the fix as now my OH3 is running without any issues.

UPDATE: My issue is definitely a Docker problem unique to my installation. I haven’t yet resolved it, but I was able to install OH3 on my Server using a VM and it worked fine, so not a network or OH3 problem, but a local docker install issue. Thanks again for responses.

My apologies. My shorthand seemed to create additional and unnecessary confusion. I am using Home = as that is the Tab on the website. I also have no doubt others are able to access OH3 from, but every time I try I get

openHAB connection error: HttpClient@4016d1a5{FAILED} is stopped

I just created a fresh Docker and did a clean install and I get the same error. shows that I am ONLINE and I am able to send messages to my iOS device but I am not able to access the dashboard. I will continue to evaluate, but I am curious as to whether you are using a Docker install or another type of setup such as a Pi? I know it shouldn’t make a difference but I am trying to eliminate possible causes.

Which Docker image? Alpine or Debian? The default is Debian. I tried the Alpine image with H2 and moved to Debian due to issues.

I use debian.

1 Like

On OsX 10.15.17 Safari Pages -> Add from Model wont add widgets, instead just returns back to the pages overview screen. Firefox 84 on the same system works flawlessly.

A post was split to a new topic: Scripts in OH3

What about GPIO binding in OH3

This is at least equivalent:

1 Like

A post was split to a new topic: Issue with OH3 logging