openHAB 3.0 Release Candidates discussion

Which Docker image? Alpine or Debian? The default is Debian. I tried the Alpine image with H2 and moved to Debian due to issues.

I use debian.

1 Like

On OsX 10.15.17 Safari Pages -> Add from Model wont add widgets, instead just returns back to the pages overview screen. Firefox 84 on the same system works flawlessly.

A post was split to a new topic: Scripts in OH3

What about GPIO binding in OH3

This is at least equivalent:

1 Like

A post was split to a new topic: Issue with OH3 logging

A post was split to a new topic: Generic issue with OH3

3 posts were split to a new topic: Homekit issue

Thank you. Posted here: Possible auth bug in HTTP 3.0 binding

Interesting: the aforementioned latency only exists if the Android client (beta or release) is logged in to the OH instance. If I do NOT log in the client to the OH instance, the latency performance is effectively zero.

Suspecting some kind of DNS-induced wait-states (due to the use of a locally DNS-named OH instance e.g. openhab.mylan.tld), I checked, and discovered that I see the same performance issues whether the client is configured via a DNS name or its IPv4 address.

This issue persists even after the update to 3.0.0.Release.
I’m happy to help reproduce/debug with some guidance.

In my environment the log4j2.xml file was ok, but in the file org.ops4j.pax.logging.cfg I had to change everything from stmarthome to openhab. Now I get the events in the events.log file.

Actually that file should only contain one line:

Configuration is done through log4j2.xml.

I installed OH3 over my working OH2.5 and the file org.ops4j.pax.logging.cfg has 145 lines. I will try to change everything to only 1 line

Make sure that file has the correct content:

It is exactly that content. I change now the org.ops4j.pax.logging.cfg to only one line and it is working.

1 Like

Good, now you are on the openHAB3 track :grinning:


I’m on OH3 (release) and these messages appear not only 33 times as in your log, but in mine I have 64 entries of this. So yes this happens in a clean install too! It’s a bit anoying seing that - any news on this?

This post has the solution to this problem, it fixed it for me:

this post also fixes this issue for me: