openHAB 3.2 Milestone discussion

I don’t mean to ask for the background why all the Smarthome/J addons have been removed from the marketplace. Just one question from a users perspective: it’s anything wrong in using these addons?

Edit: I found some explanations in the HTTP Addon Thread. I think that will do for now. Sorry for asking here again…

I have trouble with my Nanoleafs. They lock, so that I cannot use the Nanoleaf app and any effect of the lights stops (changing colors). Some times it is possible for Openhab to change to another lightsetting, but not always, and it is is not possible for Openhab to turn the panels off

That is for sure not an issue with the nanoleaf binding. Since M4 it has become extremely stable. Can you please open a separate thread and explain in detail what you are experiencing?

Many thanks to @cweitkamp for this:
implicit variable


is now available!

1 Like

Running openHABian on RPi4, after upgrading to latest openHABian version / M5 (coming from M4), all my manual installed bundles remains in status resolved. Need to run bundle:start <bundleId> to get the bundles active, which works fine.

However, if I reboot, the bundles end up as resolved once again, and “manual” start of the bundles is required.

Anyone else?

After having the system settle for a day, I can now reboot, and all my bundles become active automatically, and within reasonable time.

3 posts were split to a new topic: Errors after upgrade to M5

Moderator’s request:
People please don’t post any type of issue here just because it happens to you on latest milestone.
This thread is when you have identified issues with the code of this milestone, i.e. they started to appear in this version and are not present in earlier ones.

For anything else such as identifying your problem in the first place, determining if it’s really an undesired software behavior and which software version it is with, please open your own thread(s).
Thank you.

1 Like

uh oh… we’re being bold again… :hushed:… tbh I’m a bit lost with the semantics of that argument Markus…the grand title wherein I (and others) posted does say ‘OH 3.2 discussion’.
Admittedly my issue first appeared going from 3.1.0.M4 to 3.1 stable (so I stayed on 3.1.0.M4) BUT it is still persisting (for me) in the 3.2 Milestones! I did ask about it under a 3.1 discussion back in July but got no answers really, so it seemed reasonable/ok/not off topic to raise it here in the hope of some enlightenment… :roll_eyes:

Markus is right here - this thread is specifically meant to report regressions that come up with milestone builds and is the corresponding discussion thread for the announcements in openHAB 3.2 Milestone Builds.
Keeping the scope to direct regressions over previous milestone builds helps the maintainers to ensure that nothing was accidentally broken, which is what we all want to avoid here.

Ok, I can see your point, hopefully someone will pick up on the moved post.

1 Like

12 posts were split to a new topic: Breaking changes in 3.2?

Does anyone experience an issue with Google TTS in M5?

My google TTS has been working fine for months. The last issue was due to the google app profile not set to production, and I got that fixed back in February 2021 I think.

After upgrading to M5, I’m getting

org.openhab.core.voice.TTSException: Missing service configuration.

I have tried re-entering the Authorization Code in the main ui, but this didn’t help.

Downgrading to M4 made it work again. Also restarting Openhab (3.2M5) seems to fix it for a while.

A post was merged into an existing topic: Breaking changes in 3.2?

I am on 3.2.0.M5 and quickly tried it out with
and I can confirm that it still works well. So I would say it is not related to M5 then.

Hi, does anyone know, if 3.2.0 stable will be released tomorrow or if it is posponed according the karaf update:

Thanks in advance

A post was split to a new topic: Warning in 3.2RC1

Hi all

Did update to RC1 today and my f7-icons are not visible anymore. E.g.:



Did also a quick check with material-icons. But this does also not work. No issues with OH-Icons.
Can someone else see this in RC1?

I think this is the same issue as this one:

With final release 3.2.0 version icons are back again.