openHAB 3.2 Release discussion

As my problem has been split from this thread I’d like to come back again and want to raise hand that there are now several users complaining about Memory Leak problems. They can be reproduced - see thread here and here.
If moderators like to split this post again, then please simply delete this post. No need to restart all over again…

Just upgraded an Ubuntu 20.04LTS x86 system using apt. Smooth upgrade, working great! Thanks to all involved.

A few observations:

I noticed that openhab.log now provides more more verbose description of validation issues with configuration files. It helped me fix some sitemap validation issues logged by previous OH versions that I couldn’t figure out before (I still use a few sitemaps). Nice add. I didn’t see this in the release notes but maybe I missed it.

Z-wave BE469ZP Deadbolt - was not immediately recognized and the following entry was in the log:

ConfigStatusInfo [configStatusMessages=[]]

This was solved by manually locking and unlocking the door several times. This thread helped… Trouble with battery powered Z-Wave things

Interestingly the openhab log that included the z-wave issue described above seems to have been overwritten. I have checked all openhab.log.x files in /var/log/openhab and the log representing running OH 3.2 the first few times while troubleshooting this message appears to be missing. Logs prior to and after the upgrade are all present. Not sure how this could happen.

In any case all is well now and thanks again. I am looking forward to experimenting with the new features. Keep up the good work.

1 Like

I get the same error when simply move one level down in the sitemap menu. The error message is

Unexpected exception occurred while processing REST request.

After this comes many lines in the log with derived error messages.

The problem arises both in a browser using BasicUI and when using the Apple iOS app for OH.

This worked fine without problems in version 3.1

1 Like

Not sure if it’s different in a “3.2 clean-install”, but my in “3.2 as updated from 3.1”-install, the link mentioned in /sitemaps/readme.txt is , which leads to a 404.

The correct link should be Sitemaps | openHAB from what I can see (so a “/ui/” got included in there).

Maybe nitty-gritty-feedback, I know, but I just stumbled upon this and this would’ve made things more difficult for me three months ago, when I was trying to understand the sitemap-logic.

A post was split to a new topic: Log xml question

A post was split to a new topic: Restore problem

It’s only me that don’t see how you can install bindings on OH 3.2?
The GUI have changed in 3.2. Seems like the documentation is now outdated.
Installation of Add-ons | openHAB

the look changed a bit but the entry to start with in the menu is the same.
You need to login with your admin account.

Thanks for your reply.
Seems like I got everything now after I restarted openHAB.

I discovered the same issue. I’m monitoring energy consumption with openhab and rrd4j using COUNTER definitions like yours.
This has been working for a year with openhab 3.1 but was broken after upgrading to 3.2. All values are now zero.

I had to downgrade to openhab 3.1 to keep my use cases working.

The problem seams to be more far-reaching. I looks like rrd4j has a problem getting data when the query is done during the file update.

I can confirm that the System Info binding seems to cause issues. I also received a ton of log messages including the “jvmfield” message.
I went ahead and did a complete new setup of my openHAB instance with a backup, but the issue was still there. It was only resolved when removing the System Info binding.

I have updated from 3.1.0 to 3.2.0 but I cannot find the marketplace.
I have even enabled to show not published add-ons.
But when I go to Add-ons → User interfaces, I only see the section “Other UI Add-ons” but no widgets from the community.
And under Add-ons → Automation, I do not see rule templates from the community.
What am I doing wrong? Thanks!

I have one NPE during start about some HTTP error, but I don’t know what that is. Otherwise no exceptions, only these warnings:

2022-02-05 11:42:35.982 [WARN ] [core.karaf.internal.FeatureInstaller] - The binding add-on 'http1' does not exist - ignoring it.
2022-02-05 11:42:35.999 [WARN ] [core.karaf.internal.FeatureInstaller] - The binding add-on 'fritzboxtr0641' does not exist - ignoring it.
2022-02-05 11:42:36.002 [WARN ] [core.karaf.internal.FeatureInstaller] - The binding add-on 'expire1' does not exist - ignoring it.
2022-02-05 11:42:36.005 [WARN ] [core.karaf.internal.FeatureInstaller] - The binding add-on 'wol1' does not exist - ignoring it.
2022-02-05 11:42:36.021 [WARN ] [core.karaf.internal.FeatureInstaller] - The misc add-on 'market' does not exist - ignoring it.
2022-02-05 11:42:36.039 [WARN ] [core.karaf.internal.FeatureInstaller] - The ui add-on 'restdocs' does not exist - ignoring it.
2022-02-05 11:42:36.040 [WARN ] [core.karaf.internal.FeatureInstaller] - The ui add-on 'homebuilder' does not exist - ignoring it.
2022-02-05 11:42:36.041 [WARN ] [core.karaf.internal.FeatureInstaller] - The ui add-on 'classic' does not exist - ignoring it.
2022-02-05 11:42:36.042 [WARN ] [core.karaf.internal.FeatureInstaller] - The ui add-on 'paper' does not exist - ignoring it.

Edit 2:
After restarting openHAB, I have the marketplace stuff. Weird…

You’ve got some ancient OH2 history in your addons.cfg file. It would be wise to tidy that up, this can cause poor performance when trying repeatedly to install non-available addons.

Thanks, but there is nothing in conf/services/addons.cfg.

same here. I even stopped OH3, openhab-cli clear-cache'd my installation and still got this… strange. It’s my remote installation. Next time I’ll backup the config, put in a vanilla openhabian and restore to see, if it helps. must be some real strange config still floating around somewhere…

OK, got it. Those old addons were configured in userdata/config/org/openhab/addons.config.

1 Like

hmmm. it does contain all OH3 configuration, right? So, just remove the *1 bindings from the list?
…but why are they in there in the first place?

Legacy of OH2. addons.config is a system-built cache, it may still contain stuff that is no longer in addons.cfg etc.

so, I can just delete that file?