Openhab 3.2 VolumeStep for Speaker not working

Hi everyone,
I’ve just updated my setup to Openhab 3.2.
Everything’s good so far but I have a small issue.
When I try to bind a number item (the speaker volume) to an Alexa Metadata the only options I have for the Speaker device type are “VolumeLevel”.
The documentation on the website says that there should be also an option called “VolumeStep”, and that’s what I want because I don’t have an absolute volume for my speaker but only increase/decrease commands.
I’ve tried to force it by code but then alexa would not recognize the capability…
This is what I’m talking about:

I’ve also tried to use the option “Use discrete steps” but it doesn’t seem to work.

Here it says that it should be supported:
(openHAB Skill For Amazon Alexa | openHAB)

The speaker volume item is inside a Speaker type Group item.

Can anyone help me? Thank you very much.

This is because the change for this one was introduced after OH 3.2 release and won’t be reflected until 3.3 is released or if you switch to the snapshot version once the Main UI changes are merged.

@Matte_Goghero You are on the right track. Could you please provide the details of the item and the Alexa metadata you tried to configure?