openHAB 3.4 Release discussion

Would a link to OpenHAB docs State Description already make a difference?

Does anyone know if there is a known bug in the UI?

What kind of bug ? You need to be more precise asking such a question.

Some feedback from my update from 3.4.0 to 3.4.1 from yesterday.
Here it seems that OH and the Addons got an update.
It was needed from me, to do an manual reboot otherwise some Items were not displayed.
Also I saw, that Values and Items from my Shelly TRV Thermostat were not working.
The only way was, to delete the Shelly TRV as a thing an create them new.
Now the values are back and it seems that it works.
What else I need to look on it?

Is there a changelog from the Shelly ADDON from 3.4.0 to 3.4.1 ?


No change about Shelly binding in 3.4.1.

I have trouble with the Sonos binding, as i wrote in the two threads:
Sonos not recognized after upgrade from 3.2 to 3.3
SONOS Binding does not work after update to 3.4.1. anymore

I updated to 3.4.1 and now I’m having trouble editing my sitemap because apparently there are syntax errors which haven’t been there for earlier version of OH (I did not change the sitemap):

I read in this forum that the new line character message probably means that something is wrong in the group section, but I cannot figure out what it is since it was working perfectly before.

Not an expert on this at all, but it looks to me the message is saying there is a space after the “}”. Is there?

1 Like

Replace Group by Text and it should work. The checker is a bit more strict in the 3.4.1 version. It expects an item for the Group.

1 Like

That was it! Thank you!
The checker complained about a couple of other things (mainly charts) after I replaced all the Groups with Text but now it looks fine. :+1:

I upgraded to 3.4.1 (from 3.3) and no manual jar in the /usr/share/openhab/addon folder is loaded anymore. I’ve tried different files/jar’s, checked file permissions, restarted multiple times but no go.

Nothing in the logs indicate trying to load them even, it’s like a setting that disables manual files has been activated somehow without me knowing about it …what am I missing? :woozy_face:

In my experience, it helps to delete the files from the addons folder, wait a couple of minutes, and then add the files to the folder again. (Keep copies elsewhere before deleting…)

enable debug logging for org.apache.karaf and org.openhab then move the jar(s)

Clean the cache.

Hello all,
Is there a description about the “private Cache” feature and what is the benefit of it?

It lets UI rules preserve variables from one run of the rule to the next in a standard and universally (i.e. supported by all rules langauges) applicable manner. For text based rules you can just use a global variable.

Note the sharedCache does the same but can share data between different rules, not just the one rule.

It’s in the documentation: JSR223 Scripting | openHAB and also linked from Rules | openHAB.

I tried but there seems to be no activity when booting with files in place nor moving them out/in of the folder, nothing in the logs. It just doesn’t seem to trigger in the folder, really weird.
Also tried enabling/uncommenting the explicit folder settings (DEFAULTS PATHS) in /etc/default/openhab but that didn’t help either… is there a process/bundle that needs to be active that monitors the folder to trigger a loading of a new .jar file? something I can check? :face_with_monocle:

Thanks for helping!

Was there a change to rule functions like .toString or split?
Some of my rules where i use .state.toString.split("\\.") stopped working and only return NULL.
The item is defined as ‘Number’ and contains the battery level of a sensor with 10 decimal places.

Nevermind, it was a configuration error that wasn´t causing errors before 3.4


strange behaviour in the rule trigering…

With this rule evrything is fine:

  name: "siebendreisig",
  description: "siebendreisig",
  triggers: [triggers.TimeOfDayTrigger('07:42')],
    execute: (event) => {
  tags: ["teset", "Tsest"],
  id: "siebendreisig"

2023-02-01 07:42:17.120 [INFO ] [enhab.automation.script.file.test.js] - siebensiebenzwanzig

But with this one not but why???

  name: "siebendreisig",
  description: "siebendreisig",
  triggers: [triggers.TimeOfDayTrigger('00:01')],
    execute: (event) => {
  tags: ["teset", "Tsest"],
  id: "siebendreisig"

2023-02-01 01:29:45.079 [INFO ] [enhab.automation.script.file.test.js] - siebensiebenzwanzig

It’s a bug or a feature?

After Upgrade from 3.3 to 3.4.1 backup file increased. I found out, that under /var/lib/openhab/ a new folder “kar" was created with all add ons included.

All add ons are also stored under /var/lib/openhab/tmp/kar/*

In the main UI the option “Access Remote Repository” is enabled. The change of that option didnt bring a solution.

Further infos can be found here: After Upgrade from 3.3 to 3.4.1 backup file increased