openHAB 3.4 Release discussion

Hello all,
Is there a description about the “private Cache” feature and what is the benefit of it?

It lets UI rules preserve variables from one run of the rule to the next in a standard and universally (i.e. supported by all rules langauges) applicable manner. For text based rules you can just use a global variable.

Note the sharedCache does the same but can share data between different rules, not just the one rule.

It’s in the documentation: JSR223 Scripting | openHAB and also linked from Rules | openHAB.

I tried but there seems to be no activity when booting with files in place nor moving them out/in of the folder, nothing in the logs. It just doesn’t seem to trigger in the folder, really weird.
Also tried enabling/uncommenting the explicit folder settings (DEFAULTS PATHS) in /etc/default/openhab but that didn’t help either… is there a process/bundle that needs to be active that monitors the folder to trigger a loading of a new .jar file? something I can check? :face_with_monocle:

Thanks for helping!

Was there a change to rule functions like .toString or split?
Some of my rules where i use .state.toString.split("\\.") stopped working and only return NULL.
The item is defined as ‘Number’ and contains the battery level of a sensor with 10 decimal places.

Nevermind, it was a configuration error that wasn´t causing errors before 3.4


strange behaviour in the rule trigering…

With this rule evrything is fine:

  name: "siebendreisig",
  description: "siebendreisig",
  triggers: [triggers.TimeOfDayTrigger('07:42')],
    execute: (event) => {
  tags: ["teset", "Tsest"],
  id: "siebendreisig"

2023-02-01 07:42:17.120 [INFO ] [enhab.automation.script.file.test.js] - siebensiebenzwanzig

But with this one not but why???

  name: "siebendreisig",
  description: "siebendreisig",
  triggers: [triggers.TimeOfDayTrigger('00:01')],
    execute: (event) => {
  tags: ["teset", "Tsest"],
  id: "siebendreisig"

2023-02-01 01:29:45.079 [INFO ] [enhab.automation.script.file.test.js] - siebensiebenzwanzig

It’s a bug or a feature?

After Upgrade from 3.3 to 3.4.1 backup file increased. I found out, that under /var/lib/openhab/ a new folder “kar" was created with all add ons included.

All add ons are also stored under /var/lib/openhab/tmp/kar/*

In the main UI the option “Access Remote Repository” is enabled. The change of that option didnt bring a solution.

Further infos can be found here: After Upgrade from 3.3 to 3.4.1 backup file increased


i updated from 3.3 to the latest 3.4 version. AFter the update my HUE Bridge ( Deconz) does not come back. If i enable the Thing, it gets the status UNKNOWN.

The NUKI-Bridge stucks at status “INITIALIZING”.

I have deleted the HUE binding and installed it again, but it will not start correctly. I have configure the HTTP-Port.

Try with 3.4.2. If problem persists, please tell us what detailed status is reported by MainUI.

I have installed the newest 3.4.2 version. In the mainUi I get no error or message. The state switch from disabled to unknown instantly.

Why “disabled” ? Are you disabling your thing ?
Do you mean in MainUI, you see your thing status being OFFLINE with no status message ? That is strange.
You are talking about the bridge thing or a thing like one of your lights ?
Please show the corresponding lines in file events.log when your thing changed status.

Perhaps it is one of the following recent Issues HERE ??

I did a upgrade from the version 3.3 to 3.4.2 and disaster started for me. Before I had a stable working ebus adapter connected on adroid n2+ and address was /dev/ttyAML1 under eBus bridge. After upgrade connection no longer working. I can see only : Connecting to eBUS …
I need help with it, don’t know what’s reason and how to solve. Hardware is still the same. Only upgrade was done.

This seems to be a double post of
I am replying there.

Hi, since Upgrade to openHAB 3.4.4 - Release Build, i hab to refresh the Main UI (STRG F5) to login.
I am using Firefox 113.0.2 (64-Bit), with Edge it seems to be OK.

Hi! I was running openHAB 3.4.2 and did the following to update to 3.4.5 in openhabian-config.
Chose point 01. OpenHABian version was set to openHab 3 so I chose execute. Then chose point 02. Upgrade the system.
OpenHAB was then upgraded to 3.4.4.
Did I do something wrong? Should I do another upgrade?

This is not related to the openHAB 3.4.5 itself, so does not belong here. Please open a new topic.

Well, upgrading should be getting him the latest OH3 package but didn’t.
Eventually there’s a problem with the build or repo ?

have you found a solution for this warning?

[mqtt.homeassistant] Add support for Update component by ccutrer · Pull Request #14241 · openhab/openhab-addons · GitHub is the solution. It just needs merged.