Openhab 3 / homematic binding / CCU (raspberryMatic) not connection / Jetty start failed

Hello all, I am trying to connect the openhab 3 hometic binding to a CCU (raspberry matic)
I everytime get the error below:
Thing ‘homematic:bridge:7296dc0cfc’ changed from INITIALIZING to OFFLINE (COMMUNICATION_ERROR): Jetty start failed

I opened the firewall on raspberryMatic. it is not helping. I restarted many times the both systems.
Is there a resolution.
Regards
Markus

Please post the excerpt from openhab.log with the complete error message.

Also please give some more information about the environment your OH installation is running on.

Hello I am running OH 3.0.1 on 1 server and raspberryMatic on server 2.
The target is to import the homematic devices in openhab

openhab server: IP 192.168.178.70

here is the routing table:
root@openHABianDevice:~# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.178.1 0.0.0.0 UG 202 0 0 eth0
192.168.1.0 0.0.0.0 255.255.255.0 U 304 0 0 wlan0
192.168.178.0 0.0.0.0 255.255.255.0 U 202 0 0 eth0

raspberrymatic: 192.168.178.50

Binding: homematic

Openhab find the bridge and the device, but it is running into problems and then a communication error comes up.

2021-02-28 10:13:26.021 [WARN ] [core.thing.internal.ThingManagerImpl] - Disposing handler for thing ‘homematic:bridge:34a2b67edc’ takes more than 5000ms.

==> /var/log/openhab/events.log <==

2021-02-28 10:13:26.046 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing ‘homematic:bridge:34a2b67edc’ changed from UNINITIALIZED to UNINITIALIZED (DISABLED)

2021-02-28 10:13:26.048 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing ‘homematic:HMIP-PS:34a2b67edc:00021A498E18B5’ changed from UNINITIALIZED (HANDLER_MISSING_ERROR) to UNINITIALIZED (BRIDGE_UNINITIALIZED)

2021-02-28 10:13:33.620 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing ‘homematic:bridge:34a2b67edc’ changed from UNINITIALIZED (DISABLED) to INITIALIZING

==> /var/log/openhab/openhab.log <==

2021-02-28 10:13:43.864 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler HomematicBridgeHandler tried updating its configuration although the handler was already disposed.

2021-02-28 10:13:43.867 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler HomematicBridgeHandler tried updating its configuration although the handler was already disposed.

2021-02-28 10:13:43.954 [INFO ] [ternal.communicator.client.RpcClient] - Interface ‘WIRED’ on gateway ‘34a2b67edc’ not available, disabling support

2021-02-28 10:13:43.984 [INFO ] [ternal.communicator.client.RpcClient] - Interface ‘CUXD’ on gateway ‘34a2b67edc’ not available, disabling support

2021-02-28 10:13:44.029 [INFO ] [ommunicator.AbstractHomematicGateway] - HmGatewayInfo[id=CCU,type=CCU2,firmware=3.55.10.20210213,address=QEQ0695118,rf=true,wired=false,hmip=true,cuxd=false,group=true]

2021-02-28 10:13:59.050 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler HomematicBridgeHandler tried updating the thing status although the handler was already disposed.
2021-02-28 10:14:58.988 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing ‘homematic:HMIP-PS:34a2b67edc:00021A498E18B5’ changed from UNINITIALIZED (BRIDGE_UNINITIALIZED) to INITIALIZING

2021-02-28 10:14:59.001 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing ‘homematic:HMIP-PS:34a2b67edc:00021A498E18B5’ changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): HomematicGateway not yet available!
The ports should be open to raspberryMatic

Thanks for your help.
Markus

This problem looks like some ports are blocked.

Please double check that all necessary ports are open on the Raspberrymatic and that also all necessary ports are open on your OH server (see binding documentation for more information). On the Raspberrymatic firewall settings the settings for XML-RPC-API and the Remote Homematic Script API must be set to “Vollzugriff”.

What kind of hardware/operating system are you using for OH? In some situations you must configure an explicit callback address in the bridge. If the server you are running OH has more than one IP address OH sometimes uses the wrong address in this case you should also configure the correct one.

Hello Martin, infact I did it before. see the picture.

.
nmap shows this:

grafik
But I used a differnt server for nmap.
I got mad.
Regards

Hello, I cleaned the cache and it work for 1 minute, then it broke with the following error:
0194fa126:HmIP-RCV-1’ to inbox.

==> /var/log/openhab/events.log <==
2021-02-28 10:53:34.431 [INFO ] [openhab.event.InboxAddedEvent ] - Discovery Result with UID ‘homematic:HMIP-PS:70194fa126:00021A498E18B5’ has been added.
2021-02-28 10:53:34.472 [INFO ] [openhab.event.InboxAddedEvent ] - Discovery Result with UID ‘homematic:GATEWAY-EXTRAS-70194FA126:70194fa126:GWE00000000’ has been added.
2021-02-28 10:53:34.489 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing ‘homematic:bridge:70194fa126’ changed from OFFLINE (COMMUNICATION_ERROR): java.util.concurrent.TimeoutException: Total timeout 15000 ms elapsed to ONLINE

==> /var/log/openhab/openhab.log <==
2021-02-28 10:53:34.431 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘homematic:HMIP-PS:70194fa126:00021A498E18B5’ to inbox.
2021-02-28 10:53:34.454 [INFO ] [ng.homematic.internal.misc.MiscUtils] - Datapoint name ‘Alarmzone 1’ contains invalid characters, new Datapoint name ‘Alarmzone_1’
2021-02-28 10:53:34.472 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘homematic:GATEWAY-EXTRAS-70194FA126:70194fa126:GWE00000000’ to inbox.

==> /var/log/openhab/events.log <==
2021-02-28 10:54:19.520 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing ‘homematic:bridge:70194fa126’ changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Connection lost

==> /var/log/openhab/openhab.log <==
2021-02-28 10:54:19.516 [WARN ] [ommunicator.AbstractHomematicGateway] - Connection lost on gateway ‘70194fa126’, cause: “No Pong received!”

What does this mean?

Regards Markus

This looks like a very unstable network connection. How are your Raspberrymatic and OH server connected to your network? WiFi or Ethernet cable?

The problem could also be caused on the OH side: either the necessary ports on your OH server are not open or you have to explicitly configure the “Callback Network Address” in the bridge configuration. This is necessary if the OH server has more than one IP address or is running e.g. in a docker container.

What kind of Raspi are you using for the CCU?

BTW: I am missing the information about the used server machine and OS. Without these information I can only try to guess.

Connection lost on gateway ‘70194fa126’, cause: “No Pong received!”

Hello Martin, I am running openhab 3.0.1 on a raspberry 3B+. RaspberryMatic on a different raspberry 3B.

I got it running by setting the call back address.
I used openhab 2 over years, now I am starting with OH 3.

could you short explain me how I got an homematic IP power plug running with an item. I there a mothod to generate automatically an item of that. I tried by creating a text file. the item comes up but the channel is missing.
Regards Markus

Thanksa lot Martin, I got a first device running. I do not know whyit is working, but it works.
I linked all 5 “switch” channels to an item in the model viwe. 3 of the 5 switch channeles are working.


this is not perfect but for a first testa for now.

The call back address was that hint I needed.
Regards Markus

I am currently working on a patch that makes the callback address for most situations obsolete in the future.

Good evening everyone

I saw a similar problem.
Since OH 2.4 I enjoy the integration of HomeMatic.
I use a CCU2 and a RaspberryMatic CCU3.
Since version 3.1.0.M1 to 3.1.0-M3-1, the RaspberryMatic-CCU3 can no longer be contacted.
With version 2.5 and 3.0. (stabile) everything works correctly.
Has anything changed from 3.0 to 3.1 that I should take into account?
All ports are open.

Systems used:

  • Ubuntu 20.04 on NUC with OH 3.0 or 3.1.0-Mx,
  • CCU2, (V: 2.57.4.) works without problems with Homematic, Homematic-iP and -Wired.
  • RaspberryMatic CCU3, (3.57.4.20210320) does not work Homematic-iP (exclusively); RPi4, HMiP-RFUSB.

============
openhab.log:
2021-04-05 15:36:32.867 [WARN ] [very.HomematicDeviceDiscoveryService] - Failed to set Homematic controller in install mode
java.io.IOException: -1 setInstallMode: unknown.method name (sending setInstallMode()
true
60
1
)
at org.openhab.binding.homematic.internal.communicator.parser.RpcResponseParser.parse(RpcResponseParser.java:50) ~[bundleFile:?]
at org.openhab.binding.homematic.internal.communicator.client.BinRpcClient.sendMessage(BinRpcClient.java:82) ~[bundleFile:?]
at org.openhab.binding.homematic.internal.communicator.client.BinRpcClient.sendMessage(BinRpcClient.java:94) ~[bundleFile:?]
at org.openhab.binding.homematic.internal.communicator.client.BinRpcClient.sendMessage(BinRpcClient.java:94) ~[bundleFile:?]
at org.openhab.binding.homematic.internal.communicator.client.BinRpcClient.sendMessage(BinRpcClient.java:94) ~[bundleFile:?]
at org.openhab.binding.homematic.internal.communicator.client.BinRpcClient.sendMessage(BinRpcClient.java:70) ~[bundleFile:?]
at org.openhab.binding.homematic.internal.communicator.client.RpcClient.setInstallMode(RpcClient.java:396) ~[bundleFile:?]
at org.openhab.binding.homematic.internal.communicator.AbstractHomematicGateway.setInstallMode(AbstractHomematicGateway.java:596) ~[bundleFile:?]
at org.openhab.binding.homematic.internal.discovery.HomematicDeviceDiscoveryService.enableInstallMode(HomematicDeviceDiscoveryService.java:109) [bundleFile:?]
at org.openhab.binding.homematic.internal.discovery.HomematicDeviceDiscoveryService.startScan(HomematicDeviceDiscoveryService.java:90) [bundleFile:?]
at org.openhab.core.config.discovery.AbstractDiscoveryService.startScan(AbstractDiscoveryService.java:194) [bundleFile:?]
at org.openhab.binding.homematic.internal.handler.HomematicBridgeHandler.initializeInternal(HomematicBridgeHandler.java:115) [bundleFile:?]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515) [?:?]
at java.util.concurrent.FutureTask.run(FutureTask.java:264) [?:?]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304) [?:?]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
at java.lang.Thread.run(Thread.java:834) [?:?]

Manual integration: stays yellow, connection

Integration via “homatic.things”: stays yellow, connection … after (two) minutes: red, connection error

What am I doing wrong? where can I look for my mistake?

PS: At the moment I am working again with the stable version 3.0 without any problems …

Thank you for any ideas

Hello Urs,

first of all, when you post excerpts from log files please mark them as “pre-formatted text”, e.g. by adding separate lines with 3 backticks before and after the excerpts (there is also a button in the toolbar).

Is it correct that you are using only HmIP devices with the CCU3?

In your excerpt from the log I can see a BinRpc request. This should only be used for CuxD.

Therefore I need some more information: please enable TRACE log mode for the Homematic binding (log:set TRACE org.openhab.binding.homematic in the console). Then please restart OH 3. I would need an excerpt from openhab.log that starts with the first message regarding Homematic.

In the last weeks I have also made some improvements in the binding. You can get a test version from here: GitHub - MHerbst/openhab-addons-test

Good evening Martin
First of all, thank you very much for your valuable support.
As a non-software expert, I really appreciate this support.

Correctly recognized: I also use the CUxD on the RaspberryMatic to measure the CPU temperature and to operate Alpha heating controllers.
However, this does not make the difference. I used Debmatic beforehand. I suspected wrong security settings and therefore switched back to RaspberryMatic. A complete new installation with a few IP components produced the same result.

With CCU2 and my CCU3 / RaspberryMatic I received far too much data in the trace.
That’s why I deleted CCU2 and only integrated CCU3. But this start also gives a very large amount of data. I hope to integrate the log correctly … (Does a file upload work ???)

I will then try to install your latest version (according to your instructions).
If I should find a difference, I’ll get back to you tonight.
Thank you and greetings, Urs
OH-Logfile_2021-04-08.txt (9.7 KB)

Hi Martin With the latest file it doesn’t work either.
Tries:
feature:install openhab-transport-upnp
feature:install openhab-transport-serial
I am now trying to start the addon normally.
I’m doing something wrong … but what?
OH-Logfile_2021-04-08_2.txt (2.1 KB)

Oh wait, there seems to be a problem with the dependencies to openHAB core. I need to check whether it is possible to build a test version that run on current version or whether it will need the next milestone (M4).

The log shows an exception that I have never seen before at this position :-(.

Can you give me some information about your environment:

  • in wich environment is OH running?
  • do you have one or two CCU resp. Raspberrymatic installations active?
  • can you login to the Karaf console and issue the following command bundle:list | grep Homematic. The output contains the exact version of the binding. This would help me to find the correct position in the source code.

OH-Logfile_2021-04-08_3.txt (13.4 KB)

grep Homematic: get stuck!!!

In combination: bundle:list | grep Homematic: no reaction, new line!!!

With: source code.bundle:list | grep Homematic
gogo: NoSuchFileException: /var/lib/openhab/code.bundle:list

can you do something with it? For me it only means “train station”

Gruss, Urs

Hi Martin
Sorry, I realized that I did not answer your questions or answered them incompletely.

  • in wich environment is OH running?

    openHAB 3.1.0.M3
    Environment: FriztBox7590 with FRITZ!OS: 07.25
    Switch-Netgear-GS724TPv2
    NUC with Ubuntu 20.04 as Server (with OH, MQTT, MySQL-MariaDB, …)

  • do you have one or two CCU resp. Raspberrymatic installations active?

    In normal mode I work with an original CCU2 and with the RaspberryMatic on an RPi4.
    At the moment (to narrow down my mistake) only my RaspberryMatic is running on the RPi4.
    i have exclusively the binding Homematic, with one Thing installed: homematic:bridge:3014F711A000041709ADFD4E
    yellow display INITIALIZING

Logfile after Restart: OH-Logfile_2021-04-09_4.txt (11.8 KB)

bundle:list
Bundle-List.txt (13.6 KB)

bundle:list | grep Homematic ==> NULL (new line)

Your file (org.openhab.binding.homematic-3.1.0-SNAPSHOT.jar), I copied it into the path (/usr/share/openhab/addons/) and started it according to the instructions. I don’t see any reaction.

Did I misinterpret something?

Hi Urs,

I don’t know why the grep did not work correctly, but bundle:list shows two version:

208 │ Installed │  80 │ 3.1.0.202104031037      │ openHAB Add-ons :: Bundles :: Homematic Binding
225 │ Active    │  80 │ 3.1.0.M3                │ openHAB Add-ons :: Bundles :: Homematic Binding

The second one is the information I needed. In order to get rid of the first one that did not start correctly should remove the jar from the addons folder, stop openhab, clean the cache directory and start openhab again.

I will try to find out the reason for your problem and the reason why it is not possible to use the test version.

Hi Urs,

I think, I have found the cause of the exception and fixed it. You can download a new test version. But it won’t work with 3.1.0.M3 because there have been some updates in openHAB core after the milestone was released. I have tested the binding successfully with the latest snapshot (2319).