Openhab 3 - HTTP Binding GET-Request Issue

Hello everybody,

I have some issues by setting up the channels and items for the http binding.

In OH 2.5 I use items like
Switch Sw_01_01 “Kugeln” (Licht,EG_Flur) {http=">[ON:GET:] >[OFF:GET:]"}
to enable scenes at my lightmanager air.

Now I want the same behaviour in OH3 but I stuck at sending the “ON” command (which works) but hte item does not store the state and the “OFF” command does not work.

Where is my mistake?

I also tried to move the “control?scene=%2$s” part to command url extension. This worked as well but with the same issue.

The same toggle switch, accessed from my iphone, works like a charm. Both commands ON and OFF.


Can you plese show the YAML (“Code” in the UI). Much easier to reproduce.

UID: http:url:Lightmanager-Air
label: Lightmanager-Air
thingTypeUID: http:url
authMode: BASIC
ignoreSSLErrors: true
refresh: 1
commandMethod: GET
timeout: 3000
bufferSize: 2048
location: EG_Wohnzimmer

  • id: Sw_03_01
    channelTypeUID: http:switch
    label: Vitrine Büro
    description: “”
    onValue: “22”
    mode: WRITEONLY
    offValue: “23”
    commandExtension: control?scene=%2$s

This hasn’t got anything to do with the binding - check this:

I checked this out.
The described issue is exactly the same at my side but activating “Implicit user role for unauthenticated requests” did not solved the problem at my site.

I would add your experience to that issue, and report out what happens when you perform the actions from this post.

I got throug the whole thread again and the second to last post had the solution.

My Sophos AV is also blocking the SSE updates.
If I go to https everything works.

Thank you!

1 Like