Openhab 3 Setpoint

Hi, I managed to integrate a z-wave thermostat into openhab 3. The lower setpoint (tmeperature you want inside) works perfectly with alexa, but in the new ui of openhab 3, it only shows an analysis of the temperature, but I’m not able to change…I believe it’s a very beginners-mistake but what am I doing wrong? I managed to set the steps correctly:

I ran into this too, and I thought that it was related to my item not having a channnel. However, I agree that it’s more likely a problem with number:temperature. I can’t get either setpoint or slider to work in a BasicUI sitemap.

I have a channel…but it’s not working anyway…

Until it’s fixed, you can change it to be a number item.

Tried… doesn’t work either…it’s working in basic-ui and app, bit not in the new interface of OpenHab 3

1 Like

Okay, that’s good to know. I’m submitting a bug report in Github, so I’ll reference this thread. Post anything else you figure out here.

1 Like

Okay thanks :slight_smile:

1 Like

Hi. Can you help me as to how you have connected your z wave device? In my case, I have been using OH2 and a bridge to a Vera Mios device for z-wave connectivity successfully for some time. I set up OH3 on a separate Rpi (4) and have been able to connect to the OH2 instance using the remote openhab binding. That’s where I encountered the formatting problem. (I have not any issues with set point by the way…maybe this shouold all be moved to a different thread?)
The Mios binding is not available in OH3 (as it is a OH1 binding only). So I now have a UZB stick but haven’t been able to work out how to make this work. All the threads talk about using HABMin but that isn’t available in OH3 either as far as I can work out.

Yes, this has nothing to do with what’s being discussed in this thread. Please start a new topic to ask for help with your specific problem. :wink:

Im using a aeotec Z-Stick with an usb hub here. It’s working perfectly! Don’t worry about habmin because all the functions are integrated in the new main UI… it’s a little messy and some descriptions seem to be missing, but its working perfectly! Be sure to use an usb-hub when the Z-Stick gen 5 is not recognised…it has a hardware issue…trust me you will love the z-wave binding in oh3 :slight_smile:. If you have further problems write me a massage with the new thread…

Thanks. Once I have thoroughly sat down and made sure I definitely can’t get the UZB stick to function I will raise a new thread.

@rpwong is it only for item type number:temperature?

I am struggling with a normal number item, that main UI is always showing then a graph with the historical values and I am not able to control the the Setpoint of my room:

Number HM5_Set_Temp                 "Küche Soll-Temp [%.1f °C]"                 <temperature>     (G_Heating_Kue,G_Heating_TargetTemps) ["Setpoint","Temperature" ] {channel="homematic:HM-CC-RT-DN:XX:XX:4#SET_TEMPERATURE"} 

In Main UI it looks then like this after clicking on the room so I select the target temp:

I would expect a SetPoint as it is in OH2.5, but not a very nice graph :slight_smile:

Do you have any hint for me?

Sorry, no idea. I haven’t given this any further thought.

You can force how the MainUI displays your Item in Cells, Lists and Standalone cards.

In your case, your screenshot is for a List, so you can add the following to your metadata:


which would result in your Item configuration looking like:

Number HM5_Set_Temp "Küche Soll-Temp [%.1f °C]" <temperature> (G_Heating_Kue,G_Heating_TargetTemps) ["Setpoint","Temperature" ] {channel="homematic:HM-CC-RT-DN:XX:XX:4#SET_TEMPERATURE", listWidget="oh-stepper-item"}

This should show something similar to the below (with a different label, of course):


A little more detail available in my notes.


thank you @hafniumzinc !! that was what I was looking for! :slight_smile:

I’m gonna try this the next days, but it seems to be the solution…I have to setup a new openhab instance due to a failure…so it would take some time…

works perfectly! Thank you =)

If you are beginner with OH3, be sure to look here:

Following the link Openhab 3 Setpoint - #8 by rpwong above, it appears that a fix has been applied to OpenHAB 3.1.
Fix changing temperature via Basic UI by chris922 · Pull Request #2165 · openhab/openhab-core · GitHub