Openhab 3 Z-Wave Node Not initialized, Slow unresponsive devices

I’ve been at this for ages and not managed to fix this one.

RPi 4 Model B 8 GB
openHAB 3.3.0
Release Build
Mounted on a new SD card only (at the moment)

Z-Stick Gen5+ or Gen5 upgraded to Gen5+ firmware

Various movement sensors ZWA005 and FGMS-001
Fibaro switched and dimmers.

On system boot I get WARN messaged for most (sometimes all) of the Z-wave nodes, on each reboot the number of warn massages and nodes affected can change.

After Reboot it can take an hour or so for the network to settle down, I cannot switch anything straight away after a reboot. Once settled, everything seems to work even though I have the warnings. The response time can be slow (openhab switching a light on to the actual light coming on).

The network is also unreliable. On occasion, maybe once a day, I cannot control any Z-wave devices from Openhab. I can see data coming back and if I switch a light on manually via wall switch, Openhab switch state changes to on and the power shows the light is on. Use Openhab to switch the light off and it does not work.
Plug the stick in a PC and run Zensys, all the devices respond well and quick, I can switch lights through Zensys without issue.
Put the same stick back in the Pi , reboot and nothing, sluggish response when it eventually gets going.
Possibly related, sometimes the Pi can become unresponsive, cannot SSH onto it or access via the front end so I have to pull the plug to reboot.

Fixes ive tried so far:
Tried 2 sticks.
Tried different devices.
Updated stick firmware.
Reset stick.
Installed a fresh copy of Openhab, used my backup .zip to reinstall the config.
Reinstalled the binding
Reinstalled the stick
Just put one device back on the stick.
Reboot
Still get the error below.
That said I’ve not tried the response yet as I’ve only been looking at movement sensors.
Correct me if I’m wrong, I’m making the assumption the warning below is related to an unreliable network.

I have not tried a complete fresh install (i.e. not using my backup) as I have lots of MQTT devices and I don’t fancy setting them up from scratch.

Sample Warnings (Old messages as I only have Node 2 installed at the moment)

2022-07-05 23:18:36.718 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
2022-07-05 23:18:36.722 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.
2022-07-05 23:18:37.355 [WARN ] [nal.protocol.ZWaveTransactionManager] - NODE 8: Not initialized (ie node unknown), ignoring message.

Sample Debug (Old messages as I only have Node 2 installed at the moment)

2022-07-05 22:48:21.561 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - Creating ZWave discovery service for zwave:serial_zstick:f2eb3aaa53 with scan time of 60
2022-07-05 22:48:21.565 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - ZWave discovery: Active zwave:serial_zstick:f2eb3aaa53
2022-07-05 22:48:21.568 [INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null
2022-07-05 22:48:21.955 [DEBUG] [ing.zwave.handler.ZWaveSerialHandler] - Initializing ZWave serial controller.
2022-07-05 22:48:21.958 [DEBUG] [zwave.handler.ZWaveControllerHandler] - Initializing ZWave Controller zwave:serial_zstick:f2eb3aaa53.
2022-07-05 22:48:22.466 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:f2eb3aaa53:node4.
2022-07-05 22:48:22.489 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:f2eb3aaa53:node8.
2022-07-05 22:48:22.510 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:f2eb3aaa53:node2.
2022-07-05 22:48:22.532 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:f2eb3aaa53:node9.
2022-07-05 22:48:22.549 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:f2eb3aaa53:node3.
2022-07-05 22:48:22.554 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:f2eb3aaa53:node5.
2022-07-05 22:48:27.008 [DEBUG] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port '/dev/ttyACM0'
2022-07-05 22:48:27.042 [DEBUG] [ing.zwave.handler.ZWaveSerialHandler] - Starting receive thread
2022-07-05 22:48:27.053 [DEBUG] [WaveSerialHandler$ZWaveReceiveThread] - Starting ZWave thread: Receive
2022-07-05 22:48:27.057 [DEBUG] [ing.zwave.handler.ZWaveSerialHandler] - Serial port is initialized
2022-07-05 22:48:27.060 [DEBUG] [zwave.handler.ZWaveControllerHandler] - Initialising ZWave controller
2022-07-05 22:48:27.072 [DEBUG] [WaveSerialHandler$ZWaveReceiveThread] - Receive Message = 01 0E 00 04 00 05 06 31 05 03 0A 00 56 C7 00 5A 
2022-07-05 22:48:27.085 [DEBUG] [WaveSerialHandler$ZWaveReceiveThread] - Receive Message = 01 0E 00 04 00 03 06 31 05 03 0A 00 04 C6 00 0F 
2022-07-05 22:48:27.123 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
2022-07-05 22:48:27.123 [DEBUG] [nal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
2022-07-05 22:48:27.126 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.
2022-07-05 22:48:27.127 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.
2022-07-05 22:48:27.132 [DEBUG] [ve.internal.protocol.ZWaveController] - Event listener added.
2022-07-05 22:48:27.136 [DEBUG] [ve.internal.protocol.ZWaveController] - Event listener added.
2022-07-05 22:48:27.142 [DEBUG] [zwave.handler.ZWaveControllerHandler] - Scheduling network mesh heal for 4 hours time.
2022-07-05 22:48:29.838 [DEBUG] [WaveSerialHandler$ZWaveReceiveThread] - Receive Message = 01 0E 00 04 00 04 06 31 05 03 0A 00 3E C9 00 3D 
2022-07-05 22:48:29.849 [DEBUG] [nal.protocol.ZWaveTransactionManager] - processReceiveMessage input 0<>128 : Message: class=ApplicationCommandHandler[4], type=Request[0], dest=4, callback=0, payload=00 04 06 31 05 03 0A 00 3E C9 00 
2022-07-05 22:48:29.853 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Received msg (0): Message: class=ApplicationCommandHandler[4], type=Request[0], dest=4, callback=0, payload=00 04 06 31 05 03 0A 00 3E C9 00 
2022-07-05 22:48:29.857 [DEBUG] [nal.protocol.ZWaveTransactionManager] - lastTransaction null
2022-07-05 22:48:29.859 [WARN ] [nal.protocol.ZWaveTransactionManager] - NODE 4: Not initialized (ie node unknown), ignoring message.

Thanks in advance

John

This means that you are receiving data from devices that are not joined to the network. This normally happens if you have joined a device to the network, then reset the controller. The controller “forgets” all the devices that are in the network, but the devices still send data.