openHAB 4.0 Milestone discussion

But no rules on the system that runs OH4.M1?

Sorry wasn’t clear. 25 rules on the Rpi3. They are very simple. I will see if I can attach them.
They are DSL, no scripts, mostly Cron and counting.
HEM-refresh.rules.txt (3.5 KB)
Wattage_reports.rules.txt (6.1 KB)

The more important information is: what language. Rules and their script engines are always a good candidate for memory leaks because they are created quite often.

1 Like

More information: the RRD4j persistence began to fail about an hour and a half prior to the actual crash. Log is repetitive, but excerpt attached. I don’t know if this was the cause or the effect of low memory.
precrashlog.txt (6.4 KB)

Thx! I found the item that is causing the problem.

the Link had a Profile (hpa.js) but “JSONPATH” wasnt selected anymore. After choosing it my error changed to

[WARN ] [ofiles.JSonPathTransformationProfile] - Could not transform state ‘98952.66’ with function ‘hpa.js’ and format ‘%s’

Changing the format to %.2f doesnt help.

is there any way to transform my values in a link profile now or do i have to wait until the script transform can do that?

hpa.js contains the following:

(function(i) {
    return ((i / 100) / Math.pow((1 - (232 / 44330)), 5.255));

From the master post

Inline JS scripts in transformations and JS profiles are still work in progress.

Replaced HTTP binding by the SmartHome/J HTTP Binding and errors are gone. Also things come up without the 2 minute delay.

Bindings Miio and Daikin still show errors and delayed start.

I noticed about 40s delay after being connected to the openhab cloud and before sitemaps and Things were loading, but there were no errors in the log, just silence. Which log prefixes must I turn on to see what’s going on?

A little disappointed I didn’t get a reply to my HomeKit question. After the problems with 4.0 and other issues I’ve had (no binding support for several of my devices, near zero support on Youtube) I decided to move on. I finally made the switch to Home Assistant container and haven’t looked back.

Standards seem to be extremly high nowadays…

You could’ve downgraded back to a STABLE version instead.

Milestone releases, let alone the FIRST milestone is meant for those who are willing to test and understand that there will be issues. Nobody gets paid to work here and to provide customer support. There is certainly no mechanism within this single thread to keep track of individual issue/case, so it’s easy to get buried. Each individual developer works on things that they’re working on, there are many moving parts and they do not all monitor this forum / topics. I’m guessing sooner or later, if it’s a bug it’ll get discovered, or in the case that the problem only exists on your system, you’ll need to provide more details to make it easier for others to help you.

In any case, I’m glad that you’re happier now, that’s all that matters. This is a hobby for ALL of us, developers and users alike.


I just tried to upgrade my openhabian to openHAB 4.0.0.M1.

But Openhab doesn’t start any more. Here is the log. Any Ideas or suggestions what I can do?

2023-03-25 20:36:06.247 [ERROR] [Events.Framework                    ] - FrameworkEvent ERROR
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.xtext [128]
  Unresolved requirement: Require-Bundle: org.objectweb.asm; bundle-version="[9.4.0,9.5.0)"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.eclipse.emf.mwe.core; bundle-version="1.3.21"; visibility:="reexport"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.eclipse.emf.mwe.utils; bundle-version="1.3.21"; visibility:="reexport"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.eclipse.xtend; bundle-version="2.2.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.eclipse.xtend.typesystem.emf; bundle-version="2.2.0"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.eclipse.xtext.util; visibility:="reexport"
	at org.eclipse.osgi.container.Module.start( ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$ ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute( ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel( ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel( ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel( ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent( ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent( ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent( ~[org.eclipse.osgi-3.18.0.jar:?]
	at org.eclipse.osgi.framework.eventmgr.EventManager$ ~[org.eclipse.osgi-3.18.0.jar:?]
2023-03-25 20:36:06.260 [ERROR] [Events.Framework                    ] - FrameworkEvent ERROR
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.freeathomesystem [27]

Did you update to Java 17 first?

no, accidental afterwards

Already tried to reboot?

serveral times.

But I just restored a Backup, and with the correct sequence of updating Java from Java11 to Java17 and the openhab update afterwards it works.

I’ve problems with the netatmo binding but I think, that’s another issue.

Have you cleared cache?

Just hit this issue with OH4 M1. I didn’t have this in OH3.4. Any suggestions on debugging this further?

2023-03-26 06:20:42.457 [WARN ] [org.eclipse.jetty.util.Scanner      ] -
java.nio.file.FileSystemException: /var/lib/openhab/etc: Too many open files
        at sun.nio.fs.UnixException.translateToIOException( ~[?:?]
        at sun.nio.fs.UnixException.rethrowAsIOException( ~[?:?]
        at sun.nio.fs.UnixException.rethrowAsIOException( ~[?:?]
        at sun.nio.fs.UnixFileSystemProvider.newDirectoryStream( ~[?:?]
        at java.nio.file.Files.newDirectoryStream( ~[?:?]
        at java.nio.file.FileTreeWalker.visit( ~[?:?]
        at java.nio.file.FileTreeWalker.walk( ~[?:?]
        at java.nio.file.Files.walkFileTree( ~[?:?]
        at org.eclipse.jetty.util.Scanner.scanFiles( ~[?:?]
        at org.eclipse.jetty.util.Scanner.scan( ~[?:?]
        at org.eclipse.jetty.util.Scanner$ ~[?:?]
        at java.util.TimerThread.mainLoop( ~[?:?]
        at ~[?:?]

Also seeing this issue, could not normalize configuration for Zwave:

Does this happen all the time or did it happen once? If it happens more than once: When does it happen (immediately after starting? after some time?). What bindings are installed? Anything from 3rd party or community marketplace? Any errors in the log before?