openHAB 4.0 Milestone discussion

At least it doesn’t start the rule if I do a reload (which is the correct behavior anyway)
Test system is openHAB 4.0.0-M5

I suppose it depends on what you mean by a reload. If you change something about the rule, it should run the rule when you hit “save” given the new behavior.

Nope tested both only reload and change to the rule, nothing happend (therefor I did a sneak peek in the docs…)

My bad. Did a double check and now the behavior is completely changed.

  1. System started triggers at changed file
  2. I had more than once the same Error message:
2023-07-21 19:13:24.697 [ERROR] [internal.handler.ScriptActionHandler] - Script execution of rule with UID 'my-1' failed: An error occurred during the script execution: Could not invoke method: org.eclipse.xtext.xbase.lib.BooleanExtensions.operator_equals(boolean,boolean) on instance: null in my

Aaaand: I can switch on and off… just add some empty lines after the rule (at this time there is only one rule in the file.

The recent bug fix is System runlevel triggered rules trigger before done being saved · Issue #3713 · openhab/openhab-core · GitHub

The PR that changed the behavior I think is Trigger immediately when start level already reached by J-N-K · Pull Request #3278 · openhab/openhab-core · GitHub

Searched this topic but can’t find any mention of the Zigbee2mqtt addon not installing correctly from the menu option on OH4.
I have seen a separate thread on it. My own test version of OH4 with a Sonoff Zigbee stick (zigbee2mqtt) stopped working after a milestone upgrade.
I also remember seeing something about an addon using port 8081 but that is the port zigbee2mqtt uses.
Is it related ?
Sorry to be so vague but I’m getting on in years and my memory is not what it was……

Okay, here’s a focused example:

items/repro.items:

Number:Time Repro_Pattern "Pattern [X%1$tHX]" <time>

sitemaps/sitemaps.items:

sitemap repro label="Repro" {
        Text item=Repro_Pattern
}

Set value:

openhab:update Repro_Pattern "60 min"

Resulting sitemap:
image

BasicUI:

So it seems isolated to sitemaps.

@Lolodomo - can you reproduce?

EDIT: It seems similar to:

I’m now sure it’s a regression, so I have created:

A post was split to a new topic: Mem issues with OH4

Moderator’s request: Dear community members, please respect the posting policy specific to this thread. This is to track and consolidate issues that are
a) OH milestone specific (no OS or 3rd party software issues)
b) analysed to a reasonable extent and of interest to reasonably many users
c) identified to be related to the changes of the latest milestone versus earlier milestones.
Not anything older let alone OH3.X !

Means this thread is not to support you with your personal upgrade process so please help with this thread serve its purpose and don’t post vague, highly specific or personal-only issues with your very own upgrade experience.
If you want to help a poster, or to discuss their issue in detail, or look for help with upgrading your very own system, please open separate threads.

Thank you.

1 Like

With RC-1, back to normal behavior. :slight_smile:

2 Likes

If it’s no too late, i have this open, [openhabcloud] Updates JSON Library. by digitaldan · Pull Request #15290 · openhab/openhab-addons · GitHub , which fixes a conflict with different JSON versions loaded between the cloud bounding and other bindings. Would be great to get in if its still possible.

1 Like

I have found an issue with OH 4.0.0.RC1 - Milestone Build

If I try to add a binding the configuration becomes hosed and I get the error:

Can’t load features repository mvn:org.openhab.core.features.karaf/org.openhab.core.features.karaf.openhab-core/3.4.0-SNAPSHOT/xml/features
java.lang.RuntimeException: Error resolving artifact org.openhab.core.features.karaf:org.openhab.core.features.karaf.openhab-core:xml:features:3.4.0-SNAPSHOT: [Could not find artifact org.openhab.core.features.karaf:org.openhab.core.features.karaf.openhab-core:xml:features:3.4.0-SNAPSHOT] : mvn:org.openhab.core.features.karaf/org.openhab.core.features.karaf.openhab-core/3.4.0-SNAPSHOT/xml/features

Note that it refers to 3.4.0.

The only way that I can get a working configuration back is with my mirrored system.

Has anybody seen this? Any recommendations?

What binding are you trying to add ? Or does this happen with any binding ?

I’ve tried two or three bindings and it happens for all of them.

A piece of additional information - in a previous milestone (I don’t remember which one) I had added the beta Insteon binding. It installed fine at that time and still operates correctly but, perhaps, this problem is related to having installed a community binding.

Hi,
Probably unrelated to bugs but is the closure of 4.0 the reason for not integrating add-on improvements or it’s the usual lack of reviewers/lack of time by the add-on-maintainers?
Have some PRs pending for months already.

Cheers,
K.

That’s the main reason.

I would say it’s a combination, and also we are in the holiday season. Lately with feature and code freeze for 4.0 we have focused our time and energy on ensuring the quality of 4.0.

I can see that the first of your pull requests is already under review, but unfortunately lacking a final review/approval by the reviewer. He may have missed your comment, or simply lacking time. We usually let the original reviewer finish the review, since taking over would basically mean reviewing from scratch, which is more time consuming. Sorry for that, I will try to give him a ping.

Thanks for your contributions! With 4.0 out we will again focus on catching up with existing pull requests, and your Solax binding was also reminded by a maintainer recently. :slightly_smiling_face:

1 Like

Great. Thank you very much! Appreciate that! :slight_smile:
Sorry for the off-topic…

Thanks @ccutrer

Can a moderator close this topic ?