openHAB 4.2 Milestone discussion

Thanks for double confirmation that it was definitely the new libraries that have fixed it for you. Please do not discuss it further in this thread, as its role is to track issues and not to discuss them, so open a new thread if you wish.

The newer changes upgrade the influxdb2 library from 4.3 to 7.0 so it is a big jump and is bound to contain some fixes in that alone, also and other libs are also changed. Best guess is that your system needs a compatibility change that is in one of those libraries whilst other users do not. Not going to try and explain or guess further as I do not use the addon.

I have a weird issue. I add via UI a new Thing MQTT generic. Then i add channels items etc. I saw that I made a mistake and I tried to edit it, but I can’t. Code nor via UI. I must delete complete the channel and add a new channel. I get this message via UI if I try to edit via UI:
But I add everything via UI. What’s going on? :slight_smile:

Upgrade to snapshot.

1 Like

Bug in JUPnP library is hopefully now fixed.
We just need now a release of JUPnP v3.0.1 and OH 4.2 switching from JUPnP 3.0.0 to 3.0.1.
I am confident you can expect the fix to be included in 4.2 milestone 2 (and probably soon in 4.2 snapshots).

This new version will also include the addition of a new JUPnP setting to restrict the network interfaces to the ones you would like JUPnP to use. For example, you could then instruct JUPnP to use only eth0 interface even you have eth0 and wlan0 being up. For that create the file <OH root>/conf/services/jupnp.cfg containing this line:


The parameter accepts a comma-separated list of network interface names.


Can’t edit and save channels in things.
After upgrading from 4.1.0M3 to 4.2.0M1 i can’t edit and save channels in things.
When truing to configure channel i see lock in upper right corner an it says “Channel of Things defined in a .things file are not editable from this screen”, but i created things from UI, not from “.things” file

Read 3 posts above yours …

Influx ping Fault seems to be gone with snapshot 4021

1 Like

On 4.2.0.M1 I’m not able to edit the code in things. More specifically, I cannot edit this in the screen:

label: Comando Leds Cave
thingTypeUID: mqtt:topic
  payloadNotAvailable: offline
  payloadAvailable: online
  transformationPattern: JSONPATH:$.state
  availabilityTopic: anexo/button-cave/availability
bridgeUID: mqtt:broker:aveiro
  - id: LinkQuality
    channelTypeUID: mqtt:number
    label: Link Quality
      unit: lqi
      min: 0
      stateTopic: anexo/button-cave
      transformationPattern: REGEX:(.*linkquality.*)∩JSONPATH:$.linkquality
      max: 255
  - id: action
    channelTypeUID: mqtt:string
    label: Action
      stateTopic: anexo/button-cave
      transformationPattern: REGEX:(.*action.*)∩JSONPATH:$.action
  - id: BatteryPercentage
    channelTypeUID: mqtt:number
    label: BatteryPercentage
      unit: "%"
      min: 0
      stateTopic: anexo/button-cave
      transformationPattern: REGEX:(.*battery.*)∩JSONPATH:$.battery
      max: 100
  - id: voltage
    channelTypeUID: mqtt:number
    label: Voltage
      stateTopic: anexo/button-cave
      transformationPattern: REGEX:(.*voltage.*)∩JSONPATH:$.voltage
      unit: mV

It’s a significant problem for me, I’m used to define mqtt things using copy/paste and this is no longer possible.

Using Firefox 124.0.2 (64-bit)

Edit: Reported in github Cannot update using the Code tab · Issue #2523 · openhab/openhab-webui · GitHub

It is known issue

As @sihui wrote

1 Like

Seems to be a different issue. I’ve installed the snapshot and the problem persists. I cannot write in the Code tab.

openHAB 4.2.0

Build #4026

Please try

openhab-cli reset-ownership

from the GNU/Linux shell.

Thanks. Is there another way ? I’m running OH in QNAP/QTS and openhab-cli does not exist.

The fallback code that is being used inside of openhab-cli is

chown -R openhab:openhab "${OPENHAB_HOME:?}" "${OPENHAB_USERDATA:?}" "${OPENHAB_CONF:?}" "${OPENHAB_LOGDIR:?}"

The variables contain the value for different directories to be taken into account.

These are the contents of my openhab folder

[/share/QPKGs/OpenHab3] # ls -la
total 216
drwxrwxrwx  9 admin administrators   4096 2024-04-05 23:23 ./
drwxrwxrwx 31 admin administrators   4096 2024-04-05 22:31 ../
drwxrwxrwx  2 admin administrators   4096 2024-01-10 18:05 addons/
drwxrwxrwx  2 admin administrators   4096 2024-02-25 13:07 backups/
-rwxrwxr-x  1 admin administrators      1 2017-11-16 17:17 build*
drwxrwxrwx 16 admin administrators   4096 2024-01-10 17:35 conf/
drwxrwxrwx 10 admin administrators   4096 2023-07-10 19:23 JDK17/
-rwxrwxr-x  1 admin administrators  13430 2023-02-13 03:38 LICENSE.TXT*
-rw-rw-rw-  1 admin administrators 114073 2023-07-26 17:52 .list
-rwxr-xr-x  1 admin administrators   1524 2024-02-25 12:50*
-rw-r--r--  1 admin administrators  10090 2016-01-15 14:57 .qpkg_icon_80.gif
-rw-r--r--  1 admin administrators   8438 2016-01-15 14:58 .qpkg_icon.gif
-rw-r--r--  1 admin administrators   8150 2016-01-15 14:58 .qpkg_icon_gray.gif
drwxr-xr-x  6 admin administrators   4096 2024-04-05 23:23 runtime/
-rwxrwxr-x  1 admin administrators    144 2023-07-25 09:54*
-rwxrwxr-x  1 admin administrators    193 2024-04-05 21:51*
drwxrwxrwx  2 admin administrators   4096 2024-04-02 09:04 .@__thumb/
-rwxr-xr-x  1 admin administrators   1027 2023-07-26 17:52*
drwxrwxrwx 15 admin administrators   4096 2024-04-05 23:26 userdata/

It has always worked like that, I’ve never cared about ownership because the process runs as admin.

CPU:  2.7% usr  1.5% sys  0.0% nic 95.3% idle  0.2% io  0.0% irq  0.1% sirq
Load average: 0.48 0.49 0.47 2/1521 15649
 3803     1 admin    S    2156m 27.3   2  1.4 /sbin/hal_daemon -f
10932  5133 admin    S     650m  8.2   0  1.1 /opt/ffmpeg/ffmpeg -rtsp_transport tcp -threads 1 -skip_frame nokey -hide_banner -i rtsp://admin:M
 5133  5037 admin    S    6047m 76.7   1  0.2 /opt/OpenHab3/JDK17/bin/java -XX:-UsePerfData -Dopenhab.home=/share/CACHEDEV3_DATA/.qpkg/OpenHab3

So I made a new install in Windows (snapshot Build #4026) and I can’t write in the Code tab either.

Edit: Build #4027 has the same problem

The channel editing seems to still be impossible on #4027, at least when restoring a config from openhab 4.2M1.
I had the same issue while modifying the code tab of an MQTT thing on openhab 4.2M1 (openhabian on a raspberry pi v3). I saved the configuration with openhab-cli backup.
I started fresh with openhabian (in order to start with bookworm) which installed 4.1.2, then I updated to openhab snapshot #4027. I restored the configuration, and I was able to edit the mqtt thing a first time.
After that, editing was still impossible. I tried cleaning-cache, removing and re-adding the thing, removing and re-adding the MQTT binding itself.
A test I have not performed yet is to completely reset openhab configuration, removing everything to see if it is related to the restore of a wrong configuration.

EDIT: I performed the last test, i.e. I created a thing in a completely fresh install of openhab on #4028, but I cannot edit the text in the code tab, once the thing is created (both for the AVM binding and the MQTT binding)

EDIT2: in Milestone 2 this issue seems to be solved. I only had to clean cache after restoring the backup from milestone 1

OpenHAB 4.2.0 Build #4028
I still can’t edit the sitemap in code mode.
Is anyone experiencing the same problems?

In my case the code tab

  1. Can be used to edit items and rules
  2. Does not accept updates in things

Build #4026

Edit: a fix has been implemented, probably will be available in the next build.

I have installed 4.2M2 and I cannot find the option to import items from text : was it removed explicitly or is it a bug?

Look at the page containing developer tools.