OpenHAB Alexa Binding reading SSML tags

  • Platform information:
    • Hardware: Linux VM / 3GB / 2 vCPU
    • OS: Ubuntu 18.06 LTS
    • Java Runtime Environment: Zulu,
    • openHAB version: 2.4.0

I have the Alexa Binding configured and everything seems to work properly. However, I tried to send a TTS with SSML tags and Alexa keep reading them instead of interpret (even the speak tag). I know that the sentences with tags are correct because i used the alexa development console and its working.
I’m using the Portuguese Brazilian language, but the problem persists even when I change to English US. Am I missing something?

Thing definition:

    Bridge amazonechocontrol:account:accountUS "Amazon Account - US" @ "Accounts" 
        Thing echo		echoMarcelo          "Alexa" @ "Bedroom" [serialNumber="xxxxxxxxx"]

Item definition:

Group Alexa_Marcelo <player>

String Echo_Marcelo_TTS		"Text to Speech"	(Alexa_Marcelo) {channel="amazonechocontrol:echo:accountUS:echoMarcelo:textToSpeech"}


rule "Alexa Routine"
      Member of AlexaRoutine received command
     Echo_Marcelo_TTS.sendCommand("<speak> Teste SSML </speak>")

When I can the rule it generates the following log:

2019-10-12 13:29:07.222 [ome.event.ItemCommandEvent] - Item 'Echo_Marcelo_TTS' received command <speak> Teste SSML</speak>

2019-10-12 13:29:07.227 [nt.ItemStatePredictedEvent] - Echo_Marcelo_TTS predicted to become <speak> Teste SSML</speak>

2019-10-12 13:29:07.239 [vent.ItemStateChangedEvent] - Echo_Marcelo_TTS changed from to <speak> Teste SSML</speak>

2019-10-12 13:29:09.900 [vent.ItemStateChangedEvent] - Echo_Marcelo_TTS changed from <speak> Teste SSML</speak> to

Your log is perfectly normal
The echo binding tts Channel is exactly that. A tts channel.
It will speak the string nothing else

Yea, but Alexa is reading the SSML tag, if i add any other tag she will read too. How can I send a string with SSML tags and she doesn’t read it as a plain text?

     Echo_Marcelo_TTS.sendCommand("<speak> Teste SSML </speak>")

You did not add any SSML speach tags inside the tag. Maybe that’s why

It’s not, already tried with more tags or just with speak, with " or just ’

Then I suggest posting an issue on gitHub

Have you found a solution? My TTS works, but when I add tags, it just says nothing.

Currently I am running 2.5.0~M5-1, but the binding behaved like this since I first tested it (a year ago I

@marc.arj could you figure this out? I just reinstalled my whole system and the issue persists (openHAB 2.5.0-1 (Release Build)).
Also I was thinking, this may be an issue with Amazon-regulations. I am running Alexa on a Sonos Beam. Any chance you are also on a non-echo device?