OpenHab Cloud Never goes online

  • Platform information:
    • Hardware: VM
    • OS: Ubuntu 20.04
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: 3.2
  • Issue of the topic: please be detailed explaining your issue
    I used to be able to access https://myopenhab.org/ but didn’t use it a lot so I don’t know when it stopped working. It is now constantly showing “OffLine”
    I have tried a number of things to get it working:
  • Made sure Secret and password were correct.
  • Delete and re-create cloud login and verified account by email
  • Made sure the cloud binding was loaded.

The logs are saying:
Shutting down openHab Cloud service connection
Cannot build sitemap page_2785e2d5b7 javaoutofboundsexception: Index 1 out of Bounds for Length 1

I used to also have Google Home interface available. This is no longer operable, I believe because the cloud is off-line. Is that correct?

I know there are a lot of issues with the cloud going up/down during the day but this is not an issue I have, I can’t get it up :frowning:

no downtime in the last 7 days

Yes

That means it did work in the past and now it is not working for some reason.

Can you ping the cloud from openhab instance

You were spot on. Thanks for that.

I hadn’t tried to access the internet from within the VM as I really had no reason. Once I read your question I tried and it failed. I removed and reconfigured the Network card for the VM and rebooted. It could then see the internet and myOpenHab could see me.

I must have taken a dumb pill earlier.

Thanks Again :slight_smile: