OpenHab Cloud Will Not Connect

Just upgraded to OpenHAB 2 and have read about the cloud service which I’d like to use.

I have the openHAB Cloud Connector installed within the PaperUI > Addons > Misc

Within PaperUI > Configuration > Services I have configured openHAB Cloud with:
Mode: Notifications & Remote Access
Items to expose to apps such as IFTTT: None
Base URL for the OpenHAB Cloud Server: account is registered, with both the UUID and secret keys populated.

My account says “offline” and the dashboard says “You are using openHAB 1.x. To remotely access your openHAB’s web interface go to

I am running OpenHABianPi (installed last week) with OpenHAB 2.

Any help would be great please.

Thank you.

All steps look quite right …

What java version are you using? You will need Oracle Java Version 101 or higher:

Check your version with:

pi@raspberrypi3:~ $ java -version
java version "1.8.0_111"
Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
Java HotSpot(TM) Client VM (build 25.111-b14, mixed mode)

In my example its 111, it should not be a lower number.

1 Like

As he has used openHABian, he should already has the latest Java I think.

“Registered” means, you also have confirmed the email you got?

Is you OH2 running on any non-standard port configurations?

Hi sihui

Thank you for replying.

My java version is the same as yours:

java version "1.8.0_111"
Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
Java HotSpot(TM) Client VM (build 25.111-b14, mixed mode)

Hi Stefan

Thank you for replying.

Please see my reply to sihui confirming that my java version is the same as theirs.

Yes I’ve confirmed my registration by clicking the link in the email that was sent to me.

OH2 is running on port 8080 (HTTPS). This was set up using NGINX with the openhabian configuration tool.

Ok, so maybe this reverse proxy is a problem here (just wild guessing…). @ThomDietrich: Do you have an idea?

I’ve got the same kind of issue with as Aaron has. I’m running OH2 and after installing the openhab cloud connector states “offline” and at the bottom it says I’m running OH 1.x

So I came across this thread and after checking my Java version it says the following:
java version "1.8.0_65"
Java ™ SE Runtime Enviroment (build 1.8.0_65-b17)
Java Hotspot™ Client VM (build 25.65-b01, mixed mode)

Now I suspect this is not a high enough version right? The “65” should be “101” instead?

I’m running Raspbian Jessie on an RPi3.
When I do
sudo apt-get update
sudo apt-get install oracle-java8-jdk
I get a message saying that I already have the lastest version.

How to I go about getting up to a higher version?


Yeah unfortunately the default repositories on rasbian have too old java.

I use the following in my raspbian ansible setup:

echo "deb wily main" | tee /etc/apt/sources.list.d/webupd8team-java.list
echo "deb-src wily main" | tee -a /etc/apt/sources.list.d/webupd8team-java.list
apt-key adv --keyserver hkp:// --recv-keys EEA14886
apt-get update
echo debconf shared/accepted-oracle-license-v1-1 select true |  sudo debconf-set-selections 
echo debconf shared/accepted-oracle-license-v1-1 seen true | sudo debconf-set-selections
apt-get install -y oracle-java8-installer

The commands automatically accept the Oracle license which makes it suitable for unattended installation. The package comes from third party Ubuntu PPA that should be compatible raspbian Jessie.

You should probably remove the existing java8 before installing the new one.


Oh thank you so much! I Will give this a try today, so looking forward to follow my home solution when away from the house. :slight_smile:


I got everything installed by following your commands listed above. And the is now online and working! hurray! :slight_smile:

I removed the old java first as you suggested as well. So now java -version i showing me that I got java 8 with 111 :slight_smile:

Thanks again!


Glad that Erik’s problem is resolved.

Any further ideas as to why I might still be having a problem?


The only difference you have is NGINX.
I guess now you have to find someone who is familiar with that …:innocent:

Or I could remove it and test? How do I safely remove it?

If you’ve installed it through openHABian, there may be also an uninstall option (don’t know, have never used openHABian)., otherwise try

Thank you. This has removed it successfully.

Still no connection, even with firewall off and port forwarding on etc.

Got it connected! :slight_smile:


How did you finally get it going? It’s always nice to hear HOW it worked out, not only THAT it works now…

After getting rid of nginx it still showed offline.

I visited myopenhab, deleted my account, created my account again. Still
showed offline.

I rebooted, logged out of my account, logged back in and it said online.

Its been online for a few hours now, and I briefly saw my full dashboard.

I’ve just been back online and find that after clicking the link to view
the dashboard it times out. 504 Gateway Timeout.

I also notice that without some decent network security (eg https) or
virtual webserver presentation on the local side, using myopenhab/openhab
cloud presents a security risk to your openhab device/network. If you are
going to use these online services, make sure not to leave yourself
exposed. I’m sure that’s common sense to most.

I am facing the same issue, difference being that I am using Apache2 (SSL enabled) for reverse proxy purposes. I tried Nginx for testing (using the configuration suggested in the Getting Started guide) with the same result.

In both instances, the cloud connector drops the connection, according to the log.

When I bypass the reverse proxy (using http://my-openhab-cloud:3000), openHab establishes the connection and openHab cloud shows openHab as “online”.

It also works ok with, so obviously, the issue must be with the reverse proxy configuration. I certainly do not want to use an unsecured connection on port 3000 for anything else than testing, so any suggestions on how to fix it or work around the issue is highly appreciated :slight_smile:


openHABian is known to be working with Nginx, maybe you can “sniff around” in the conf files on github to find out how it is configured.