openHAB connection error: Connection refused


I have installed OpenHAB 1.8.3 on my Synology DS413j, which installed fine with no issues. I even managed to view the demo files on both browser and iPhone, including creating the symbolic links for the addons and configurations folders.

However since following the instructions to set up MyOpenHAB, I seem to have come unstuck with the following error when trying to browse to

openHAB connection error: Connection refused

I have set up the openhab.cfg file to include the following:

The public/OpenHAB folder on my NAS has the correct permissions for the OpenHAB daemon user set up.

When I took a look at the openhab.log file, I noticed the localhost value as follows:

13:16:33.658 [INFO ] [.myopenhab.internal.MyOHClient:224 ] - Connected to my.openHAB service (UUID = , local base URL = http://localhost:8080)

Given that my OpenHAB is running on my Synology NAS, localhost is clearly wrong and so is the port. Would I be right in thinking this is the cause? If so, has anyone come across this at all and more importantly fixed it.



Actually under normal circumstances localhost:8080 (unless you changed the default port) is correct. The my.openhab binding acts as a proxy between and your openHAB’s REST (i.e. HTTP) API. The binding actually makes the same calls to openHAB as your Sitemap does, only because it is a binding it knows it is on the same host that openHAB is running on. This is why you need to set security to EXTERNAL; the binding can’t supply a username and password to the REST API.

However, you are using the localport option so it should be connecting to localhost:8081. So I’ve no idea what is going wrong but suspect that is a problem.

Hi Rich

Thanks for the reply. I will reset the port back to 8080, retry it and report back in due course.



I reset,, and the openhab.cfg files to use port 8080 but still no joy.

Any ideas anyone? Has anyone had v1.8.3 working off a Synology NAS and using myOpenHAB as well?

Today I tested OpenHAB2 (online and offline version). Until I saw the initial web page it took up to 15 minutes running on a pi3