Openhab Connector 1.15 - Z Way

Z Way App - Openhab Connector 1.15.
Is there any way of getting the original Openhab Connector version 1.15 for Z-Way.me?
I’ve been running Openhab with the Z Way binding for about 3 years. It’s not perfect but it works. I never got the Openhab Connector 1.18 to work well, but found 1.15 did.
I’ve had to rebuild my Openhab, and now can’t get my Z Wave network to work as well as it used to.
I have had to move to the Z Wave binding, as many will know why. The latency is really bad, with some devices just not as good as they used to be. I’ve added more mains powered devices but still no better.
So I want to go back to Z Way binding, but need the Openhab Connector version 1.15.
Anyone know where I can get my hands on that version?

Which is absolutely not what most other users are seeing. Most likely you used an older OH version where network heal was broken and you activated that, corrupting your network routing.

Z-Way binding never has been supported well, I even believe it’s not maintained any more.

For these reasons, I’d strongly suggest you put your energy into getting your network to work with the ZWave binding instead of looking back at ZWay, with one exception:
ZWay is a great tool to heal your current network. Execute that from the ZWay GUI (which is what you have to do anyway). Be aware that this can be a lengthy process and you might need to initiate several runs.
Once you have a healed network, backup the network, i.e. the controller config from within ZWay.
Then upgrade to latest OH (2.5.2) if you have not done that so far, and start OH.
If you have properly healed your network before, it should come up working.

If you want to be on the safe side for the time being, disable network heal in habmin/PaperUI (it’s a property of the ZWave controller thing).

PS I moved your post as it’s not a development related question

Thanks for the feedback Markus.
I feel I need to start from scratch. The reason I got to where I am was in moving to 2.5. (That and Z-Way.me butchering all the apps)

Can you point me to the JSON.db files to restore only things and items?

I think my Openhab backup is a little messed up as Openhab failed to start properly if I clear the cache.
I want to build a clean install restoring only my paper UI things and items. I know where the Habpanel and /etc/openhab2 stuff is stored etc.

/var/lib/openhab2/jsondb/org.eclipse.smarthome.core.thing.Thing.json
You can edit it manually (with OH down) if needed, but mind not to break the syntax.

I doubt that’s the reason for OH not starting. It’s never wrong to start from scratch but be prepared you might hit the issue again when you “finished” as it might in fact still be unresolved.

Myself and others have reported issues after clearing the cache and needing two restarts of OH to get things to start prooperly. There have also been people reporting that OH is restarting itself after recent updates, which causes zwave to stay very sluggish. There are issues in GH for both of these. So, you may be experiencing some of the issues that others have been reporting.

So. Rebuilt everything. From ZWay network and network routing to openhab. Latency is still the same. It is just so slow. However, when running in ZWay, it works instantly. I’m now on OH 2.5.2, and it is not better. There are lots of issues that need resolving with 2.5.2 as well.
I might revert to two controllers with Zway on a separate machine, and OH connected through the Z Way binding.
The current ZWave binding with a Razberry is just too slow. I know it can work, as it did when I had the Z Way binding and the Openhab Connector 1.15. Now that is gone, and I just need to find another solution. Standing around for 15 seconds for devices to be triggered just isn’t what I am looking for.

No it is almost certainly not the binding. It is the routing. I believe you didn’t fully fix that while in ZWay.
If you don’t believe that, get a debug log from the ZWave binding to show all lines/messages that belong to a specific slow action (such as to switch on a particular light), visualize it using @chrislog viewer and post it here so we can dissect it.
IMHO you cannot get happy as long as you keep leeching on to ZWay binding.

Hi. Thanks for the advice.
So far, I’ve managed to run a Z Wave network for a few years without the need to seek help on the forum. I have now poured 10’s of hours into trying to get this to work with the Z Wave binding, and have now concluded that the ROI is just not worth it. As I now can’t get back to my known good working solution with the Openhab Connector 1.15, and moving forward requires further time investment, I am abandoning my Openhab project. It is a real shame, as I have invested significant time and money up till this point. However, I can’t justify devoting more time into it, to keep yielding the same poor results. It’s just not worth it.
Good luck with future Openhab developments. I hope that the community continues to flourish, as I believe this concept has strong potential. For me, the out-of-the box experience & implementation needs to be more robust and simpler.

And I poured hundreds, likely more. So what? Annoying, sure, but that’s what it takes, and remember if you move elsewhere you’ll lose the investment.
Please don’t make the mistake to believe it will be different with some other software but worse as with that one you’ll have to start from scratch again.
It’s inherent to the technology. Out-of-the-box home automation will never work.
You have not told us what HW,OS and most important OH version you run and which one you ran before.
If I was to guess it’s something old and the upgrade to 2.5.2 is a big jump to come with another set of potential quirks such as e.g. the need to recreate all ZWave things.
Comprehensively describe the state of your system and your current problem (debug logs !), and we’ll try to help you get outta there.
Many many people successfully run ZWave networks with the OH ZWave binding, I’m sure we get yours to work.

So, my OH journey begun with a Raspberry Pi 3 shortly after they launched. I ran OH 2.0 on jessie and an SSD. I started small, verifying that this was the way to go before purchasing lots of nodes, as they are expensive. Proved out on two nodes, to verify the time needed and ROI.
It worked pretty much out-of-box. My time was spent writing code for the things I wanted the system to do for me, not debugging where it has gone wrong.
I moved through up to OH 2.1 and then onto stretch. It was around OH 2.2 that the Openhab Connector went to version 1.18. I tried it but the refresh rate was poor and not as good as 1.15. Back then you could rebuild from backup in around 15 minutes, which enabled testing out things.
I skipped OH 2.3 following the issues with Z Way Binding that many suffered, and OH move over to Z Wave binding. I managed to get it all working again with OH 2.4, following Wire 83 I think who got the Z way binding working again. I tried the Z wave binding. It wasn’t anywhere near as good. Typically I would rebuild once every 6 months to keep it up-to-date. My last rebuild was back in June of last year.
Coming to January this year. OH 2.5 is out. I am migrating other machines onto Buster. My Z way network was getting a little slow, and due for a rebuild. Z way have changed how they approve apps. Openhab Connector is no longer available. Only 1.18 on Patrick’s Github.
There are suggestions that OH 2.5 works better now with Z wave, there is also better integration with Alexa. Good. I have some of my devices working with Alexa on 2.4.
Upgrade to Buster and OH 2.5. OH doesn’t work.
Thermostats don’t work with Alexa. I managed to get a switch to connect, but not a thermostat. Not had any time to to figure that out, because my Z wave network has massive latency which I have been trying to fix.
Then all of a sudden other things stop working. Clearing the cache, means OH fails to start. You have to urge and install, and restore. The exec commands fail to work. Thanks to the work on the forum you find you have to run a workaround with the whitelist because that doesn’t work properly. Still no Z Wave.
As a test. I have Z Way running. I have programmed in my rules for my Z wave network. Lights now turn on when triggered by a PIR sensor. No latency, so not the network?
I would be very happy back at OH 2.4, with Openhab Connector 1.15.
Do you know if Patrick can put it up on his Git page?

I don’t know who “Patrick” is, as indicated using ZWay is really way off mainstream so very little people know it let alone can help with debugging. I haven’t even heard of that “connector” before your post (and as you might know I am very active on the community and thus have a good overview).
That fact (Zway being used by VERY few) is the primary driver why I’d like you to move to ZWave binding instead that many many people happily use. So it cannot be all that broken.
I know it’s annoying to have OH with ZWave binding in that sort of half-baked state you need it to test and debug, but you can switch between ZWay and ZWave, even without restarting OH, just by stopping/starting the right binding (and items file to reference channels … you might even try to link Zwave items to two channels each, a ZWay and a ZWave one, as only one of them will ever be active).

I can only renew my offer to have a look after your issues but we need you to take and upload debug logs else we have no starting point. And frankly, you should have done that much earlier.

Hello Markus,

I have some partial success.

I ‘factory reset’ all my Z wave devices and rebuilt the network from scratch in Z Way.

I then rebuilt that network in Openhab. The latency is slightly improved and a noticeable improvement.

I hope it continues to perform, without degradation over time. We will see.

There are still a few issues, which should be resolvable.

Many thanks for your patience and support. It is much appreciated.

Thank you.

To play it safe, make sure a) you have made a backup of the controller in ZWay and b) disabled nightly network heal with the ZWave binding (it’s a property of the controller thing). b) used to screw a number of people’s network. There were recent fixes but it’s not yet confirmed to be working fine now.

Thanks Markus.

I have made a backup. I think it was my old backup that could have caused my issues.

The problem may have come from the recent z way update to 3.8, and some conflicts with my devices. IDK.

But factory resetting of the Razberry and my nodes seems to have improved things.

I have disabled Network Heal in OH.

All good so far.