openHAB Designer doesn't recognize Joda Time

I’m running OpenHAB Designer version 1.8.2 on MacBook Pro running OSX 10.10.5. I’ve had the hardest time doing anything meaningful with dates. I basically want to see if one DateTime item is before or after now. I’ve been digging through the forums and everyone says to import org.joda.time.*. I’m an experience Java developer and have read through all of the JavaDocs for Joda and the Designer (and openHAB server) act like they don’t see it. I keep getting “Couldn’t resolve reference to JvmIdentifiableElement” everytime I want to use a Joda object, even for the simplest implementation. From what I’ve read it should already be in there somewhere. I’ve tried adding it again to the project. I’ve even tried full paths to the objects to avoid name conflicts. Has anyone ran into this?


i had issues. Download eclipse smarthome designer and shall work. Mine is working now.

Thanks for the tip. I didn’t know there was an OpenHAB 2 also. I think I’ll upgrade everything and use Eclipse Smarthome and see how it goes.