Openhab-designer not showing up

RPi 3
Raspbian 4.4.13
Openhab-designer 1.8.3 32bit

I have the server up and running with the demo sitemap, but cannot get designer to even show up. I followed the steps perfectly, but nothing happens when I click execute. I deleted all files and reloaded with the same result.

What might I be doing wrong?

Try running it from the command prompt to see what errors are printed when it tries to start.

I find I have to run it with sudo because when I’m running Designer I’m running it as me but openHAB sets the permissions on the files to openhab:openhab and I don’t have permission to write to them.

openHAB sets permissions actively? I don’t think so!? Executing the Designer with sudo shouldn’t be promoted. Can you add yourself to group openhab or change the group to yours? I actually don’t think openHAB needs write permission on the configuration itself…

It does, or really the script /usr/share/openhab/bin/ which gets called by the daemon start script does. (NOTE: this is for OH 1.x) I had an issue with is a while back as it was changing the permissions on all openhab related files, including those in ~openhab. I had some execs that sshed to another machine and the script was adding group read permissions to ~openhab/.ssh/*. Of course ssh doesn’t like it when your private key is group readable. Here is the original thread:

I’m not sure if this is still done by OH 2. Because I’m running in docker the user/group ids are all messed up for me right now anyway (see my Docker tutorial for details). I don’t see a script in the openhab folder on the docker image so either it is no longer done or done some other way. Can’t run an experiment right now to test for sure.

Nope. changes ownership to openhab:openhab and applies read only permissions to the group. So neither approaches would work.

I agree, running designer as sudo isn’t really a good solution. I should add that I use sudo to run designer as the openhab user, not root:

sudo -u openhab /opt/openhab-designer-1.8.0/openHAB-Designer

This also poses a problem for those who try to put shell scripts to be called by the exec binding in configurations/scripts as will strip the execute permissions off those files as well. A more appropriate spot would be ~openhab/scripts which I believe no longer gets touched by that script.

As I wrote my earlier comment it got me to thinking that at a minimum the group should have write permissions too so all we have to do is add the user to the openhab group and everything is fine. But I need to straighten out docker user id problem before I can do the research to see what is happening with OH 2 and whether this is still a problem. I do know that I have to run OH 2’s Designer as root right now, but I think that is more related to my Docker problems.

Here are the results, with the directory listing to show permissions;

pi@raspberrypi:/opt/openhab-designer $ ls -aol
total 508
drwxr-xr-x 8 root 4096 Sep 27 21:49 .
drwxr-xr-x 9 root 4096 Sep 27 21:49 …
drwxr-xr-x 2 root 4096 May 22 21:42 addons
-rw-r–r-- 1 root 85642 May 22 21:41 artifacts.xml
drwxrwxrwx 5 root 4096 May 22 21:44 configuration
-rw-r–r-- 1 root 60 Feb 4 2013 .eclipseproduct
-rw-r–r-- 1 root 15551 Aug 21 2012 epl-v10.html
drwxrwxrwx 25 root 4096 May 22 21:24 features
-rwxr-xr-x 1 root 266168 May 22 21:41
-rw-r–r-- 1 root 9229 Aug 21 2012 notice.html
-rwxr-xr-x 1 root 63050 May 22 21:41 openHAB-Designer
-rw-r–r-- 1 root 283 May 22 21:42 openHAB-Designer.ini
drwxrwxrwx 4 root 4096 May 22 21:44 p2
drwxrwxrwx 12 root 36864 May 22 21:44 plugins
drwxrwxrwx 2 root 4096 May 22 21:44 readme

pi@raspberrypi:/opt/openhab-designer $ sudo ./openHAB-Designer
./openHAB-Designer: 1: ./openHAB-Designer: Syntax error: “(” unexpected

pi@raspberrypi:/opt/openhab-designer $ ./openHAB-Designer
bash: ./openHAB-Designer: cannot execute binary file: Exec format error

The permissions that matter and that we are talking about are those in the configurations folders, not Designer’s folders.

However, that doesn’t matter because the errors you are seeing makes me realize that the Designer downloads on the site do not support ARM and wont run on the Pi.

This raises a good questions. @kai, @ThomDietrich do either of you know or can point us to someone who does know: is there a build of Designer for ARM?

Now what most people do is put their configs in a samba share and run Designer from a separate machine.

Ok, since my workstation is Ubuntu, I tried a few searches here on how to reach into the RPi from Designer on my workstation, but no success. Did I miss something?

Some links I found;!msg/openhab/_zAGnIK8CJg/ZFnxnqNBtgIJ

P.S. I do like how this site is organized, and if the dropdown for tags were alphabetical or subgrouped, it would be even better.

Set up samba on the pi

Share the configurations folder via a samba share

Mount the samba share on your Ubuntu workstation

If you search for “samba” on this forum I believe you will find several threads where this is talked about.

If I remember correctly, openHABian come with samba preconfigured, though that runs OH 2, not OH 1.8.

No, there isn’t and never will be. The Designer is a desktop application and as such it isn’t meant to be run on a (usually headless) SBC and it is far to big for it as well.

1 Like

Ok, followed rikoshak’s advice and after some Samba 101 lesson learning have it all set up and running. Thanks rikoshak!

I sped up the Ubuntu mounting by using Smb4K.

I think it would be helpful to have the necessary steps and lessons learned in the set up guide. How can I help by adding that?

Hey Will,
help is always welcome. Can you tell us which details you are missing in the related docs article:

You could create a Pull Request or Issue here:
However, of you were not familiar with Github, do not hesitate to write and post an additional paragraph or similar here as an answer and I’ll be sure to include it.

Thanks Thom!

I had looked at the 1.8 installation guide, which did not have the Samba instructions.

On a related note, do you have any insights on another question I have?