Openhab dual boot install works fine but access denied for port 9001(logs) and samba to windows

Tags: #<Tag:0x00007f616f16f5d0>

I’ve installed openhabian a few times on a Raspberry pi with great succes. On a desktop computer I was able to make all the necessary connections like Samba and putty. After having to discover that every night the Pi seemed to lose connection (or interest) and while being active the next morning My set-up with an ESP32 wasn’t connected anymore and I had to reset the lot to get it working again. So I decided to make a new install but now as a dual boot on a laptop. Easy peace of cake. Works fine and fast but and there is always a but, looking into the log-files is denied and the samba connection when asking for the password are denied. Putty works though but Remote Desktop Connection is denied. Tried a lot to no avail. The windows desktop computer is the same I used with the raspberry pi and the dual is installed with ubuntu first and openhabian secondly.

openHABian image only installs on Raspberry Pi and similar. You tagged this thread openHAB. openHABian is quite different in many ways.

Didn’t know that. Sorry, I really am. The description about installing both is on the same web page. What do I have to do to make it right? Secondly I would make a remark here that I can’t see any difference between the two methods in the result of the installation.

I installed openhabian with the sudo commands and not from an image. Does that make a difference?

What OS?
Ubuntu is one boot, what is the other one with openHABian?

I hope I haven’t done anything wrong Bruce. After the problems with the Pi I just wanted to make a different set-up by using a laptop with Windows on it. So I had to make it a dual boot system with Ubuntu. Then I started to install openhabian. So the laptop starts up with Ubuntu and Raspbian starts some time later I think.Don’t know but it is working fine accept for the few issues with the connections.

That’s pretty nonsense. A Linux partition is either Ubuntu or Raspbian, and since Raspbian works on RPi only, it must be Ubuntu (only).
Did you mean to say you have installed openHABian on Ubuntu ?

1 Like

Let’s back up. openHAB is supposed to be always on and running so it doesn’t make much sense to have it running in a dual boot configuration.

Next, it’s way easier to manage VMs than dual booting so if you really want to run openHAB on this laptop in a Linux environment, use a VM instead of dual booting. Even, better, I’m about 90% certain that openHAB would install and run the Linux version under the Windows Subsystem for Linux. The manual install of openHABian might even work there (it’d be interesting to try).

In all likelihood, the root problem with the RPi is a bad power supply. Did you try and alternative and/or hook it up to a meter to see if it’s generating enough power? And if it’s going to be a problem to have the RPi offline, I’m not sure how having it offline when booted into Windows is going to be any more acceptable.

Regardless, you need to supply the exact steps you took to get this set up because your original description and replied don’t make a whole lot of sense.

For example, you have to go out of your way to set up Remote Desktop on an RPi, and it is usually VNC, not RDP (i.e. you need to use a different program to access it). And depending on what OS you actually installed, there may not even be a desktop.

You’ve provided no details on how SAMBA was installed and configured.

1 Like

Yes Markus. The laptop is installed dual boot. So when I run Ubuntu it boots up in ubuntu and Windows is not in the picture at all.

Thats a lot to answer Rich and I will do my best. First of all about the Remote Desktop Connection in Windows. I have done several set-up on a raspberry pi 3B and some with Rasbian and some only with openhabian. I always could get it right. Everything was working and with the set-up based on Rasbian I used the Remote Desktop as well. The reason I wanted to use a laptop with Ubuntu was to see if the problem I had with the Raspberry pi about ending the connection with an ESP32 (for testing), would occur on the laptop as well. But now running under Ubuntu I get errors as connection denied in Samba and the Remote Desktop doesn’t work. About Samba, the installation came with openhabian and the connection is being made. I can see the maps in the file explorer in Windows 10 but when I try to open them and type in my Pass Word I get as a response that the connection access is denied.

Sorry I did forget about your remark of the powersupply. I used a 7 Amp 12 Volt power supply with a step down regulater to 5.1 Volt and never got a lightning bolt in the screen.

Kind of a side topic, but what was the current rating for this regulator?

12 Amp. :innocent:

1 Like

Did you have a look into the Ubuntu systems log files to check if there is additional information about the reasons why the connection is refused ? Dependent on the configuration of the syslog service there are a collection of different/separated log files ( /var/log/messages /var/log/syslog /var/log/samba/smb.log ). What do they show ?
With regard to port 9001 is the port in listening mode ( execute the command: sudo netstat -tulpe ) ?
Do you run any firewall on your system ?

What about your Pi system - did you do any logfile analysis on that system ?