Openhab image on raspberry pi 2 or 3

I trying to install the image of openhab on raspberry pi 2 and then 3 what it does after some of the install it comes up with a bank screen I try 2 sd card 2 raspberry pis 2 and 3 and change the elf to a new one but still did

as anybody fix it is so can you send me a Guide because I would like to do the handsfree way

I use it before on Mac with commds but I want to do it with the image is there something wrong with their images 1.14 and should it be on a bank screen and it says when you unplug it after that blank screen initial setup exiting with an error

can you please help with this

from Oliver have you tried following this guide?

that what i did i still need help

When installing the openhabian image on a RPI it is intended to run headless. Meaning that you will not have a HDMI output to view on a screen.
This setup is for using as a sever and connecting via ssh or samba share for configuration.

EDIT: After the install (15 or so minutes) check your router for the I.P. address, then connect via ssh.

i try that but it did with ssh and did work but show that error do i need to flash a 5 time to see wait happed can you unplug it after setup i still need help on the pi 2 why do get time out serial

after setup does it show annoying on hdmi

After the download is complete there will nothing on the HDMI output.
Download the openahbain Image and flash to the SD card using Etcher. Put SD card in Pi, power up, and wait 15 or maybe 30 minutes(dependes on down load speed) do not unplug the power unless you are sure the download didn’t work.

What error are you seeing?

If it’s your only option. Just know it’s never not good for the SD card when removing power without doing a proper shutdown.

can i shut it dow and unplug it when the setup done on shh

will it should anything on cdmi after setup

NO, you will not be able to use the HDMI port…that’s what is meant by running headless…NO screen to view via direct access.

Yes after you access the Pi via SSH you can shut OH down using $sudo systemctl stop openhab2
Then $sudo shutdown

if i unplug after install will it still work

Yes, it should.
You can verify the install by typing the I.P. address of the Pi with the port 8080 from a web browser.
Example: My local I.P. for my Pi running OH is so I type this in the browser with the port number like this…

its doing in ssh now wen will i know it done can i resize the card

I believe that openhabian takes care of resizing. You can type $sudo openhabian-config from the terminal and view a list of tools available to use.
The only thing now is to open a web browser and take a look around. If you ssh into the Pi then you have the IP address.

and it does do it on screen as well the setup

Not sure I understand what you mean.

its saids installing basic cannot be wrong packages screen vim

i will come back if i need more help

after install do i need to do this Package Installation

Add the repository key
wget -qO - ‘’ | sudo apt-key add -
Add the HTTPS transport for APT
sudo apt-get install apt-transport-https
Add the repository
echo ‘deb stable main’ | sudo tee /etc/apt/sources.list.d/openhab2.list
Update the package lists and install the openHAB distribution package
sudo apt-get update && sudo apt-get install openhab2
(Optional) Install the add-ons for offline use
🛈 You don’t need the add-ons package if your machine has Internet access, openHAB will download add-ons online as necessary.
sudo apt-get install openhab2-addons

I have to disagree with one statement above. I use the openhabian install on my pi. The hdmi output does function well as long as a keyboard is plugged in. I have not tried otherwise.

The first few times I did not realize I could install headless so I flashed the card and watched for errors over hdmi.

You can access the terminal after OH is installed?

I installed the openhabian image on my RPI and observed the following.

The HDMI works and you can watch the download. After the download is complete and OH is installed the screen turns black and access to OH was only via SSH or samba.

I got this now I did unplug it after setup but that should do this
2018-09-28 12:59:43,507: FireMotD: Info: No FireMotD ExportFile detected. Please generate with “sudo .\FireMotD -S”