Openhab keeps refreshing one of my item files in linux but not in windows

I have 3 openhab installations on 3 different raspberry pi’s. On one of these, openhab keeps refreshing one of the item files. openhab doesn’t do this with other item files. If I run openhab under windows with the same items file, it doesn’t refresh it. I can’t visually detect any difference between the item file which misbehaves and those that do not isbehave. I suspected a dodgy cr/lf character but I re-entered the item file in vi on the pi and it still perpetually refreshes the item file) although the items themselves continue to operate correctly. I can’t seem to get to the bottom of this.
Has anyone ever seen this and/or have any other suggestions.
Thanks in advance

Looks like I have solved it - it was something to do with a dodgy end of line char - I would have deleted this post if I could see a delete option. Sorry about that.

I always believe it’s better to keep the topic with the solution posted so that it may help other people in future.