Openhab kiosk Autostart

Hello guys,

i’m a totaly beginner in working with Raspberry Pi and openHab and did build the following project:

I did build a weatherstation to check my inroom temperature and so on. Everything is working right now, except the output to my display
I’m trying do autostart the Basic UI - Website.
I followed a tutorial for this but its not working.

First of all they said I have to edit this file:

sudo nano /home/openhabian/.config/lxsession/LXDE-pi/autostart

but it doesn’t exist, so I started to find out why this file does not exist for me.
After a few minutes I found this comment:

sudo nano /etc/xdg/lxsession/LXDE-pi/autostart

So i opened this file and edited it with the following code:

@xset s noblank
@xset s off
@xset -dpms 
@sudo chmod a+rw /dev/i2c-*
@/usr/bin/chromium-browser --kiosk --disable-restore-session-state http://http://openhabianpi:8080/basicui/app?sitemap=weatherstationtemap=weatherstation

My Pi now is starts the Browser but shows up with an error that it can’t reach the website.

So what am I doing wrong?

My setup:
Raspberry Pi 3 b+
Raspberry Pi 7-Inch Touch Screen Display
openHabian v1.4.1

I installed the following packages for my display:

sudo apt-get install --no-install-recommends xserver-xorg --yes
sudo apt-get install --no-install-recommends xinit --yes
sudo apt-get install raspberrypi-ui-mods --yes
sudo apt-get install chromium-browser --yes

greetings and have a nice day!

Try using your OH server IP instead of the host name e.g.

do you mean:

@/usr/bin/chromium-browser --kiosk --disable-restore-session-state http://


What may be happening is that chromium starts and tries to open the page when openHAB has not finished starting yet…

but when I try to reload the page by clicking “reload” on my touchscreen, nothing happens. so i dont think it would be a problem or am I wrong?

How long after?
Running a graphical OS AND openHAB on a raspberry PI is optimistic.
Graphical OSs are VERY hungry on resources and your little computer might be struggling to manage to load

right after I can connect to the Basic UI on my PC

This is incorrect

Try: or

Only ONE http:// is the local computer.

Doesnt work :confused: